Skip Menu |
 

This queue is for tickets about the Module-Build CPAN distribution.

Report information
The Basics
Id: 79046
Status: resolved
Priority: 0/
Queue: Module-Build

People
Owner: Nobody in particular
Requestors: eparejatobes [...] ohnosequences.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: 0.4002 - test fail
Date: Fri, 17 Aug 2012 15:25:39 +0200
To: bug-Module-Build [...] rt.cpan.org
From: Eduardo Pareja-Tobes <eparejatobes [...] ohnosequences.com>
Download (untitled) / with headers
text/plain 538b
two metadata tests fail, relevant output: t/metadata.t ................... 27/53 # Failed test ' with conflicting versions reported' # at t/metadata.t line 278. # '' # doesn't match '(?-xism:already declared)' t/metadata.t ................... 29/53 # Failed test ' with conflicting versions reported' # at t/metadata.t line 297. # '' # doesn't match '(?-xism:already declared)' perl -v yields This is perl, v5.10.1 (*) built for x86_64-linux-thread-multi -- Eduardo Pareja Tobes
Download (untitled) / with headers
text/plain 700b
On Fri Aug 17 09:26:09 2012, eparejatobes@ohnosequences.com wrote: Show quoted text
> two metadata tests fail, relevant output: > > t/metadata.t ................... 27/53 > # Failed test ' with conflicting versions reported' > # at t/metadata.t line 278. > # '' > # doesn't match '(?-xism:already declared)' > t/metadata.t ................... 29/53 > # Failed test ' with conflicting versions reported' > # at t/metadata.t line 297. > # '' > # doesn't match '(?-xism:already declared)' > > > perl -v yields > > This is perl, v5.10.1 (*) built for x86_64-linux-thread-multi
Thank you for your bug report. What version of Module::Metadata are you using? Leon
Subject: Re: [rt.cpan.org #79046] 0.4002 - test fail
Date: Fri, 17 Aug 2012 16:46:35 +0200
To: bug-Module-Build [...] rt.cpan.org
From: Eduardo Pareja-Tobes <eparejatobes [...] ohnosequences.com>
thanks for taking a look at this :) version 1.000011 perl -MModule::Metadata\ 10000 Module::Metadata version 10000 required--this is only version 1.000011. On Fri, Aug 17, 2012 at 4:30 PM, Leon Timmermans via RT < bug-Module-Build@rt.cpan.org> wrote: Show quoted text
> <URL: https://rt.cpan.org/Ticket/Display.html?id=79046 > > > On Fri Aug 17 09:26:09 2012, eparejatobes@ohnosequences.com wrote:
> > two metadata tests fail, relevant output: > > > > t/metadata.t ................... 27/53 > > # Failed test ' with conflicting versions reported' > > # at t/metadata.t line 278. > > # '' > > # doesn't match '(?-xism:already declared)' > > t/metadata.t ................... 29/53 > > # Failed test ' with conflicting versions reported' > > # at t/metadata.t line 297. > > # '' > > # doesn't match '(?-xism:already declared)' > > > > > > perl -v yields > > > > This is perl, v5.10.1 (*) built for x86_64-linux-thread-multi
> > Thank you for your bug report. > > What version of Module::Metadata are you using? > > Leon >
Download (untitled) / with headers
text/plain 854b
This test is a holdover from when Module::Build checked metadata for the modules it works with. As this functionality has been abstracted into Module::Metadata, this test should be removed. As for why it's actually failing, I recently removed those spurious warnings from Module::Metadata. They check for whether the module uses the '$VERSION = eval $VERSION' syntax. This is undesirable for a general purpose metadata reader, as in my use case it was spewing many lines about modules unrelated to what I was doing, modules I don't develop myself. I saw no reason for a developer to see those warnings for code they don't own. These tests should be excised from Module::Build and not carried over to Module::Metadata except if Module::Build wants stringent $VERSION checking and support to optionally warn on that is added to Module::Metadata.
Download (untitled) / with headers
text/plain 1.3k
On Fri Aug 17 11:17:07 2012, APEIRON wrote: Show quoted text
> This test is a holdover from when Module::Build checked metadata for > the modules it > works with. As this functionality has been abstracted into > Module::Metadata, this test > should be removed. > > As for why it's actually failing, I recently removed those spurious > warnings from > Module::Metadata. They check for whether the module uses the '$VERSION > = eval > $VERSION' syntax. This is undesirable for a general purpose metadata > reader, as in my > use case it was spewing many lines about modules unrelated to what I > was doing, > modules I don't develop myself. I saw no reason for a developer to see > those warnings > for code they don't own. > > These tests should be excised from Module::Build and not carried over > to > Module::Metadata except if Module::Build wants stringent $VERSION > checking and > support to optionally warn on that is added to Module::Metadata.
I've just encountered the same test failure while looking at upgrading bleadperl to Module-Metadata 1.000011, so I'll have to hold off doing that until we have a new Module-Build released with these tests removed as suggested (or some other solution is found). (Alternatively, if you're sure you will indeed simply delete these tests from a future Module-Build release than I could edit the test script in bleadperl for now and let CPAN catch up later...)
Download (untitled) / with headers
text/plain 324b
On Fri Aug 17 15:10:04 2012, SHAY wrote: Show quoted text
> (Alternatively, if you're sure you will indeed simply delete these tests > from a future Module-Build release than I could edit the test script in > bleadperl for now and let CPAN catch up later...)
The attached patch gets bleadperl working with Module-Metadata-1.000011 in place.
Subject: metadata.patch
Download metadata.patch
text/x-diff 1k
diff --git a/cpan/Module-Build/t/metadata.t b/cpan/Module-Build/t/metadata.t index fac5999..f9ce95e 100644 --- a/cpan/Module-Build/t/metadata.t +++ b/cpan/Module-Build/t/metadata.t @@ -2,7 +2,7 @@ use strict; use lib 't/lib'; -use MBTest tests => 53; +use MBTest tests => 51; blib_load('Module::Build'); blib_load('Module::Build::ConfigData'); @@ -275,7 +275,6 @@ $err = stderr_of( sub { $provides = $mb->find_dist_packages } ); is_deeply($provides, {'Simple' => { file => $simple_file, version => '1.23' }}); # XXX should be 2.34? -like( $err, qr/already declared/, ' with conflicting versions reported' ); # (Same as above three cases except with no corresponding package) @@ -294,7 +293,6 @@ $err = stderr_of( sub { $provides = $mb->find_dist_packages } ); is_deeply($provides, {'Foo' => { file => $simple_file, version => '1.23' }}); # XXX should be 2.34? -like( $err, qr/already declared/, ' with conflicting versions reported' ); # Missing version should not show up in provides as version "0"
Download (untitled) / with headers
text/plain 417b
On Fri Aug 17 15:15:09 2012, SHAY wrote: Show quoted text
> On Fri Aug 17 15:10:04 2012, SHAY wrote:
> > (Alternatively, if you're sure you will indeed simply delete these tests > > from a future Module-Build release than I could edit the test script in > > bleadperl for now and let CPAN catch up later...)
> > The attached patch gets bleadperl working with Module-Metadata-1.000011 > in place.
This is resolved in 0.4003 :-) Leon


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.