Skip Menu |
 

This queue is for tickets about the Imager CPAN distribution.

Report information
The Basics
Id: 79029
Status: resolved
Priority: 40/
Queue: Imager

People
Owner: Nobody in particular
Requestors: TONYC [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Important
Broken in: (no value)
Fixed in: (no value)



Subject: giflib 5.0 support
Add support for giflib 5.0. Some function signatures changed to improve thread safety.
May I ask how far is giflib-5.0 support?

I am wandering what giflib version (4 or 5) to bundle with the next strawberry perl release (approx. Oct/Nov 2012).

--
kmx

Subject: Re: [rt.cpan.org #79029] giflib 5.0 support
Date: Tue, 2 Oct 2012 08:28:31 +1000
To: kmx via RT <bug-Imager [...] rt.cpan.org>
From: tonyc [...] cpan.org
Download (untitled) / with headers
text/plain 571b
On Mon, Oct 01, 2012 at 04:45:40PM -0400, kmx via RT wrote: Show quoted text
> <URL: https://rt.cpan.org/Ticket/Display.html?id=79029 > > > May I ask how far is giflib-5.0 support? > > I am wandering what giflib version (4 or 5) to bundle with the next strawberry > perl release (approx. Oct/Nov 2012).
It's implemented but not yet released. I have a few other Imager fixes I want to get in for the next release, so I'm not sure when that will be. If you're in a rush I'd just bundle giflib 4, 5 doesn't gain anything except thread safety, and Imager isn't thread safe anyway. Tony
Download (untitled) / with headers
text/plain 851b
On Mon Oct 01 18:28:45 2012, TONYC wrote: Show quoted text
> On Mon, Oct 01, 2012 at 04:45:40PM -0400, kmx via RT wrote:
> > <URL: https://rt.cpan.org/Ticket/Display.html?id=79029 > > > > > May I ask how far is giflib-5.0 support? > > > > I am wandering what giflib version (4 or 5) to bundle with the next
> strawberry
> > perl release (approx. Oct/Nov 2012).
> > It's implemented but not yet released. > > I have a few other Imager fixes I want to get in for the next release, > so I'm not sure when that will be. > > If you're in a rush I'd just bundle giflib 4, 5 doesn't gain anything > except thread safety, and Imager isn't thread safe anyway.
As a result of tracking down one of those bugs, I believe I've found a bug in giflib 4.2.0 and giflib 5.0.0. Please see: https://sourceforge.net/tracker/?func=detail&aid=3574283&group_id=102202&atid=631304 Tony
Download (untitled) / with headers
text/plain 354b
On Mon Oct 01 16:45:39 2012, KMX wrote: Show quoted text
> May I ask how far is giflib-5.0 support? > > I am wandering what giflib version (4 or 5) to bundle with the next > strawberry > perl release (approx. Oct/Nov 2012).
Imager 0.93 includes support for giflib 5.0.1 support. 5.0.0 has a bug and a limitation that made it impossible to support it with Imager. Tony


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.