Skip Menu |
 

Preferred bug tracker

Please visit the preferred bug tracker to report your issue.

This queue is for tickets about the DBD-Oracle CPAN distribution.

Report information
The Basics
Id: 78965
Status: resolved
Priority: 0/
Queue: DBD-Oracle

People
Owner: Nobody in particular
Requestors: hugh_williams [...] non.agilent.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: DBD::Oracle requiring deprecated module
Date: Tue, 14 Aug 2012 14:55:04 -0600
To: <bug-DBD-Oracle [...] rt.cpan.org>
From: <hugh_williams [...] non.agilent.com>
Download (untitled) / with headers
text/plain 4.2k
Hi; The information I have read from the change logs and such seems to indicate that Oraperl has been deprecated: http://search.cpan.org/~pythian/DBD-Oracle-1.48/Oraperl.pm contains the following statements: Oraperl - [DEPRECATED] Perl access to Oracle databases for old oraperl scripts The use of Oraperl is deprecated in favor of DBD::Oracle<http://search.cpan.org/%7Epythian/DBD-Oracle-1.48/lib/DBD/Oracle.pm>, and will be removed from the DBD::Oracle distribution as of 1.38. However, when I try to install DBD-Oracle-1.48, it tells me that I have to have Oraperl and proceeds to load DBD::Oracle-1.36 first. # uname -a Linux engsr1 2.6.32-220.el6.x86_64 #1 SMP Wed Nov 9 08:03:13 EST 2011 x86_64 x86_64 x86_64 GNU/Linux # perl -v This is perl, v5.10.1 (*) built for x86_64-linux-thread-multi Here is an edited output from my command: env ORACLE_HOME=$OHOME LD_LIBRARY_PATH=$LIBPATH ORACLE_USERID=$OUID PERL_MM_USE_DEFAULT=1 perl -MCPAN -e 'CPAN::Shell->force("install","DBD::Oracle");' (I have correct env vars set, in that at the end, I do have a working DBD::Oracle installed...) CPAN.pm: Going to build P/PY/PYTHIAN/DBD-Oracle-1.48.tar.gz Using DBI 1.609 (for perl 5.010001 on x86_64-linux-thread-multi) installed in /usr/lib64/perl5/auto/DBI/ Configuring DBD::Oracle for perl 5.010001 on linux (x86_64-linux-thread-multi) Remember to actually *READ* the README file! Especially if you have any problems. Installing on a linux, Ver#2.6 Using Oracle in /usr/lib/oracle/11.2/client64 DEFINE _SQLPLUS_RELEASE = "1102000300" (CHAR) Oracle version 11.2.0.3 (11.2) Found /usr/share/oracle/11.2/client64/demo.mk Using /usr/share/oracle/11.2/client64/demo.mk Your LD_LIBRARY_PATH env var is set to '/usr/lib/oracle/11.2/client64/lib' Reading /usr/share/oracle/11.2/client64/demo.mk WARNING: Oracle /usr/share/oracle/11.2/client64/demo.mk doesn't define a 'build' rule. WARNING: I will now try to guess how to build and link DBD::Oracle for you.^G This kind of guess work is very error prone and Oracle-version sensitive. It is possible that it won't be supported in future versions of DBD::Oracle. *PLEASE* notify dbi-users about exactly _why_ you had to build it this way. Found header files in /usr/include/oracle/11.2/client64. client_version=11.2 DEFINE= -Wall -Wno-comment -DUTF8_SUPPORT -DORA_OCI_VERSION=\"11.2.0.3\" -DORA_OCI_102 -DORA_OCI_112 Checking for functioning wait.ph System: perl5.010001 linux hs20-bc2-5.build.redhat.com 2.6.18-274.3.1.el5 #1 smp fri aug 26 18:49:02 edt 2011 x86_64 x86_64 x86_64 gnulinux Compiler: gcc -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -D_REENTRANT -D_GNU_SOURCE -fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 Linker: /usr/bin/ld Sysliblist: Oracle makefiles would have used these definitions but we override them: CC: /usr/bin/gcc LDFLAGS: -g [-g] Linking with -L../../ -locci -lclntsh -lpthread [from $(CCLIB)] Checking if your kit is complete... Looks good Warning: -L../../ changed to -L/tmp/.cpan/build/DBD-Oracle-1.48-FFtUN2/../../ LD_RUN_PATH=/usr/lib/oracle/11.2/client64/lib Using DBD::Oracle 1.48. Using DBD::Oracle 1.48. Using DBI 1.609 (for perl 5.010001 on x86_64-linux-thread-multi) installed in /usr/lib64/perl5/auto/DBI/ Writing Makefile for DBD::Oracle *** If you have problems... read all the log printed above, and the README and README.help.txt files. (Of course, you have read README by now anyway, haven't you?) Show quoted text
---- Unsatisfied dependencies detected during ---- ---- PYTHIAN/DBD-Oracle-1.48.tar.gz ---- Oraperl [build_requires] Running make test Delayed until after prerequisites Running make install Delayed until after prerequisites Running install for module 'Oraperl' Running make for P/PY/PYTHIAN/DBD-Oracle-1.36.tar.gz [ ... ] PYTHIAN/DBD-Oracle-1.36.tar.gz /usr/bin/make install -- OK Running make for P/PY/PYTHIAN/DBD-Oracle-1.48.tar.gz Has already been unwrapped into directory /tmp/.cpan/build/DBD-Oracle-1.48-FFtUN2 CPAN.pm: Going to build P/PY/PYTHIAN/DBD-Oracle-1.48.tar.gz [ ... ] PYTHIAN/DBD-Oracle-1.48.tar.gz /usr/bin/make install -- OK Am I missing something, or is this an issue with the configuration? Thanks, hugh williams
Download (untitled) / with headers
text/html 16.4k

Message body is not shown because it is too large.

Download (untitled) / with headers
text/plain 545b
On Tue Aug 14 16:53:20 2012, hugh_williams@non.agilent.com wrote: Show quoted text
> Hi; > > The information I have read from the change logs and such seems to > indicate that Oraperl has been deprecated: > http://search.cpan.org/~pythian/DBD-Oracle-1.48/Oraperl.pm contains > the following statements:
<snipped> Hugh, Strange but even though I delete Oraperl I cannot reproduce this. I'm guessing it just needs removing from the build_requires in the META file but I'd have liked to see it happen myself first. Martin -- Martin J. Evans Wetherby, UK
Subject: Re: [rt.cpan.org #78965] DBD::Oracle requiring deprecated module
Date: Wed, 15 Aug 2012 08:39:55 -0400
To: "bug-DBD-Oracle [...] rt.cpan.org" <bug-DBD-Oracle [...] rt.cpan.org>
From: Yanick Champoux <champoux [...] pythian.com>
Download (untitled) / with headers
text/plain 1.1k
Hi all, I've checked and Hugh is right. The meta indeed lists oraperl as a dependency because some tests use it. I'll double-check, but if I'm not wrong a patched release will come out today. Joy, Yanick Sent from my iPhone On 2012-08-15, at 8:10 AM, "Martin J Evans via RT" <bug-DBD-Oracle@rt.cpan.org> wrote: Show quoted text
> Queue: DBD-Oracle > Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=78965 > > > On Tue Aug 14 16:53:20 2012, hugh_williams@non.agilent.com wrote:
>> Hi; >> >> The information I have read from the change logs and such seems to >> indicate that Oraperl has been deprecated: >> http://search.cpan.org/~pythian/DBD-Oracle-1.48/Oraperl.pm contains >> the following statements:
> <snipped> > > Hugh, > > Strange but even though I delete Oraperl I cannot reproduce this. > > I'm guessing it just needs removing from the build_requires in the META > file but I'd have liked to see it happen myself first. > > Martin > -- > Martin J. Evans > Wetherby, UK
-- -- Limited Time Offer: Save over 30% when you purchase an Oracle Database Appliance from Pythian. Visit bit.ly/ODAOffer for details.
Download (untitled) / with headers
text/plain 247b
v1.50 with Oraperl dependency removed pushed to CPAN. Martin: I'm slowly showing the ropes to a colleague, so the changes are not in the repo yet. They'll appear tomorrow as we get to that stage, at the same time a new Oraperl distro goes live.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.