Skip Menu |
 

Preferred bug tracker

Please visit the preferred bug tracker to report your issue.

This queue is for tickets about the Dist-Zilla CPAN distribution.

Report information
The Basics
Id: 78934
Status: resolved
Priority: 0/
Queue: Dist-Zilla

People
Owner: Nobody in particular
Requestors: rob [...] hoelz.ro
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: 4.300021
Fixed in: (no value)



Subject: Document :version for dist.ini
Download (untitled) / with headers
text/plain 387b
Hello, I noticed today that one may specify a :version key in a configuration section in dist.ini to explicitly specify which version of a plugin is required. This behavior is not documented, and I think it would be nice if it were. I'm willing to write the documentation myself; I would appreciate some suggestions on the most appropriate place for the addition, though! Thanks, Rob
Download (untitled) / with headers
text/plain 518b
On 2012-08-13 10:37:52, RHOELZ wrote: Show quoted text
> Hello, > > I noticed today that one may specify a :version key in a configuration > section in dist.ini to explicitly specify which version of a plugin is > required. This behavior is not documented, and I think it would be nice > if it were. I'm willing to write the documentation myself; I would > appreciate some suggestions on the most appropriate place for the > addition, though!
Probably this belongs in the CYOA tutorial at https://github.com/rjbs/dzil.org -- rjbs
From: rob [...] hoelz.ro
Download (untitled) / with headers
text/plain 765b
On Thu Jul 25 16:35:03 2013, RJBS wrote: Show quoted text
> On 2012-08-13 10:37:52, RHOELZ wrote:
> > Hello, > > > > I noticed today that one may specify a :version key in a > > configuration > > section in dist.ini to explicitly specify which version of a plugin > > is > > required. This behavior is not documented, and I think it would be > > nice > > if it were. I'm willing to write the documentation myself; I would > > appreciate some suggestions on the most appropriate place for the > > addition, though!
> > Probably this belongs in the CYOA tutorial at > https://github.com/rjbs/dzil.org
Thanks for the suggestion; I took a look at the CYOA sources, but I'm struggling to find which page would be most appropriate for this information. Any suggestions? Thanks, Rob
Subject: Re: [rt.cpan.org #78934] Document :version for dist.ini
Date: Tue, 30 Jul 2013 08:01:26 -0400
To: Rob Hoelz via RT <bug-Dist-Zilla [...] rt.cpan.org>
From: Ricardo Signes <rjbs [...] cpan.org>
Download (untitled) / with headers
text/plain 410b
* Rob Hoelz via RT <bug-Dist-Zilla@rt.cpan.org> [2013-07-30T04:57:07] Show quoted text
> > Probably this belongs in the CYOA tutorial at > > https://github.com/rjbs/dzil.org
> > Thanks for the suggestion; I took a look at the CYOA sources, but I'm > struggling to find which page would be most appropriate for this information. > Any suggestions?
Yeah, it's not clear. Maybe http://dzil.org/tutorial/prereq.html ? -- rjbs
Download signature.asc
application/pgp-signature 490b

Message body not shown because it is not plain text.

I've just added this myself. -- rjbs


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.