Skip Menu |
 

Preferred bug tracker

Please visit the preferred bug tracker to report your issue.

This queue is for tickets about the devel-nytprof CPAN distribution.

Report information
The Basics
Id: 78900
Status: resolved
Priority: 0/
Queue: devel-nytprof

People
Owner: Nobody in particular
Requestors: davido [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Important
Broken in: 4.07
Fixed in: (no value)



Subject: nytprofhtml and nytprofmerge both fail with "...version 4.06 doesn't match version 4.07 of ..."
Download (untitled) / with headers
text/plain 1.6k
In Version 4.07 the version numbers from the two helper utilities, "nytprofhtml" and "nytprofmerge" will fail to execute, announcing the following error message: $ nytprofhtml /home/davido/perl5/bin/nytprofhtml version '4.06' doesn't match version '4.07' of /home/davido/perl5/lib/perl5/x86_64-linux/Devel/NYTProf/Core.pm The issue is really simple: The version numbers of those two utilities didn't get updated in release 4.07 from their previous number of 4.06. Sorry for a 'git diff' patch: I don't use subversion, but it's only two lines of code to fix. Here's a patch: $ git diff diff --git a/bin/nytprofhtml b/bin/nytprofhtml index 1d861d5..0047e74 100755 --- a/bin/nytprofhtml +++ b/bin/nytprofhtml @@ -44,7 +44,7 @@ use Devel::NYTProf::Constants qw(NYTP_SCi_CALLING_SUB); my $json_any = eval { require JSON::Any; JSON::Any->import; JSON::Any->new } or warn "Can't load JSON::Any module - HTML visualizations skipped.\n"; -our $VERSION = '4.06'; +our $VERSION = '4.07'; if ($VERSION != $Devel::NYTProf::Core::VERSION) { die "$0 version '$VERSION' doesn't match version '$Devel::NYTProf::Core::VERSION' of $INC{'Devel/NYTProf/Core.pm'}\n"; diff --git a/bin/nytprofmerge b/bin/nytprofmerge index cd20ba4..a7b1842 100755 --- a/bin/nytprofmerge +++ b/bin/nytprofmerge @@ -18,7 +18,7 @@ require Devel::NYTProf::FileHandle; require Devel::NYTProf::Data; use List::Util qw(min sum); -our $VERSION = '4.06'; +our $VERSION = '4.07'; if ($VERSION != $Devel::NYTProf::Core::VERSION) { die "$0 version '$VERSION' doesn't match version '$Devel::NYTProf::Core::VERSION' of $INC{'Devel/NYTProf/Core.pm'}\n";
Download (untitled) / with headers
text/plain 531b
On Fri Aug 10 19:22:26 2012, DAVIDO wrote: Show quoted text
> In Version 4.07 the version numbers from the two helper utilities, > "nytprofhtml" and "nytprofmerge" will fail to execute, announcing the > following error message:
...should have read like this: "In version 4.07 of Devel::NYTProf, the version numbers from the two helper utilities, "nytprofhtml" and "nytprofmerge" will cause a failure to execute, announcing the following error message:" ...and I should have proof-read my ticket before finalizing the submission. :) Apologies.
Fixed. New release on it's way. Thanks!


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.