Skip Menu |
 

Preferred bug tracker

Please visit the preferred bug tracker to report your issue.

This queue is for tickets about the Dist-Zilla CPAN distribution.

Report information
The Basics
Id: 78770
Status: resolved
Priority: 0/
Queue: Dist-Zilla

People
Owner: Nobody in particular
Requestors: NGLENN [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Critical
Broken in: 4.300021
Fixed in: (no value)



Subject: Won't install on Windows 7 x64
Download (untitled) / with headers
text/plain 119b
I'm trying to install Dist::Zilla on a Windows 7 x64 system. It fails. I've attached the output from the installation.
Subject: dzilOut.txt
Download dzilOut.txt
text/plain 13.3k

Message body is not shown because it is too large.

Subject: dzilErr.txt
Download dzilErr.txt
text/plain 7.8k
# # # Generated by Dist::Zilla::Plugin::ReportVersions::Tiny v1.05 # perl: v5.14.2 (wanted v5.8.5) on MSWin32 from C:\STRAWB~1\perl\bin\perl.exe # # App::Cmd::Setup => 0.318 (want 0.309) # App::Cmd::Tester => 0.318 (want 0.306) # Archive::Tar => 1.80 (want any version) # CPAN::Meta::Converter => 2.120921 (want 2.101550) # CPAN::Meta::Prereqs => 2.120921 (want 2.120630) # CPAN::Meta::Requirements => 2.122 (want 2.121) # CPAN::Meta::Validator => 2.120921 (want 2.101550) # CPAN::Uploader => 0.103001 (want 0.101550) # Carp => 1.23 (want any version) # Class::Load => 0.20 (want 0.17) # Config::INI::Reader => 0.019 (want any version) # Config::MVP::Assembler => 2.200002 (want any version) # Config::MVP::Assembler::WithBundles => 2.200002 (want any version) # Config::MVP::Reader => 2.200002 (want 2.101540) # Config::MVP::Reader::Findable::ByExtension => 2.200002 (want any version) # Config::MVP::Reader::Finder => 2.200002 (want any version) # Config::MVP::Reader::INI => 2.101461 (want 2) # Config::MVP::Section => 2.200002 (want 2.200002) # Data::Dumper => 2.131 (want any version) # Data::Section => 0.101621 (want 0.004) # DateTime => 0.76 (want 0.44) # Digest::MD5 => 2.51 (want any version) # Encode => 2.44 (want any version) # ExtUtils::MakeMaker => 6.62 (want 6.30) # ExtUtils::Manifest => 1.60 (want 1.54) # File::Copy::Recursive => 0.38 (want any version) # File::Find => 1.19 (want any version) # File::Find::Rule => 0.33 (want any version) # File::HomeDir => 0.98 (want any version) # File::Path => 2.08_01 (want any version) # File::ShareDir => 1.03 (want any version) # File::ShareDir::Install => 0.04 (want 0.03) # File::Spec => 3.33 (want any version) # File::Temp => 0.22 (want any version) # File::pushd => 1.001 (want any version) # Hash::Merge::Simple => 0.051 (want any version) # JSON => 2.53 (want 2) # List::MoreUtils => 0.33 (want any version) # List::Util => 1.23 (want any version) # Log::Dispatchouli => 2.005 (want 1.102220) # Moose => 2.0603 (want 0.92) # Moose::Autobox => 0.12 (want 0.10) # Moose::Role => 2.0603 (want any version) # Moose::Util::TypeConstraints => 2.0603 (want any version) # MooseX::LazyRequire => 0.08 (want any version) # MooseX::Role::Parameterized => 1.00 (want any version) # MooseX::SetOnce => 0.200001 (want any version) # MooseX::Types => 0.35 (want any version) # MooseX::Types::Moose => 0.35 (want any version) # MooseX::Types::Path::Class => 0.06 (want any version) # MooseX::Types::Perl => 0.101341 (want any version) # PPI => 1.215 (want any version) # Params::Util => 1.04 (want any version) # Path::Class => 0.26 (want any version) # Perl::PrereqScanner => 1.014 (want 1.005) # Perl::Version => 1.011 (want any version) # Pod::Eventual => 0.093330 (want 0.091480) # Scalar::Util => 1.23 (want any version) # Software::License => 0.103004 (want 0.101370) # Software::LicenseUtils => 0.103004 (want any version) # String::Formatter => 0.102082 (want 0.100680) # String::RewritePrefix => 0.006 (want 0.005) # Sub::Exporter => 0.984 (want any version) # Sub::Exporter::ForMethods => 0.100050 (want any version) # Sub::Exporter::Util => 0.984 (want any version) # Term::ReadKey => 2.30.02 (want any version) # Term::ReadLine => 1.07 (want any version) # Term::ReadLine::Gnu => module not found. (want any version) # Term::UI => 0.26 (want any version) # Test::Deep => 0.11 (want any version) # Test::Fatal => 0.010 (want any version) # Test::File::ShareDir => 0.3.1 (want any version) # Test::More => 0.98 (want 0.96) # Text::Glob => 0.09 (want 0.08) # Text::Template => 1.45 (want any version) # Try::Tiny => 0.11 (want any version) # YAML::Tiny => 1.50 (want any version) # autobox => 2.75 (want 2.53) # autodie => 2.1001 (want any version) # base => 2.16 (want any version) # namespace::autoclean => 0.13 (want any version) # parent => 0.225 (want any version) # strict => 1.04 (want any version) # version => 0.95 (want any version) # warnings => 1.12 (want any version) # # Thanks for using my code. I hope it works for you. # If not, please try and include this output in the bug report. # That will help me reproduce the issue and solve your problem. # cannot unlink file for tmp\1Nfdp0ph7D\source\dist.ini: Permission denied at C:/strawberry/perl/lib/File/Temp.pm line 902 cannot remove directory for tmp\1Nfdp0ph7D\source: Directory not empty at C:/strawberry/perl/lib/File/Temp.pm line 902 cannot remove directory for tmp\1Nfdp0ph7D: Directory not empty at C:/strawberry/perl/lib/File/Temp.pm line 902 mkdir C:\strawberry\cpan\build\Dist-Zilla-4.300021-6pyoMP\tmp\Hp0lr2yl8c\build\txt\{{ $dist->name }}: Invalid argument; The filename, directory name, or volume label syntax is incorrect at C:/strawberry/perl/site/lib/Path/Class/Dir.pm line 134 # Tests were run but no plan was declared and done_testing() was not seen. Failed 1/37 test programs. 0/541 subtests failed. dmake.EXE: Error code 255, while making 'test_dynamic'
Download (untitled) / with headers
text/plain 379b
This is a problem with the test. ">" is not a valid character in a Windows filename. You can use "notest install Dist::Zilla" to skip the tests, since the rest of them passed. If we really want to test that the filename is not a template unless name_is_template is true, I suggest replacing {{ $dist->name }} with {{ 'testing' }} (which will produce a valid Windows filename).


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.