Skip Menu |
 

This queue is for tickets about the Module-Install CPAN distribution.

Report information
The Basics
Id: 78269
Status: new
Priority: 0/
Queue: Module-Install

People
Owner: Nobody in particular
Requestors: dorian [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: one-line fix for `use 5.010'
Download (untitled) / with headers
text/plain 195b
It appears that %Module::CoreList::version has perl 5.10 listed as 5.01 rather than 5.010. This patch just enforces the six-digit decimal perl version for versions greater than or equal to 5.006.
Subject: djt-module-install.diff
Index: lib/Module/Install/Admin/ScanDeps.pm =================================================================== --- lib/Module/Install/Admin/ScanDeps.pm (revision 15456) +++ lib/Module/Install/Admin/ScanDeps.pm (working copy) @@ -18,6 +18,8 @@ perl_version('5.005'); END_MESSAGE $perl_version =~ s{^(\d+)\.(\d+)\.(\d+)}{$1 + $2/1_000 + $3/1_000_000}e; + # make this more robust against situations like 5.01/5.010 + $perl_version = sprintf('%0.6f', $perl_version) if $perl_version >= 5.006; require Module::ScanDeps; require Module::CoreList;


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.