This queue is for tickets about the Class-Std CPAN distribution.

Report information
The Basics
Id:
78196
Status:
patched
Priority:
Low/Low
Queue:

People
Owner:
Nobody in particular
Requestors:
MRSCOTTY [...] cpan.org
cpan [...] zoffix.com
Cc:
CARNIL [...] cpan.org
AdminCc:

BugTracker
Severity:
Important
Broken in:
0.011
Fixed in:
(no value)



Subject: t/pod.t fails due to encoding error
Note: Although the underlying issue is trivial, a failed test prevents this module from installing automatically with tools like cpanm. That is why I set the severity at "important". Description: When installing Class::Std with cpanm, the installation fails due to the t/pod.t not passing. Details: $ cpanm --verbose Class::Std cpanm (App::cpanminus) 1.5015 on perl 5.017001 built for darwin-2level Work directory is /Users/scott/.cpanm/work/1341386642.94741 You have make /usr/bin/make You have LWP 6.04 You have /usr/bin/tar: bsdtar 2.8.3 - libarchive 2.8.3 You have /usr/bin/unzip Searching Class::Std on cpanmetadb ... --> Working on Class::Std Fetching http://www.cpan.org/authors/id/D/DC/DCONWAY/Class-Std-0.011.tar.gz ... OK Unpacking Class-Std-0.011.tar.gz x Class-Std-0.011/ x Class-Std-0.011/Build.PL x Class-Std-0.011/Changes x Class-Std-0.011/demo/ x Class-Std-0.011/lib/ x Class-Std-0.011/Makefile.PL x Class-Std-0.011/MANIFEST x Class-Std-0.011/META.yml x Class-Std-0.011/README x Class-Std-0.011/t/ x Class-Std-0.011/t/00.load.t x Class-Std-0.011/t/access.t x Class-Std-0.011/t/access_automethod.t x Class-Std-0.011/t/access_name.t x Class-Std-0.011/t/automethod.t x Class-Std-0.011/t/begin-coercion.t x Class-Std-0.011/t/can.t x Class-Std-0.011/t/coercions.t x Class-Std-0.011/t/cumulative.t x Class-Std-0.011/t/dump.t x Class-Std-0.011/t/perlattrs.t x Class-Std-0.011/t/pod-coverage.t x Class-Std-0.011/t/pod.t x Class-Std-0.011/t/runtime.t x Class-Std-0.011/t/simple.t x Class-Std-0.011/t/start.t x Class-Std-0.011/lib/Class/ x Class-Std-0.011/lib/Class/Std.pm x Class-Std-0.011/demo/demo_can.pl x Class-Std-0.011/demo/demo_coercions.pl x Class-Std-0.011/demo/demo_library.pl x Class-Std-0.011/demo/demo_library_AUTOLOAD.pl x Class-Std-0.011/demo/demo_library_AUTOLOAD_CUMULATIVE.pl x Class-Std-0.011/demo/demo_library_AUTOMETHDEF.pl x Class-Std-0.011/demo/demo_perlify.pl x Class-Std-0.011/demo/demo_shimmer.pl x Class-Std-0.011/demo/demo_unclass.pl Entering Class-Std-0.011 Checking configure dependencies from META.yml Configuring Class-Std-0.011 ... Running Build.PL Created MYMETA.yml and MYMETA.json Creating new 'Build' script for 'Class-Std' version '0.011' OK Checking dependencies from MYMETA.json ... Checking if you have Test::More 0 ... Yes (0.98) Checking if you have Scalar::Util 0 ... Yes (1.25) Checking if you have Data::Dumper 0 ... Yes (2.135_06) Building and testing Class-Std-0.011 ... Building Class-Std t/00.load.t ............ 1/1 # Testing Class::Std 0.011 t/00.load.t ............ ok t/access.t ............. ok t/access_automethod.t .. ok t/access_name.t ........ ok t/automethod.t ......... ok t/begin-coercion.t ..... ok t/can.t ................ ok t/coercions.t .......... ok t/cumulative.t ......... ok t/dump.t ............... ok t/perlattrs.t .......... ok t/pod-coverage.t ....... ok t/pod.t ................ 1/1 # Failed test 'POD test for blib/lib/Class/Std.pm' # at /Users/scott/perl5/lib/perl5/Test/Pod.pm line 182. # blib/lib/Class/Std.pm (1512): Non-ASCII character seen before =encoding in ':key?value?'. Assuming ISO8859-1 # Looks like you failed 1 test of 1. t/pod.t ................ Dubious, test returned 1 (wstat 256, 0x100) Failed 1/1 subtests t/runtime.t ............ ok t/simple.t ............. ok t/start.t .............. ok Test Summary Report ------------------- t/pod.t (Wstat: 256 Tests: 1 Failed: 1) Failed test: 1 Non-zero exit status: 1 Files=16, Tests=277, 2 wallclock secs ( 0.12 usr 0.05 sys + 0.89 cusr 0.14 csys = 1.20 CPU) Result: FAIL Failed 1/16 test programs. 1/277 subtests failed. FAIL
Trivial patch attached. gregor, Debian Perl Group
Subject: pod.patch
Description: add =encoding, some POD tools are more picky now Origin: vendor Bug: https://rt.cpan.org/Public/Bug/Display.html?id=78196 Bug-Debian: http://bugs.debian.org/709765 Forwarded: https://rt.cpan.org/Public/Bug/Display.html?id=78196 Author: gregor herrmann <gregoa@debian.org> Last-Update: 2013-05-25 --- a/lib/Class/Std.pm +++ b/lib/Class/Std.pm @@ -613,6 +613,8 @@ 1; # Magic true value required at end of module __END__ +=encoding ISO-8859-1 + =head1 NAME Class::Std - Support for creating standard "inside-out" classes
Also, to note: these types of tests should be placed in xt/ and only run for authors, not end users. This bug is one of the reasons: a trivial issue, but the installation of the module fails. -- Cheers, ZZ [ https://metacpan.org/author/ZOFFIX ]
On 2012-07-04 03:35:33, MRSCOTTY wrote:
Show quoted text
> Note: Although the underlying issue is trivial, a failed test prevents > this module from installing > automatically with tools like cpanm. That is why I set the severity at > "important".
And the list of modules depending on Class::Std is also impressive: https://metacpan.org/requires/distribution/Class-Std?sort=[[2,1]]&size=100


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.