Skip Menu |
 

This queue is for tickets about the Sex CPAN distribution.

Report information
The Basics
Id: 78067
Status: open
Priority: 0/
Queue: Sex

People
Owner: Nobody in particular
Requestors: perl [...] toby.ink
Cc:
AdminCc:

Bug Information
Severity: Critical
Broken in: 0.69
Fixed in: (no value)



Subject: Supports modern versions of Perl
Download (untitled) / with headers
text/plain 155b
Sex should issue a warning when running on any version of Perl newer than 5.005, as they have not yet reached the age of consent (in most jurisdictions).
Subject: Re: [rt.cpan.org #78067] Supports modern versions of Perl
Date: Fri, 29 Jun 2012 10:11:19 -0700
To: bug-Sex [...] rt.cpan.org
From: Michael G Schwern <schwern [...] pobox.com>
Download (untitled) / with headers
text/plain 510b
On 2012.6.27 5:24 AM, Toby Inkster via RT wrote: Show quoted text
> Sex should issue a warning when running on any version of Perl newer than > 5.005, as they have not yet reached the age of consent (in most > jurisdictions).
Oh, that's beautiful! I will put Sex on Github now just so you can write that patch! For bonus points, it would calculate the current age of each version and release them to have Sex as they cross the age of consent. For maximum hilarity, use geoip to cross reference with the local age limits.
Download (untitled) / with headers
text/plain 449b
On Wed Jun 27 08:24:54 2012, TOBYINK wrote: Show quoted text
> Sex should issue a warning when running on any version of Perl newer than > 5.005, as they have not yet reached the age of consent (in most > jurisdictions).
What gender is Perl? The age of consent varies by gender in several jurisdictions. Also, should we check the age of the user when warning (for jurisdictions where age of consent varies according to the age gap between the parties involved)?
Download (untitled) / with headers
text/plain 302b
On 2012-06-29 13:25:36, http://noirin.myopenid.com/ wrote: Show quoted text
> What gender is Perl? The age of consent varies by gender in several > jurisdictions.
Perl is whatever gender makes it easier for the user to get work done, so I suggest picking the gender less likely to allow the user to use Sex. -- rjbs
Download (untitled) / with headers
text/plain 522b
On 2012-06-29T18:11:31+01:00, schwern@pobox.com wrote: Show quoted text
> Oh, that's beautiful! I will put Sex on Github now just so you can > write that patch!
Repo appears to be empty. Show quoted text
> For bonus points, it would calculate the current age of each version > and release them to have Sex as they cross the age of consent.
perlhist looks fairly parsable. Show quoted text
> For maximum hilarity, use geoip to cross reference with the local > age limits.
Perhaps for a future version. In the mean time, maybe an AGE_OF_CONSENT environment variable?
Download (untitled) / with headers
text/plain 125b
On 2012-07-01T02:39:58+01:00, TOBYINK wrote: Show quoted text
> In the mean time, maybe an AGE_OF_CONSENT environment variable?
LC_CONSENT?
Subject: Re: [rt.cpan.org #78067] Supports modern versions of Perl
Date: Sat, 30 Jun 2012 20:17:11 -0700
To: bug-Sex [...] rt.cpan.org
From: Michael G Schwern <schwern [...] pobox.com>
Download (untitled) / with headers
text/plain 619b
On 2012.6.30 6:39 PM, Toby Inkster via RT wrote: Show quoted text
> Repo appears to be empty.
Fixed! Show quoted text
>> For bonus points, it would calculate the current age of each version >> and release them to have Sex as they cross the age of consent.
> > perlhist looks fairly parsable. >
>> For maximum hilarity, use geoip to cross reference with the local >> age limits.
> > Perhaps for a future version. In the mean time, maybe an AGE_OF_CONSENT > environment variable?
Of course, like all good problems, it needs its own module. We're off on the idea of writing Acme::Perl::Consensual. https://github.com/schwern/Acme-Perl-Consensual
Download (untitled) / with headers
text/plain 436b
On 2012-07-01T04:17:22+01:00, schwern@pobox.com wrote: Show quoted text
> idea of writing Acme::Perl::Consensual. > https://github.com/schwern/Acme-Perl-Consensual
Fork here: https://github.com/tobyink/p5-acme-perl-consensual ... contains a working implementation. Tested in Perl 5.8 and 5.16. Due to the nature of the module, it would be nice if it worked in some older versions of Perl too. Anybody have any pre-5.005 Perls they can test it on?
Subject: Re: [rt.cpan.org #78067] Supports modern versions of Perl
Date: Mon, 02 Jul 2012 13:04:55 -0700
To: bug-Sex [...] rt.cpan.org
From: Michael G Schwern <schwern [...] pobox.com>
Download (untitled) / with headers
text/plain 586b
On 2012.7.2 5:57 AM, Toby Inkster via RT wrote: Show quoted text
> Fork here: > > https://github.com/tobyink/p5-acme-perl-consensual > > ... contains a working implementation. Tested in Perl 5.8 and 5.16. Due > to the nature of the module, it would be nice if it worked in some older > versions of Perl too. Anybody have any pre-5.005 Perls they can test it > on?
Since you've ran with it, I've deleted my empty repository. It's all yours now! I don't have a pre-5.005 handy, they don't compile so well on OS X. PS Make sure to turn your issues tab back on in the admin part of the project.
Download (untitled) / with headers
text/plain 172b
Acme-Perl-Consensual 0.000_01 is now on CPAN: https://metacpan.org/release/TOBYINK/Acme-Perl-Consensual-0.000_01 It is does well on CPAN Testers, then I'll release 0.001.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.