This queue is for tickets about the Plack-Middleware-Test-StashWarnings CPAN distribution.

Report information
The Basics
Id:
77970
Status:
resolved
Priority:
Low/Low

People
Owner:
Nobody in particular
Requestors:
ANDK [...] cpan.org
Cc:
AdminCc:

BugTracker
Severity:
Normal
Broken in:
0.06
Fixed in:
(no value)



Subject: Fails with Test::Harness 3.24,3.25
I haven't yet understood why it fails but with a little statistics and experimentation I could prove that installing T:H 3.23 makes the tests pass, installing 3.24 makes them fail. HTH&&Regards,
Subject: Re: [rt.cpan.org #77970] Fails with Test::Harness 3.24,3.25
Date: Mon, 12 Nov 2012 23:22:41 -0500
To: bug-Plack-Middleware-Test-StashWarnings@rt.cpan.org
From: Alex Vandiver <alex@chmrr.net>
On Fri, 2012-06-22 at 17:31 -0400, Andreas Koenig via RT wrote:
Show quoted text
> I haven't yet understood why it fails but with a little statistics and > experimentation I could prove that installing T:H 3.23 makes the tests > pass, installing 3.24 makes them fail.
Thanks for the report. I've fixed the tests and pushed version 0.07, but this is caused by commit 18794a8 in Test::Harness. See also [rt.cpan.org #58229] -- I'm sure other modules are being bitten by that change, as well. - Alex


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.