Skip Menu |
 

This queue is for tickets about the libwww-perl CPAN distribution.

Report information
The Basics
Id: 77956
Status: open
Priority: 0/
Queue: libwww-perl

People
Owner: Nobody in particular
Requestors: angelabad [...] ubuntu.com
Cc: FANY [...] cpan.org
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: Doesn't connect to some XHTML 1.1 sites using ssl
Download (untitled) / with headers
text/plain 258b
Hi, Bug forwarded from Ubuntu, see: https://bugs.launchpad.net/bugs/1013883 doesn't allow you to connect to some websites over ssl, if they are in the xhtml 1.1 markup. Instead, it simply times out. I have attached a script demonstrating this. Cheers,
Download (untitled) / with headers
text/plain 690b
Maybe I just don't get it, but I do not see the connection to the site's markup here, especially since this problem already seems to occur during the SSL connection phase. Are you sure that this is a LWP issue? I got the same error message when trying for https://banking.postbank.de/rai/login , regardless if I used LWP, wget or curl after upgrading from openSUSE 12.1 to 12.2 and thus from openssl 1.0.0e to 1.0.1c, and here is why: http://www.mail-archive.com/openssl-users@openssl.org/msg68653.html So at least in my case the reason is a server side bug, and my workaround is: $ua->ssl_opts(SSL_version => 'SSLv3'); (Which is then passed to IO::Socket::SSL->new.) Regards, fany


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.