Skip Menu |
 

This queue is for tickets about the Config-IniFiles CPAN distribution.

Report information
The Basics
Id: 77930
Status: resolved
Priority: 0/
Queue: Config-IniFiles

People
Owner: Nobody in particular
Requestors: TJENNESS [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: (no value)
Fixed in: (no value)



Subject: List::MoreUtils version matters
Download (untitled) / with headers
text/plain 522b
Can you please consider adding a minimum version requirement on List::MoreUtils in your Build.PL? I have just been driven to distraction trying to work out why Config::IniFiles was failing its tests (and failing them badly despite lots of green on linux on cpantesters). It turns out that List::MoreUtils v0.22 is too old for Config::IniFiles but cpan tools don't know about that and so never try to update it. I know about the issue now but maybe putting a v0.33 minimum would help prevent problems for other people.
Download (untitled) / with headers
text/plain 814b
Hi TJENNESS, On Wed Jun 20 16:04:13 2012, TJENNESS wrote: Show quoted text
> Can you please consider adding a minimum version requirement on > List::MoreUtils in your > Build.PL? I have just been driven to distraction trying to work out > why Config::IniFiles was failing > its tests (and failing them badly despite lots of green on linux on > cpantesters). It turns out that > List::MoreUtils v0.22 is too old for Config::IniFiles but cpan tools > don't know about that and so > never try to update it. I know about the issue now but maybe putting a > v0.33 minimum would > help prevent problems for other people.
Thanks for the report. List-MoreUtils-0.33 is pretty recent (from August, 2011), but maybe I can set a dependency on https://metacpan.org/release/ADAMK/List-MoreUtils-0.26/ or something. Regards, -- Shlomi Fish
Subject: Re: [rt.cpan.org #77930] List::MoreUtils version matters
Date: Thu, 21 Jun 2012 09:35:17 -0700
To: bug-Config-IniFiles [...] rt.cpan.org
From: Tim Jenness <tjenness [...] cpan.org>
Download (untitled) / with headers
text/plain 1.1k
On Thu, Jun 21, 2012 at 9:32 AM, Shlomi Fish via RT <bug-Config-IniFiles@rt.cpan.org> wrote: Show quoted text
> <URL: https://rt.cpan.org/Ticket/Display.html?id=77930 > > > Hi TJENNESS, > > On Wed Jun 20 16:04:13 2012, TJENNESS wrote:
>> Can you please consider adding a minimum version requirement on >> List::MoreUtils in your >> Build.PL? I have just been driven to distraction trying to work out >> why Config::IniFiles was failing >> its tests (and failing them badly despite lots of green on linux on >> cpantesters). It turns out that >> List::MoreUtils v0.22 is too old for Config::IniFiles but cpan tools >> don't know about that and so >> never try to update it. I know about the issue now but maybe putting a >> v0.33 minimum would >> help prevent problems for other people.
> > Thanks for the report. > > List-MoreUtils-0.33 is pretty recent (from August, 2011), but maybe I > can set a dependency on > https://metacpan.org/release/ADAMK/List-MoreUtils-0.26/ or something. >
If it works with that version then that would be fine with me. All I determined was that 0.22 was breaking everything and that 0.33 fixed it. -- Tim Jenness
This was fixed in Config-IniFiles-2.77. Thanks again for the report.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.