Skip Menu |
 

This queue is for tickets about the XML-LibXML CPAN distribution.

Report information
The Basics
Id: 77924
Status: resolved
Priority: 0/
Queue: XML-LibXML

People
Owner: Nobody in particular
Requestors: mmann [...] otmltd.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 2.0000
Fixed in: (no value)



Subject: perl-libxml-libxml-h missing
Download (untitled) / with headers
text/plain 647b
I get the following when running Makefile on the new version; /usr/src/XML-LibXML-2.0000> perl Makefile.PL enable native perl UTF8 running xml2-config...ok (2.7.8) looking for -lxml2... yes Checking if your kit is complete... Warning: the following files are missing in your kit: perl-libxml-libxml.h Please inform the author. Writing Makefile for XML::LibXML Writing MYMETA.yml and MYMETA.json /usr/src/XML-LibXML-2.0000> I have check the MANIFEST file and this is indeed listed but does not exist within the the tar supplied... Cheers Martin (PS Got much bigger issue but I'll let you catch this one first in case it's the cause)
Download (untitled) / with headers
text/plain 1.1k
Hi Martin, On Wed Jun 20 10:42:37 2012, mmann@otmltd.com wrote: Show quoted text
> I get the following when running Makefile on the new version; > > /usr/src/XML-LibXML-2.0000> perl Makefile.PL > enable native perl UTF8 > running xml2-config...ok (2.7.8) > looking for -lxml2... yes > Checking if your kit is complete... > Warning: the following files are missing in your kit: > perl-libxml-libxml.h > Please inform the author. > Writing Makefile for XML::LibXML > Writing MYMETA.yml and MYMETA.json > /usr/src/XML-LibXML-2.0000> > > I have check the MANIFEST file and this is indeed listed but does not > exist within the the tar supplied... >
thanks for the report. This is now fixed in XML-LibXML-2.0001 which was just uploaded to CPAN. perl-libxml-libxml.h was a file that I considered adding, but eventually did not (and forgot to remove from the MANIFEST). It was now removed from the MANIFEST. Show quoted text
> Cheers > > Martin > > (PS Got much bigger issue but I'll let you catch this one first in case > it's the cause)
I doubt that was the cause. If you still have problems with XML-LibXML-2.0001, please file a different bug report. Regards, -- Shlomi Fish


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.