Skip Menu |
 

This queue is for tickets about the Net-SMTP-TLS CPAN distribution.

Report information
The Basics
Id: 77400
Status: new
Priority: 0/
Queue: Net-SMTP-TLS

People
Owner: Nobody in particular
Requestors: mark [...] workingtraffic.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



CC: Matthew Hochman <mdhochman [...] optonline.net>
Subject: invalid SSL_version specified at /usr/lib/perl5/site_perl/5.8.8/IO/Socket/SSL.pm line 308
Date: Thu, 24 May 2012 09:21:18 -0400
To: bug-IO-Socket-SSL [...] rt.cpan.org, bug-Net-SMTP-TLS [...] rt.cpan.org
From: Mark Underwood <mark [...] workingtraffic.com>
Greetings, I maintain many e-commerce websites for various clients and about 2 weeks ago it suddenly became impossible for any of my Perl code to send e-mail to customers or clients when orders were placed from the websites. All my code uses the module NET::SMTP::TLS after debugging this code I found that the error causing the code to crash was coming from another module which TLS depends upon, namely: IO::Socket::SSL. I also tried using NET::SMTP::SSL The error is: invalid SSL_version specified at /usr/lib/perl5/site_perl/5.8.8/IO/Socket/SSL.pm line 308 I have tried to use the simple NET::SMTP to send mail (which does not require the SSL module) but then I have to send from localhost which does not have a FQDN and therefore all the email ends up being filtered out as spam. Perl seems totally dependent upon NET::SMTP to be able to send e-mail so I am at a dead end and none of my clients or their customers are receiving sales notification/receipts. I hope you can find the time to fix this bug (which must have been introduced in a new version of one of the modules) . My guess is that ::SSL now requires a version number to be passed and that ::TLS is not doing this, so therefore ::TLS needs updating so that it passes the version number in a way that IO::Socket::SSL accepts, or I guess IO::Socket::SSL could be modified to take a version number optionally? This is just a guess in case it helps to fast track a fix for this urgent issue. I have tried to resolve the problem and now I have waited several days expecting a fix to appear, since I assumed 10's of thousands of developers and their customers would be affected by this, but I am starting to think that this bug is not effecting as many people as I thought it would and I am therefore contacting you directly. Note: I have sent this bug report to both bug-IO-Socket-SSL@rt.cpan.org AND bug-Net-SMTP-TLS@rt.cpan.org since I do not know who should best handle this problem? Please help. Best regards, Mark. ------------------------ Mark Underwood Traffic Director Working Traffic Inc. +1(516)669-0006 mark@workingtraffic.com
Download (untitled) / with headers
text/html 13.9k

Message body is not shown because it is too large.



This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.