Skip Menu |
 

This queue is for tickets about the Net-SSH-Perl CPAN distribution.

Report information
The Basics
Id: 7736
Status: resolved
Priority: 0/
Queue: Net-SSH-Perl

People
Owner: Nobody in particular
Requestors: Smylers [...] stripey.com
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in:
  • 1.24
  • 1.25
Fixed in: (no value)



Subject: Perl Version Prereq
Download (untitled) / with headers
text/plain 531b
I've just tried to install Net::SSH::Perl on a Perl 5.005 computer. Having since read the change-log, this is documented as not working (so I went back to version 1.23 of Net::SSH::Perl instead, which is working fine). But it'd be nicer to have a better error message when trying to install on an older Perl -- currently running make test yields an error about weak references in Net::SSH::Perl::Packet; adding this line to the top of Net::SSH::Perl: use 5.006; would result in a more helpful error message. Cheers. Smylers
This was fixed (independent of this ticket) in 1.26.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.