Skip Menu |
 

Preferred bug tracker

Please visit the preferred bug tracker to report your issue.

This queue is for tickets about the HTML-FormHandler CPAN distribution.

Report information
The Basics
Id: 76942
Status: resolved
Priority: 0/
Queue: HTML-FormHandler

People
Owner: Nobody in particular
Requestors: h.dudeness [...] gmail.com
Cc:
AdminCc:

Bug Information
Severity: Important
Broken in: 0.40007
Fixed in: (no value)



Subject: HTML::FormHandler::Render::Table render_field is not working
Download (untitled) / with headers
text/plain 550b
perl5 (revision 5 version 8 subversion 8) 2.6.18-194.el5 #1 SMP Tue Mar 16 21:52:43 EDT 2010 i686 i686 i386 GNU/Linux I have my forma packages setup like this: package MyForm; use HTML::FormHandler::Moose; extends 'HTML::FormHandler'; with 'HTML::FormHandler::Render::Table'; Then to render I make use of the render_field method in toolkit: [% form.render_field('email') %] FormHandler does not seem to be wrapping the fields in <tr><td> anymore. I am not sure if I am not using it correctly or if it is not supposed to function that way anymore.
Subject: Re: [rt.cpan.org #76942] HTML::FormHandler::Render::Table render_field is not working
Date: Wed, 02 May 2012 11:37:41 -0400
To: bug-HTML-FormHandler [...] rt.cpan.org
From: Gerda Shank <gerda.shank [...] gmail.com>
Download (untitled) / with headers
text/plain 951b
On 5/2/12 10:30 AM, Matt via RT wrote: Show quoted text
> I have my forma packages setup like this: > package MyForm; > use HTML::FormHandler::Moose; > extends 'HTML::FormHandler'; > with 'HTML::FormHandler::Render::Table'; > > Then to render I make use of the render_field method in toolkit: > [% form.render_field('email') %] > > FormHandler does not seem to be wrapping the fields in<tr><td> anymore. I am not sure if I > am not using it correctly or if it is not supposed to function that way anymore.
This is a bug in HTML::FormHandler::Render::Simple. It's been fixed in the repo and will go out in the next release. Meanwhile, you could switch to the Widget table rendering, by doing: with 'HTML::FormHandler::Widget::Form::Table'; has '+widget_wrapper' => ( default => 'Table' ); The widget rendering options are being more fully supported right now. Some new features are only implemented in widgets, not in Render::Simple and Render::Table. Gerda
From: h.dudeness [...] gmail.com
Download (untitled) / with headers
text/plain 692b
Show quoted text
> Meanwhile, you could switch to the Widget table rendering, by doing: > > with 'HTML::FormHandler::Widget::Form::Table'; > has '+widget_wrapper' => ( default => 'Table' );
Thanks for the quick reply. I have tried this setup: use HTML::FormHandler::Moose; extends 'HTML::FormHandler'; with 'HTML::FormHandler::Widget::Form::Table'; has '+widget_wrapper' => ( default => 'Table' ); It is the same issue. form.render works great. But [%form.render_field('email')%] outputs nothing. Here is my has_feild: has_field 'email' => ( type => 'Email', required => 1, html_attr => { class => '{required:true}' }, label_attr => { class => [ 'control-label', 'required' ] } );
Subject: Re: [rt.cpan.org #76942] HTML::FormHandler::Render::Table render_field is not working
Date: Thu, 03 May 2012 11:42:53 -0400
To: bug-HTML-FormHandler [...] rt.cpan.org
From: Gerda Shank <gerda.shank [...] gmail.com>
Download (untitled) / with headers
text/plain 1002b
Matt: When using the widget rendering, you don't do form.render_field('email'), you do form.field('email').render. Gerda On 5/3/12 8:12 AM, Matt via RT wrote: Show quoted text
> Queue: HTML-FormHandler > Ticket<URL: https://rt.cpan.org/Ticket/Display.html?id=76942> >
>> Meanwhile, you could switch to the Widget table rendering, by doing: >> >> with 'HTML::FormHandler::Widget::Form::Table'; >> has '+widget_wrapper' => ( default => 'Table' );
> Thanks for the quick reply. I have tried this setup: > use HTML::FormHandler::Moose; > extends 'HTML::FormHandler'; > with 'HTML::FormHandler::Widget::Form::Table'; > has '+widget_wrapper' => ( default => 'Table' ); > > It is the same issue. form.render works great. But [%form.render_field('email')%] outputs > nothing. Here is my has_feild: > has_field 'email' => ( > type => 'Email', > required => 1, > html_attr => { class => '{required:true}' }, > label_attr => { class => [ 'control-label', 'required' ] } > );
From: h.dudeness [...] gmail.com
Thanks for taking the time to respond. I should have looked at the docs closer.
Fixed.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.