Skip Menu |
 

This queue is for tickets about the Encode CPAN distribution.

Report information
The Basics
Id: 76713
Status: open
Priority: 0/
Queue: Encode

People
Owner: Nobody in particular
Requestors: perlbug-followup [...] perl.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



CC: bug-Encode [...] rt.cpan.org
Subject: [perl #44359] Encode has mixed minimum Perl version requirements
Date: Thu, 19 Apr 2012 18:09:57 -0700
To: "OtherRecipients of perl Ticket #44359":;
From: "Father Chrysostomos via RT" <perlbug-followup [...] perl.org>
Download (untitled) / with headers
text/plain 4.2k
Forwarding to the CPAN queue.... On Fri Aug 03 02:36:54 2007, nospam-abuse@bloodgate.com wrote: Show quoted text
> This is a bug report for perl from nospam-abuse@bloodgate.com, > generated with the help of perlbug 1.35 running under perl v5.8.8. > > > ----------------------------------------------------------------- > [Please enter your report here] > > Encode (2.23) has mixed requirements on the minimum Perl version: > > * The Makefile.PL says v5.7.3 > * piconv needs v5.8.0 > * ucm2table says min. v5.6.0 > * and yet META.yml doesn't specify any requirement > * the .pm files seem not to specify any requirement > > It would be good if the real minimum version could be found out > and be specified in Makefile.PL and META.yml. > > [Please do not change anything below this line] > ----------------------------------------------------------------- > --- > Flags: > category=library > severity=low > --- > This perlbug was built using Perl v5.8.8 - Sat Apr 22 23:31:53 UTC > 2006 > It is being executed now by Perl v5.8.8 - Sat Apr 22 23:26:49 UTC > 2006. > > Site configuration information for perl v5.8.8: > > Configured by abuild at Sat Apr 22 23:26:49 UTC 2006. > > Summary of my perl5 (revision 5 version 8 subversion 8) configuration: > Platform: > osname=linux, osvers=2.6.16, archname=x86_64-linux-thread-multi > uname='linux dvorak 2.6.16 #1 smp mon apr 10 04:51:13 utc 2006 > x86_64 > x86_64 x86_64 gnulinux ' > > config_args='-ds -e -Dprefix=/usr -Dvendorprefix=/usr > -Dinstallusrbinperl -Dusethreads -Di_db -Di_dbm -Di_ndbm -Di_gdbm > -Duseshrplib=true -Doptimize=-O2 -fmessage-length=0 -Wall > -D_FORTIFY_SOURCE=2 -g -Wall -pipe' > hint=recommended, useposix=true, d_sigaction=define > usethreads=define use5005threads=undef useithreads=define > usemultiplicity=define > useperlio=define d_sfio=undef uselargefiles=define usesocks=undef > use64bitint=define use64bitall=define uselongdouble=undef > usemymalloc=n, bincompat5005=undef > Compiler: > cc='cc', ccflags > ='-D_REENTRANT -D_GNU_SOURCE -DTHREADS_HAVE_PIDS -DDEBUGGING > -fno-strict-aliasing -pipe -Wdeclaration-after-statement > -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64', > > optimize='-O2 -fmessage-length=0 -Wall -D_FORTIFY_SOURCE=2 -g -Wall > -pipe', > > cppflags='-D_REENTRANT -D_GNU_SOURCE -DTHREADS_HAVE_PIDS -DDEBUGGING > -fno-strict-aliasing -pipe -Wdeclaration-after-statement' > ccversion='', gccversion='4.1.0 (SUSE Linux)', gccosandvers='' > intsize=4, longsize=8, ptrsize=8, doublesize=8, byteorder=12345678 > d_longlong=define, longlongsize=8, d_longdbl=define, > longdblsize=16 > ivtype='long', ivsize=8, nvtype='double', nvsize=8, Off_t='off_t', > lseeksize=8 > alignbytes=8, prototype=define > Linker and Libraries: > ld='cc', ldflags =' -L/usr/local/lib64' > libpth=/lib64 /usr/lib64 /usr/local/lib64 > libs=-lm -ldl -lcrypt -lpthread > perllibs=-lm -ldl -lcrypt -lpthread > libc=/lib64/libc-2.4.so, so=so, useshrplib=true, > libperl=libperl.so > gnulibc_version='2.4' > Dynamic Linking: > dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, > ccdlflags='-Wl,-E > -Wl,-rpath,/usr/lib/perl5/5.8.8/x86_64-linux-thread-multi/CORE' > cccdlflags='-fPIC', lddlflags='-shared -L/usr/local/lib64' > > Locally applied patches: > > > --- > @INC for perl v5.8.8: > /usr/lib/perl5/5.8.8/x86_64-linux-thread-multi > /usr/lib/perl5/5.8.8 > /usr/lib/perl5/site_perl/5.8.8/x86_64-linux-thread-multi > /usr/lib/perl5/site_perl/5.8.8 > /usr/lib/perl5/site_perl > /usr/lib/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi > /usr/lib/perl5/vendor_perl/5.8.8 > /usr/lib/perl5/vendor_perl > . > > --- > Environment for perl v5.8.8: > HOME=/home/te > LANG=en_US.UTF-8 > LANGUAGE (unset) > LD_LIBRARY_PATH (unset) > LOGDIR (unset) > >
PATH=/usr/local/bin:/usr/bin:/usr/X11R6/bin:/bin:/usr/games:/opt/gnome/bin:/opt/kde3/bin:/usr/lib/mit/bin:/usr/lib/mit/sbin:/home/te/.local/bin:/home/te/games/dirkdashing:/home/te/games/dirkdashing:/home/te/games/dirkdashing:/home/te/games/dirkdashing Show quoted text
> PERL_BADLANG (unset) > SHELL=/bin/bash >
-- Father Chrysostomos --- via perlbug: queue: perl5 status: open https://rt.perl.org:443/rt3/Ticket/Display.html?id=44359


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.