Skip Menu |
 

This queue is for tickets about the XML-SAX-PurePerl CPAN distribution.

Report information
The Basics
Id: 766
Status: new
Priority: 0/
Queue: XML-SAX-PurePerl

People
Owner: Nobody in particular
Requestors: alex [...] acatysmoof.com
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: 0.80
Fixed in: (no value)

Attachments
C:\WINNT\Profiles\ateslik\Desktop\t ests.tgz
test2.tgz



Subject: <pre>Name contains invalid start character: '&#x3C;'</pre> on 5005_03
Download (untitled) / with headers
text/plain 1.1k
I get the <pre>Name contains invalid start character: '&#x3C;'</pre> error when I try to parse any xml files with perl 5005_03 using XML::SAX::PurePerl. Attached is a tgz of all of the xml files I am trying to use. All of them fail. Also inside the tgz is the CGI script I am using that outputs (creates?) the error. Mabye it's something in my code. The .pl is very much in development, so expect something ugly. I deleted extraneous subs and vars to make it quick and easy to follow. After deleting those subs and vars I still get the error. For a more detailed decription of the problem see http://www.perlmonks.org/index.pl?node_id=174943 The $VERSION inside PurePerl.pm is 0.90 $Id: PurePerl.pm,v 1.15 2002/02/05 17:33:52 matt Exp $ perl -v: This is perl, version 5.005_03 built for i386-freebsd uname -a: FreeBSD gouda.acatysmoof.com 4.4-RELEASE FreeBSD 4.4-RELEASE #1: Mon Feb 25 22:16:05 PST 2002 alex@gouda.acatysmoof.com:/usr/obj/usr/src/sys/DUALP3.4.4R i386 To me, this seems to be a bug. I checked my config and can't seem to find any problems. Of course, it could be something I'm doing. Thanks for your help. Alex
Download C:\WINNT\Profiles\ateslik\Desktop\t ests.tgz
application/x-gzip-compressed 5.9k

Message body not shown because it is not plain text.

Date: Thu, 20 Jun 2002 00:44:24 -0700 (PDT)
From: "Alex Teslik" <alex [...] acatysmoof.com>
To: bug-XML-SAX-PurePerl [...] rt.cpan.org, alex [...] acatysmoof.com
Subject: Re: [cpan #766] AutoReply: <pre>Name contains invalid start character: '&#x3C;'</pre> on 5005_03
Download (untitled) / with headers
text/plain 2.2k
I seem to be able to at least make it work when I turn off taint checking (-T). But with taint on and untainted vars, I still get the error. hmmmm. Unfortunately I would like to leave -T on. Also, I noticed I made an error in the Handlers in the tgz I originally sent. I was going back and forth between XML::Parser::Lite and XML::SAX::PurePerl and noticed I took off the ->{Name} portions of the Handlers. They are back in the test2.tgz file attached to this email. HTH, alex Show quoted text
> > Greetings, > This message has been automatically generated in response to
your bug report about XML-SAX-PurePerl, a summary of which appears below. Show quoted text
> > There is no need to reply to this message right now. Your bug in
XML-SAX-PurePerl has been assigned an ID of [cpan #766]. Please include the string: Show quoted text
> > [cpan #766] > > in the subject line of all future correspondence about this issue. To
do so, Show quoted text
> you may reply to this message. > > Thank you, > bug-XML-SAX-PurePerl@rt.cpan.org > >
------------------------------------------------------------------------- Show quoted text
> I get the <pre>Name contains invalid start character: '&#x3C;'</pre>
error when I try to parse any xml files with perl 5005_03 using XML::SAX::PurePerl. Show quoted text
> > Attached is a tgz of all of the xml files I am trying to use. All of > them fail. Also inside the tgz is the CGI script I am using that
outputs Show quoted text
> (creates?) the error. Mabye it's something in my code. The .pl is very > much in development, so expect something ugly. I deleted extraneous
subs Show quoted text
> and vars to make it quick and easy to follow. After deleting those
subs Show quoted text
> and vars I still get the error. > > For a more detailed decription of the problem see
http://www.perlmonks.org/index.pl?node_id=174943 Show quoted text
> > The $VERSION inside PurePerl.pm is 0.90 > $Id: PurePerl.pm,v 1.15 2002/02/05 17:33:52 matt Exp $ > > perl -v: > This is perl, version 5.005_03 built for i386-freebsd > > uname -a: > FreeBSD gouda.acatysmoof.com 4.4-RELEASE FreeBSD 4.4-RELEASE #1: Mon
Feb 25 22:16:05 PST 2002 alex@gouda.acatysmoof.com:/usr/obj/usr/src/sys/DUALP3.4.4R i386 Show quoted text
> > > To me, this seems to be a bug. I checked my config and can't seem to
find any problems. Of course, it could be something I'm doing. Show quoted text
> > Thanks for your help. > Alex > >
Download test2.tgz
application/octet-stream 5.9k

Message body not shown because it is not plain text.



This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.