Skip Menu |
 

This queue is for tickets about the MooseX-Method-Signatures CPAN distribution.

Report information
The Basics
Id: 76427
Status: rejected
Priority: 0/
Queue: MooseX-Method-Signatures

People
Owner: Nobody in particular
Requestors: KAPPA [...] cpan.org
Cc: lxp [...] cpan.org
AdminCc:

Bug Information
Severity: Critical
Broken in: 0.41
Fixed in: 0.42



Subject: Failed test 'Sane error message for syntax error'
Download (untitled) / with headers
text/plain 941b
I get this when running tests on perl-5.12.4: t/closure.t .......................... ok t/declarators.t ...................... ok # Failed test 'Sane error message for syntax error' # at t/errors.t line 10. # 'Failed to compile source: Compilation error # # source: # sub { ( do { do {my $check = $_[0];ref($check) eq "ARRAY" && &List::MoreUtils::all(sub { ( do { 1 } ) }, @{$check})} } ) } at /usr/local/lib/perl/5.12.4/Moose/Meta/TypeConstraint.pm line 320. # Compilation failed in require at (eval 8) line 1. # BEGIN failed--compilation aborted at (eval 8) line 1. # ' # doesn't match '(?-xism:^Global symbol "\$op" requires explicit package name at .*?\bInvalidCase01.pm line 8\b)' # Looks like you failed 1 test of 4. t/errors.t ........................... Dubious, test returned 1 (wstat 256, 0x100) Failed 1/4 subtests t/eval.t ............................. ok t/list.t ............................. ok
Download (untitled) / with headers
text/plain 116b
The error goes away when you when method meth2{ } is changed to method meth2(){ } in t/lib/InvalidCase01.pm
I can report seeing the same error: https://gist.github.com/2384615
Download (untitled) / with headers
text/plain 240b
From change log for version 0.42: 0.42 2012-04-23 11:08:19 PDT-0700 * Mark failing test due to Eval::Closure/Devel::Declare issues as TODO until things are fixed, to at least allow recent versions to install without errors.
Download (untitled) / with headers
text/plain 1.2k
Marking this as "rejected" because: 1. the module is deprecated. 2. "dzil build" said that "Module::Build::Tiny should not be used in distributions that are targeting perl 5.006" which makes too little sense to investigate further. 09 Nis 2012 Pts, 04:42:43 tarihinde, KAPPA yazdı: Show quoted text
> I get this when running tests on perl-5.12.4: > > t/closure.t .......................... ok > t/declarators.t ...................... ok > > # Failed test 'Sane error message for syntax error' > # at t/errors.t line 10. > # 'Failed to compile source: Compilation error > # > # source: > # sub { ( do { do {my $check = $_[0];ref($check) eq "ARRAY" && > &List::MoreUtils::all(sub { ( do { 1 } ) }, @{$check})} } ) } at > /usr/local/lib/perl/5.12.4/Moose/Meta/TypeConstraint.pm line 320. > # Compilation failed in require at (eval 8) line 1. > # BEGIN failed--compilation aborted at (eval 8) line 1. > # ' > # doesn't match '(?-xism:^Global symbol "\$op" requires explicit > package name at .*?\bInvalidCase01.pm line 8\b)' > # Looks like you failed 1 test of 4. > t/errors.t ........................... > Dubious, test returned 1 (wstat 256, 0x100) > Failed 1/4 subtests > t/eval.t ............................. ok > t/list.t ............................. ok
Download (untitled) / with headers
text/plain 448b
On 2015-10-06 10:56:18, KAPPA wrote: Show quoted text
> Marking this as "rejected" because: > 1. the module is deprecated. > 2. "dzil build" said that "Module::Build::Tiny should not be used in > distributions that are targeting perl 5.006" which makes too little > sense to investigate further.
kappa: There is no reason to do a 'dzil build' -- 'prove -lr t' works just fine (see the CONTRIBUTING file in the repository). However, I have fixed the build failure.
Download (untitled) / with headers
text/plain 912b
06 Eki 2015 Sal, 14:07:12 tarihinde, ETHER yazdı: Show quoted text
> On 2015-10-06 10:56:18, KAPPA wrote:
> > Marking this as "rejected" because: > > 1. the module is deprecated. > > 2. "dzil build" said that "Module::Build::Tiny should not be used in > > distributions that are targeting perl 5.006" which makes too little > > sense to investigate further.
> > kappa: There is no reason to do a 'dzil build' -- 'prove -lr t' works > just fine (see the CONTRIBUTING file in the repository). However, I > have fixed the build failure.
Thanks. Running tests with prove requires installing dependencies. So I ran 'dzil build' to get META.json. 'dzil listdeps' also gave the same error message about MB::Tiny. In the end, instead of cloning the repo I downloaded the tarball from CPAN which already has the dependency list generated and successfully run all the tests. Which means that the ticket is even more irrelevant now :)
Download (untitled) / with headers
text/plain 408b
On 2015-10-06 16:21:35, KAPPA wrote: Show quoted text
> In the end, instead of cloning the repo I downloaded the tarball from > CPAN which already has the dependency list generated and successfully > run all the tests. Which means that the ticket is even more irrelevant > now :)
Aha, ok -- sounds like one of the dependencies has resolved the error perhaps? If you find more information, feel free to re-open this ticket.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.