Skip Menu |
 

This queue is for tickets about the Module-Build CPAN distribution.

Report information
The Basics
Id: 76397
Status: open
Priority: 0/
Queue: Module-Build

People
Owner: Nobody in particular
Requestors: aad [...] dreamsnake.net
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: 0.40
Fixed in: (no value)



Subject: Module::Metadata (we need version 1.000002)
Download (untitled) / with headers
text/plain 511b
I was asked by a user last week to install Moose, which entailed building 40+ dependencies. Among them was Module::Build. The Moose build asserted: Module::Metadata (we need version 1.000002) All other dependencies were indicated as a minimum version, not an exact version -- in this case, an old one. The current version of Module::Metadata is 1.000009. Does Module::Build 0.40 really require exactly this version of Module::Metadata, or should it be corrected to work with 1.000002 or anything newer?
Subject: Re: [rt.cpan.org #76397] Module::Metadata (we need version 1.000002)
Date: Sun, 8 Apr 2012 11:32:11 +0200
To: bug-Module-Build [...] rt.cpan.org
From: Leon Timmermans <fawaka [...] gmail.com>
Download (untitled) / with headers
text/plain 848b
On Sun, Apr 8, 2012 at 5:43 AM, anthony D via RT <bug-Module-Build@rt.cpan.org> wrote: Show quoted text
> I was asked by a user last week to install Moose, which entailed > building 40+ dependencies.  Among them was Module::Build.  The Moose > build asserted: > >  Module::Metadata (we need version 1.000002) > > All other dependencies were indicated as a minimum version, not an exact > version -- in this case, an old one.  The current version of > Module::Metadata is 1.000009.   Does Module::Build 0.40 really require > exactly this version of Module::Metadata, or should it be corrected to > work with 1.000002 or anything newer?
I don't think Module::Build declares anywhere that it needs exactly that version (it works fine for me with Module::Metadata 1.000004). Can you provide the whole build log? This sounds like something else is going on. Leon
From: aad [...] dreamsnake.net
% perl Makefile.PL PREFIX=/tmp/Module::Build *** BOOTSTRAPPING Module::Metadata *** # running Build.PL --prefix /tmp/Module::Build *** BOOTSTRAPPING Module::Metadata *** Checking prerequisites... requires: ! CPAN::Meta is not installed ERRORS/WARNINGS FOUND IN PREREQUISITES. You may wish to install the versions of the modules indicated above before proceeding with this installation Could not create MYMETA files Creating new 'Build' script for 'Module-Build' version '0.40' Copied META.yml to MYMETA.yml for bootstrapping These additional prerequisites must be installed: requires: ! Module::Metadata (we need version 1.000002) These additional prerequisites must be installed: requires: ! Module::Metadata (we need version 1.000002) -- I don't see an obvious build log in my working directory -- can you be more explicit? I do see that _build/prereqs includes 'requires' => { 'Module::Metadata' => '1.000002', yet when I installed 1.000009 and re-ran Makefile.pl the error above remained. It disappeared when I built and installed 1.000002


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.