Skip Menu |
 

This queue is for tickets about the Dist-Zilla-Plugin-ReportVersions-Tiny CPAN distribution.

Maintainer(s)' notes

This module is deprecated!

This distribution has reached end-of-life now that better alternatives exist.

The recommended alternative is Dist::Zilla::Plugin::Test::ReportPrereqs.

Report information
The Basics
Id: 76308
Status: open
Priority: 0/
Queue: Dist-Zilla-Plugin-ReportVersions-Tiny

People
Owner: Nobody in particular
Requestors: xenoterracide [...] gmail.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: Test::Tester errors
Date: Wed, 25 Jan 2012 17:46:59 -0600
To: bugs-dist-zilla-plugin-reportversions-tiny <bugs-dist-zilla-plugin-reportversions-tiny [...] rt.cpan.org>
From: Caleb Cushing <xenoterracide [...] gmail.com>
Download (untitled) / with headers
text/plain 408b
RPT complains of issues with loading Test::Tester which will complain of it not being loaded first. I think it's because you ` eval "require $module;"; ` and I think that Template::Toolkit has similar errors. Try using one of the following, to check that it's installed. Module::Load::Conditional (core perl 5.10+) deps of Moose Module::Runtime Class::Load -- Caleb Cushing http://xenoterracide.com
Subject: Re: [rt.cpan.org #74395] AutoReply: Test::Tester errors
Date: Wed, 25 Jan 2012 17:57:49 -0600
To: bug-Dist-Zilla-Plugin-ReportVersions-Tiny [...] rt.cpan.org
From: Caleb Cushing <xenoterracide [...] gmail.com>
Download (untitled) / with headers
text/plain 110b
other options include Module::Metadata to get the info for you. -- Caleb Cushing http://xenoterracide.com
Subject: don't eval
Date: Wed, 4 Apr 2012 13:03:58 -0500
To: bugs-dist-zilla-plugin-reportversions-tiny <bugs-dist-zilla-plugin-reportversions-tiny [...] rt.cpan.org>
From: Caleb Cushing <xenoterracide [...] gmail.com>
Download (untitled) / with headers
text/plain 257b
evaling the dists is dangerous and also the reason that some dists like Test::Tester require workarounds. Module::Metadata would allow you to extract all of the info safely. Would you accept patches to this end? -- Caleb Cushing http://xenoterracide.com
Download (untitled) / with headers
text/plain 433b
Le 2012-04-04 20:04:07, XENO a écrit : Show quoted text
> evaling the dists is dangerous and also the reason that some dists > like Test::Tester require workarounds. Module::Metadata would allow > you to extract all of the info safely. Would you accept patches to > this end?
I'm the new maintainer. Patches welcome at GitHub! https://github.com/dolmen/p5-Dist-Zilla-Plugin-ReportVersions-Tiny/ -- Olivier Mengué - http://perlresume.org/DOLMEN
Subject: Re: [rt.cpan.org #76308] don't eval
Date: Sun, 9 Sep 2012 23:46:15 -0500
To: bug-Dist-Zilla-Plugin-ReportVersions-Tiny [...] rt.cpan.org
From: Caleb Cushing <xenoterracide [...] gmail.com>
Download (untitled) / with headers
text/plain 2.7k
(this happens if I use ReportVersions::Tiny instad of ReportVersions in Dist::Zilla::Plugin::Test::PodSpelling 2.002004 t/000-report-versions-tiny.t .. # You should load Test::Tester before Test::Builder (or anything that loads Test::Builder) at /home/xenoterracide/perl5/perlbrew/perls/perl-5.16.0/lib/5.16.0/Test/Tester.pm line 9. # # Generated by Dist::Zilla::Plugin::ReportVersions::Tiny v1.05 # perl: v5.16.0 (wanted 5.010) on linux from /home/xenoterracide/perl5/perlbrew/perls/perl-5.16.0/bin/perl # # Cwd => 3.39_02 (want any version) # Dist::Zilla::Plugin::InlineFiles => 4.300023 (want any version) # Dist::Zilla::Role::FileFinderUser => 4.300023 (want any version) # Dist::Zilla::Role::TextTemplate => 4.300023 (want any version) # Dist::Zilla::Tester => 4.300023 (want any version) # ExtUtils::MakeMaker => 6.6302 (want 6.30) # File::Find => 1.20 (want any version) # File::Temp => 0.22 (want any version) # Moose => 2.0603 (want any version) # Path::Class => 0.26 (want any version) # Pod::Wordlist::hanekomu => 1.121370 (want any version) # Test::DZil => 4.300023 (want any version) # Test::More => 0.98 (want 0.88) # Test::Script => 1.07 (want 1.05) # Test::Spelling => 0.15 (want any version) # Test::Tester => 0.108 (want any version) # strict => 1.07 (want any version) # warnings => 1.13 (want any version) # # Thanks for using my code. I hope it works for you. # If not, please try and include this output in the bug report. # That will help me reproduce the issue and solve your problem. # A merge request will be coming soon, just testing now. On Mon, Jul 2, 2012 at 5:45 PM, Olivier Mengué via RT <bug-Dist-Zilla-Plugin-ReportVersions-Tiny@rt.cpan.org> wrote: Show quoted text
> <URL: https://rt.cpan.org/Ticket/Display.html?id=76308 > > > Le 2012-04-04 20:04:07, XENO a écrit :
>> evaling the dists is dangerous and also the reason that some dists >> like Test::Tester require workarounds. Module::Metadata would allow >> you to extract all of the info safely. Would you accept patches to >> this end?
> > I'm the new maintainer. Patches welcome at GitHub! > https://github.com/dolmen/p5-Dist-Zilla-Plugin-ReportVersions-Tiny/ > > > -- > Olivier Mengué - http://perlresume.org/DOLMEN
-- Caleb Cushing http://xenoterracide.com
Download (untitled) / with headers
text/plain 115b
Issue documented in the CAVEATS section in POD in release 1.09. -- Olivier Mengué - http://perlresume.org/DOLMEN
I don't plan to fix this.
Instead I'm deprecating this module and recommends Dist::Zilla::Plugin::Test::ReportPrereqs instead.

-- 
Olivier Mengué - http://perlresume.org/DOLMEN - https://gratipay.com/dolmen/


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.