Skip Menu |
 

This queue is for tickets about the Perl-MinimumVersion CPAN distribution.

Report information
The Basics
Id: 76283
Status: rejected
Priority: 0/
Queue: Perl-MinimumVersion

People
Owner: Nobody in particular
Requestors: DOHERTY [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: perlver should report the reason(s) for the discovered minimum version
Download (untitled) / with headers
text/plain 748b
It would be helpful to have the report include the reasons(s) for the discovered minimum version. If using ~~ caused the minimum version to bumped to 5.10, then reporting that would help module authors understand why 5.10 is required, and whether it was worth it. It'd be very helpful for people trying to write code that works on old perls because they could incrementally remove the highest-version- requiring constructs to reduce the minimum version required to whatever level they require. It might not be possible to incorporate that into the current output format easily, in which case it might require an additional command line switch to request it, or it might be included only when giving a different output format (like HTML).
Download (untitled) / with headers
text/plain 232b
On Tue Apr 03 13:08:42 2012, DOHERTY wrote: Show quoted text
> It would be helpful to have the report include the reasons(s) for the > discovered minimum version.
Do you mean something like --blame option? -- Alexandr Ciornii, http://chorny.net


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.