Skip Menu |
 

Preferred bug tracker

Please visit the preferred bug tracker to report your issue.

This queue is for tickets about the DateTime-Format-Strptime CPAN distribution.

Report information
The Basics
Id: 76128
Status: resolved
Priority: 0/
Queue: DateTime-Format-Strptime

People
Owner: Nobody in particular
Requestors: bitcard [...] 32ths.com
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: 1.5000
Fixed in: 1.51



Download (untitled) / with headers
text/plain 1.1k
Test::More is listed as runtime requirement. This breaks RPM packaging for older distributions that require the core modules to be listed in the depends. (cpanspec -o basically). Propose to move Test::More requirements in Makefile.PL to build reqs. --- Makefile.PL 2010-10-16 16:26:44.000000000 -0400 +++ ../Makefile.PL 2012-03-28 13:23:50.000000000 -0400 @@ -11,7 +11,9 @@ my %WriteMakefileArgs = ( 'ABSTRACT' => 'Parse and format strp and strf time patterns', 'AUTHOR' => 'Dave Rolsky <autarch@urth.org>', - 'BUILD_REQUIRES' => {}, + 'BUILD_REQUIRES' => { + 'Test::More' => '0.88' + }, 'CONFIGURE_REQUIRES' => { 'ExtUtils::MakeMaker' => '6.31' }, @@ -20,11 +22,10 @@ 'LICENSE' => 'artistic_2', 'NAME' => 'DateTime::Format::Strptime', 'PREREQ_PM' => { - 'DateTime' => '0.4304', + 'DateTime' => '0.44', 'DateTime::Locale' => '0.45', 'DateTime::TimeZone' => '0.79', 'Params::Validate' => '0.64', - 'Test::More' => '0.88' }, 'VERSION' => '1.5000', 'test' => { This is perl, v5.8.8 built for x86_64-linux-thread-multi 2.6.18-274.12.1.el5 #1 SMP Tue Nov 8 21:37:35 EST 2011 x86_64 x86_64 x86_64 GNU/Linux RedHat EL5
Subject: Test::More should not be requirement for runtime
From: bitcard [...] 32ths.com
Download (untitled) / with headers
text/plain 1.3k
On Wed Mar 28 13:25:23 2012, xmikew wrote: Show quoted text
> Test::More is listed as runtime requirement. This breaks RPM packaging > for older distributions that require the core modules to be listed in > the depends. (cpanspec -o basically). > > Propose to move Test::More requirements in Makefile.PL to build reqs. > > --- Makefile.PL 2010-10-16 16:26:44.000000000 -0400 > +++ ../Makefile.PL 2012-03-28 13:23:50.000000000 -0400 > @@ -11,7 +11,9 @@ > my %WriteMakefileArgs = ( > 'ABSTRACT' => 'Parse and format strp and strf time patterns', > 'AUTHOR' => 'Dave Rolsky <autarch@urth.org>', > - 'BUILD_REQUIRES' => {}, > + 'BUILD_REQUIRES' => { > + 'Test::More' => '0.88' > + }, > 'CONFIGURE_REQUIRES' => { > 'ExtUtils::MakeMaker' => '6.31' > }, > @@ -20,11 +22,10 @@ > 'LICENSE' => 'artistic_2', > 'NAME' => 'DateTime::Format::Strptime', > 'PREREQ_PM' => { > 'DateTime::Locale' => '0.45', > 'DateTime::TimeZone' => '0.79', > 'Params::Validate' => '0.64', > - 'Test::More' => '0.88' > }, > 'VERSION' => '1.5000', > 'test' => { > > This is perl, v5.8.8 built for x86_64-linux-thread-multi > 2.6.18-274.12.1.el5 #1 SMP Tue Nov 8 21:37:35 EST 2011 x86_64 x86_64 > x86_64 GNU/Linux > RedHat EL5 >
Sorry, fail on the subject and patch but no edit options. Made the patch not adjust the version req for DateTime (previous improvement already filed on that) Thanks, - Mike


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.