Skip Menu |
 

This queue is for tickets about the Gitalist CPAN distribution.

Report information
The Basics
Id: 76068
Status: new
Priority: 0/
Queue: Gitalist

People
Owner: Nobody in particular
Requestors: KENTNL [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Unimportant
Broken in: 0.003009
Fixed in: (no value)



Subject: Non-Meta-1.4spec compatibile LICENSE value

Hi

I was wondering why the metadata exported by MetaCPAN  and hence this page: https://metacpan.org/release/BROQ/Gitalist-0.003003 suggested that your license was "unknown".

It appears that the license string "gpl2" is not supported by the Meta-1.4 specification , and so when the meta-1.4 document is translated to a meta-2.0 document, "gpl2" maps to "unknown"

Seems only the strings "gpl" and "lgpl" are supported with regard to GPL licenses in the 1.4 spec, and EUMM doesn't do you any favours and doesn't warn you about "gpl2" being invalid, and just passes the value through.

If you're lucky, you might be able to specify "gpl_2" and make EUMM generate a META.json file, which /might/ be close enough to work. ( THough I forget what you need to have installed to make that happen )

But as it stands, 'gpl2' is on neither the META-1.4 or Meta-2.0 Spec.

https://metacpan.org/module/Module::Build::API#license

https://metacpan.org/source/RJBS/Software-License-0.103004/lib/Software/License/GPL_1.pm

https://metacpan.org/source/RJBS/Software-License-0.103004/lib/Software/License/GPL_2.pm

https://metacpan.org/source/RJBS/Software-License-0.103004/lib/Software/License/GPL_3.pm

Hope this is useful.

Thanks.

 



This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.