Skip Menu |
 

This queue is for tickets about the Object-InsideOut CPAN distribution.

Report information
The Basics
Id: 75768
Status: rejected
Priority: 0/
Queue: Object-InsideOut

People
Owner: Nobody in particular
Requestors: smueller [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: 3.92
Fixed in: (no value)



Subject: Bogus META.yml with cyclic dependency
Download (untitled) / with headers
text/plain 164b
I think you want to get rid of the META.yml which seems to be outdated. The one that's shipped creates a cyclic dependency with Math::Random::MT::Auto. --Steffen
Download (untitled) / with headers
text/plain 556b
On 2012-03-14 12:38:08, SMUELLER wrote: Show quoted text
> I think you want to get rid of the META.yml which seems to be outdated.
Outdated? How so? (Or are you just referring to what follows?) Show quoted text
> The one that's shipped creates a cyclic dependency with > Math::Random::MT::Auto.
Well, not exactly. While MRMA 'requires' OIO, OIO only 'recommends' using MRMA. So OIO is required, but MRMA is optional. Then again, I profess ignorance as to the proper specifications for such dependencies. Is there some reference I can access to gain greater insight on this issue?
Subject: Re: [rt.cpan.org #75768] Bogus META.yml with cyclic dependency
Date: Wed, 14 Mar 2012 19:03:44 +0100
To: bug-Object-InsideOut [...] rt.cpan.org
From: Steffen Mueller <smueller [...] cpan.org>
On 03/14/2012 06:07 PM, Jerry D. Hedden via RT wrote: Show quoted text
> <URL: https://rt.cpan.org/Ticket/Display.html?id=75768> > > On 2012-03-14 12:38:08, SMUELLER wrote:
>> I think you want to get rid of the META.yml which seems to be outdated.
> > Outdated? How so? (Or are you just referring to what > follows?) >
>> The one that's shipped creates a cyclic dependency with >> Math::Random::MT::Auto.
> > Well, not exactly. While MRMA 'requires' OIO, OIO only > 'recommends' using MRMA. So OIO is required, but MRMA is > optional. > > Then again, I profess ignorance as to the proper > specifications for such dependencies. Is there some > reference I can access to gain greater insight on this > issue?
Oooh, indeed, it's my oversight. META.yml and META.json do not contain the same information. That could be considered a bug somewhere, but likely not in your module. In the end, the particular problem is that our annoying build system promotes recommends to requires. I'll close the bug and work around the hate that is the RedHat/RPM/cpanspec based build system. Sorry for the noise! --Steffen


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.