Skip Menu |
 

This queue is for tickets about the Net-IMAP-Simple CPAN distribution.

Report information
The Basics
Id: 75514
Status: resolved
Priority: 0/
Queue: Net-IMAP-Simple

People
Owner: Nobody in particular
Requestors: TEAM [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 1.2030
Fixed in: (no value)



Subject: Test failures and daemon process left active after testing
Hi there, I've noticed that the last few attempts to install the current version (1.2030) on my local system are failing, and there's a Net::IMAP::Server process left running afterwards - ps auxw output: 4319 ? S 0:00 Net::IMAP::Server(4319) An example test report is here: http://www.cpantesters.org/cpan/report/b7bdeb3c-5b79-11e1-b768-53e3da31a447 and I think this may be related to the test stability issue reported in https://rt.cpan.org/Public/Bug/Display.html?id=73915. This doesn't appear due to network/firewall issues, however, since the daemon process is listening on two ports and I can connect locally - netstat -ltnp: tcp 0 0 0.0.0.0:19794 0.0.0.0:* LISTEN 14461/Net::IMAP::Se tcp 0 0 0.0.0.0:19795 0.0.0.0:* LISTEN 14461/Net::IMAP::Se Connecting to the first port as the same user I'm running the test as gives me: $ telnet localhost 19794 Trying ::1... Trying 127.0.0.1... Connected to localhost. Escape character is '^]'. * OK Net::IMAP::Simple Test Server (1) ^]quit Show quoted text
telnet> quit
Connection closed. with the second port accepting the connection but not returning a banner: $ telnet localhost 19795 Trying ::1... Trying 127.0.0.1... Connected to localhost. Escape character is '^]'. ^]quit Show quoted text
telnet> quit
Connection closed. Initially I thought this might be due to the version of Test.pm installed (1.25_02), but installing Test.pm 1.25 and retrying the Net::IMAP::Simple installation still gave the same result. Obviously this then impacts on any further attempts to run tests since the port number appears to be hardcoded - I'd suspect that running the server component in-process in each test might help with this since this should allow the system to assign a port for you, and it should also avoid the test ordering issue mentioned in the latest Changes entry? I should hasten to add I'm reporting this for completeness, since I'm not actively using the module at the moment, so from my point of view at least this isn't an urgent bug report =) best regards, Tom
Download (untitled) / with headers
text/plain 819b
I would guess you're running the tests simultaneously. For the last 12 or 15 years, the tests ran in ascii order, one at a time. Lately I've been seeing test failures because some of the test systems are using EV to multithread the testing. There doesn't appear to be any way to tell those systems that the test suite needs to be run single threaded... so my two options are build the test suite as a monolithic single file or to simply disable the tests. I'm leaning toward the later. The tests don't really tell me anything when the run around the world that I can't learn here at my house. That second port is the SSL port. It wont answer unless you speak SSL to it. -Paul -- If riding in an airplane is flying, then riding in a boat is swimming. 116 jumps, 48.6 minutes of freefall, 92.9 freefall miles.
Download (untitled) / with headers
text/plain 677b
Hi there, On Sun Mar 04 12:55:34 2012, JETTERO wrote: Show quoted text
> I would guess you're running the tests simultaneously. For the last 12 > or 15 years, the tests ran in ascii order, one at a time.
No, they should be running in serial - or at least they do with TAP::Harness and I haven't enabled any specific configuration to run parallel testing with the Test.pm framework. The output and results (see linked test report) are sequential so I'd be surprised if it was running things in parallel. I also get the same errors when running the tests individually. If it's any help I can attach the output, although there's not much more than the cpantesters report contains. cheers, Tom
Subject: Re: [rt.cpan.org #75514] Test failures and daemon process left active after testing
Date: Sun, 4 Mar 2012 17:37:07 -0500
To: bug-Net-IMAP-Simple [...] rt.cpan.org
From: Paul Miller <paul [...] voltar.org>
Download (untitled) / with headers
text/plain 1.1k
The tests should log most things they do. Doesn't show up on the testers output. Certainly send them. Though, these aren't really package bugs. They're just portability errors in the tests. -- message brief, sent from phone On Mar 4, 2012 5:11 PM, "Thomas Edward Alexander Molesworth via RT" < bug-Net-IMAP-Simple@rt.cpan.org> wrote: Show quoted text
> Queue: Net-IMAP-Simple > Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=75514 > > > Hi there, > > On Sun Mar 04 12:55:34 2012, JETTERO wrote:
> > I would guess you're running the tests simultaneously. For the last 12 > > or 15 years, the tests ran in ascii order, one at a time.
> > No, they should be running in serial - or at least they do with > TAP::Harness and I haven't enabled any specific configuration to run > parallel testing with the Test.pm framework. The output and results (see > linked test report) are sequential so I'd be surprised if it was running > things in parallel. I also get the same errors when running the tests > individually. If it's any help I can attach the output, although there's > not much more than the cpantesters report contains. > > cheers, > > Tom >
Download (untitled) / with headers
text/plain 898b
On Sun Mar 04 17:37:18 2012, paul@voltar.org wrote: Show quoted text
> The tests should log most things they do. Doesn't show up on the testers > output. Certainly send them. Though, these aren't really package bugs. > They're just portability errors in the tests.
I've attached the output from running the first few tests directly via perl, rather than going through prove, in case that was causing additional issues. The informal-*.log files are empty. My guess is that the make test failures are due to the daemon still running after the first test so the next attempt to bind to the port fails, although if that's the case I'm not sure why the first few tests are okay when run manually. As I say, this is just something I'm reporting for completeness, so if you're satisfied that it's purely due to environment rather than anything wrong with the package itself, feel free to close this RT. cheers, Tom
Subject: session.txt
Download session.txt
text/plain 5.2k
cpan[2]> look Net::IMAP::Simple Running look for module 'Net::IMAP::Simple' Trying to open a subshell in the build directory... Checksum for /home/tom/.cpan/sources/authors/id/J/JE/JETTERO/Net-IMAP-Simple-1.2030.tar.gz ok Working directory is /home/tom/.cpan/build/Net-IMAP-Simple-1.2030-U5PTEH tom@roku:~/.cpan/build/Net-IMAP-Simple-1.2030-U5PTEH$ dir total 136 drwxr-x--- 2 tom tom 4096 2012-02-06 15:06 certs/ -rw-r--r-- 1 tom tom 18547 2012-02-06 15:05 Changes drwxr-x--- 2 tom tom 4096 2012-02-06 15:06 contrib/ drwxr-x--- 3 tom tom 4096 2012-02-06 15:06 inc/ drwxr-x--- 3 tom tom 4096 2012-02-06 15:06 lib/ -rw-r--r-- 1 tom tom 2629 2011-09-02 19:35 Makefile.PL -rw-r--r-- 1 tom tom 2478 2012-02-06 15:06 MANIFEST -rw-r----- 1 tom tom 1689 2012-02-06 15:06 META.json -rw-r----- 1 tom tom 960 2012-02-06 15:06 META.yml -rw-r--r-- 1 tom tom 589 2010-10-29 14:09 README -rw-r--r-- 1 tom tom 32602 2012-02-06 14:43 Simple.pm -rw-r--r-- 1 tom tom 30064 2012-01-25 19:25 Simple.pod -rwxr-xr-x 1 tom tom 95 2010-10-29 14:09 start_server.sh* -rwxr-xr-x 1 tom tom 96 2010-10-29 14:09 stop_server.sh* drwxr-x--- 2 tom tom 4096 2012-02-06 15:06 t/ -rw-r--r-- 1 tom tom 212 2010-10-29 14:09 TODO tom@roku:~/.cpan/build/Net-IMAP-Simple-1.2030-U5PTEH$ perl Makefile.PL Do you wish to include some simple protocol extensions (pulls in Parse::RecDescent)? [y] y Checking if your kit is complete... Looks good Writing Makefile for Net::IMAP::Simple Writing MYMETA.yml and MYMETA.json tom@roku:~/.cpan/build/Net-IMAP-Simple-1.2030-U5PTEH$ make cp Simple.pm blib/lib/Net/IMAP/Simple.pm cp SimpleX.pm blib/lib/Net/IMAP/SimpleX.pm cp SimpleX.pod blib/lib/Net/IMAP/SimpleX.pod cp Simple.pod blib/lib/Net/IMAP/Simple.pod cp lib/Net/IMAP/Simple/PipeSocket.pm blib/lib/Net/IMAP/Simple/PipeSocket.pm Manifying blib/man3/Net::IMAP::SimpleX.3 Manifying blib/man3/Net::IMAP::Simple.3 Manifying blib/man3/Net::IMAP::Simple::PipeSocket.3 tom@roku:~/.cpan/build/Net-IMAP-Simple-1.2030-U5PTEH$ make test PERL_DL_NONLAZY=1 /home/tom/perl5/perlbrew/perls/perl-5.14.2/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t t/01_load.t .......................... ok t/07_select_and_examine.t ............ Failed 21/23 subtests * OK inc/Net/IMAP/Server.pm (1.27) t/08_selectalot.t .................... Failed 3/3 subtests * OK inc/Net/IMAP/Server.pm (1.27) t/09_concurrent_connections_new.t .... 1/5 # Failed test 1 in t/09_concurrent_connections_new.t at line 19 * OK inc/Net/IMAP/Server.pm (1.27) # t/09_concurrent_connections_new.t line 19 is: ok( $c->() ); ^Cmake: *** [test_dynamic] Interrupt --- interrupted tests here in order to run them manually tom@roku:~/.cpan/build/Net-IMAP-Simple-1.2030-U5PTEH$ ps auxw | grep -i imap tom 20092 0.0 0.1 101500 19272 ? S 22:39 0:00 Net::IMAP::Server(20092) tom 20149 0.0 0.0 8960 864 pts/22 R+ 22:40 0:00 grep -i imap tom@roku:~/.cpan/build/Net-IMAP-Simple-1.2030-U5PTEH$ kill 20092 tom@roku:~/.cpan/build/Net-IMAP-Simple-1.2030-U5PTEH$ perl -Ilib t/01_load.t 1..1 # Running under perl version 5.014002 for linux # Current time local: Sun Mar 4 22:42:43 2012 # Current time GMT: Sun Mar 4 22:42:43 2012 # Using Test.pm version 1.25 ok 1 tom@roku:~/.cpan/build/Net-IMAP-Simple-1.2030-U5PTEH$ perl -Ilib t/07_select_and_examine.t 1..23 # Running under perl version 5.014002 for linux # Current time local: Sun Mar 4 22:42:46 2012 # Current time GMT: Sun Mar 4 22:42:46 2012 # Using Test.pm version 1.25 ok 1 * OK inc/Net/IMAP/Server.pm (1.27) ok 2 tom@roku:~/.cpan/build/Net-IMAP-Simple-1.2030-U5PTEH$ perl -Ilib t/08_selectalot.t 1..3 # Running under perl version 5.014002 for linux # Current time local: Sun Mar 4 22:42:58 2012 # Current time GMT: Sun Mar 4 22:42:58 2012 # Using Test.pm version 1.25 tom@roku:~/.cpan/build/Net-IMAP-Simple-1.2030-U5PTEH$ perl -Ilib t/09_concurrent_connections_new.t 1..5 # Running under perl version 5.014002 for linux # Current time local: Sun Mar 4 22:43:23 2012 # Current time GMT: Sun Mar 4 22:43:23 2012 # Using Test.pm version 1.25 not ok 1 * OK inc/Net/IMAP/Server.pm (1.27) # Failed test 1 in t/09_concurrent_connections_new.t at line 19 # t/09_concurrent_connections_new.t line 19 is: ok( $c->() ); not ok 2 # Failed test 2 in t/09_concurrent_connections_new.t at line 20 # t/09_concurrent_connections_new.t line 20 is: ok( $c->() ); not ok 3 # Failed test 3 in t/09_concurrent_connections_new.t at line 21 # t/09_concurrent_connections_new.t line 21 is: ok( $c->() ); not ok 4 # Failed test 4 in t/09_concurrent_connections_new.t at line 22 # t/09_concurrent_connections_new.t line 22 is: ok( $c->() ); ok 5
Subject: formal-imap-server.log
2012/03/04-22:39:00 Net::IMAP::Server (type Net::Server::Coro) starting! pid(20034) Using default listen value of 128 Binding to TCP port 19794 on host * Binding to TCP port 19795 on host * Group Not Defined. Defaulting to EGID '1000 0 4 6 20 24 29 46 105 119 122 125 1000' User Not Defined. Defaulting to EUID '1000' 2012/03/04-22:39:01 CONNECT TCP Peer: "127.0.0.1:37374" Local: "127.0.0.1:19794" S(t::Connection=HASH(0x2a07a48),???,unselected): * OK Net::IMAP::Simple Test Server (1) -(t::Connection=HASH(0x2a07a48),???,unselected): Connection closed by remote host 2012/03/04-22:39:01 CONNECT TCP Peer: "127.0.0.1:37375" Local: "127.0.0.1:19794" S(t::Connection=HASH(0x2a07dc0),???,unselected): * OK Net::IMAP::Simple Test Server (1) C(t::Connection=HASH(0x2a07dc0),???,unselected): 0 LOGIN bad "login" S(t::Connection=HASH(0x2a07dc0),???,unselected): 0 NO Login is disabled -(t::Connection=HASH(0x2a07dc0),???,unselected): Connection closed by remote host 2012/03/04-22:39:07 CONNECT TCP Peer: "127.0.0.1:37378" Local: "127.0.0.1:19794" S(t::Connection=HASH(0x267c3e8),???,unselected): * OK Net::IMAP::Simple Test Server (1) C(t::Connection=HASH(0x267c3e8),???,unselected): 1 Shutdown 2012/03/04-22:39:07 Net::IMAP::Server (type Net::Server::Coro) starting! pid(20046) Using default listen value of 128 Binding to TCP port 19794 on host * Binding to TCP port 19795 on host * Group Not Defined. Defaulting to EGID '1000 0 4 6 20 24 29 46 105 119 122 125 1000' User Not Defined. Defaulting to EUID '1000' 2012/03/04-22:39:07 CONNECT TCP Peer: "127.0.0.1:37390" Local: "127.0.0.1:19794" S(t::Connection=HASH(0x26eb810),???,unselected): * OK Net::IMAP::Simple Test Server (1) -(t::Connection=HASH(0x26eb810),???,unselected): Connection closed by remote host 2012/03/04-22:39:07 CONNECT TCP Peer: "127.0.0.1:37391" Local: "127.0.0.1:19794" S(t::Connection=HASH(0x26e4b40),???,unselected): * OK Net::IMAP::Simple Test Server (1) -(t::Connection=HASH(0x26e4b40),???,unselected): Connection closed by remote host 2012/03/04-22:39:13 CONNECT TCP Peer: "127.0.0.1:37394" Local: "127.0.0.1:19794" S(t::Connection=HASH(0x26eb558),???,unselected): * OK Net::IMAP::Simple Test Server (1) C(t::Connection=HASH(0x26eb558),???,unselected): 1 Shutdown 2012/03/04-22:39:13 Net::IMAP::Server (type Net::Server::Coro) starting! pid(20049) Using default listen value of 128 Binding to TCP port 19794 on host * Binding to TCP port 19795 on host * Group Not Defined. Defaulting to EGID '1000 0 4 6 20 24 29 46 105 119 122 125 1000' User Not Defined. Defaulting to EUID '1000' 2012/03/04-22:39:14 CONNECT TCP Peer: "127.0.0.1:37407" Local: "127.0.0.1:19794" S(t::Connection=HASH(0x2f88980),???,unselected): * OK Net::IMAP::Simple Test Server (1) -(t::Connection=HASH(0x2f88980),???,unselected): Connection closed by remote host 2012/03/04-22:39:27 Server closing! 2012/03/04-22:39:36 Net::IMAP::Server (type Net::Server::Coro) starting! pid(20092) Using default listen value of 128 Binding to TCP port 19794 on host * Binding to TCP port 19795 on host * Group Not Defined. Defaulting to EGID '1000 0 4 6 20 24 29 46 105 119 122 125 1000' User Not Defined. Defaulting to EUID '1000' 2012/03/04-22:39:37 CONNECT TCP Peer: "127.0.0.1:37415" Local: "127.0.0.1:19794" S(t::Connection=HASH(0x2d05540),???,unselected): * OK Net::IMAP::Simple Test Server (1) -(t::Connection=HASH(0x2d05540),???,unselected): Connection closed by remote host 2012/03/04-22:39:37 CONNECT TCP Peer: "127.0.0.1:37416" Local: "127.0.0.1:19794" S(t::Connection=HASH(0x2cfdfc0),???,unselected): * OK Net::IMAP::Simple Test Server (1) C(t::Connection=HASH(0x2cfdfc0),???,unselected): 0 LOGIN bad "login" S(t::Connection=HASH(0x2cfdfc0),???,unselected): 0 NO Login is disabled -(t::Connection=HASH(0x2cfdfc0),???,unselected): Connection closed by remote host 2012/03/04-22:41:45 Server closing! 2012/03/04-22:41:49 Net::IMAP::Server (type Net::Server::Coro) starting! pid(20341) Using default listen value of 128 Binding to TCP port 19794 on host * Binding to TCP port 19795 on host * Group Not Defined. Defaulting to EGID '1000 0 4 6 20 24 29 46 105 119 122 125 1000' User Not Defined. Defaulting to EUID '1000' 2012/03/04-22:41:50 CONNECT TCP Peer: "127.0.0.1:37453" Local: "127.0.0.1:19794" S(t::Connection=HASH(0x33ab910),???,unselected): * OK Net::IMAP::Simple Test Server (1) -(t::Connection=HASH(0x33ab910),???,unselected): Connection closed by remote host 2012/03/04-22:41:50 CONNECT TCP Peer: "127.0.0.1:37454" Local: "127.0.0.1:19794" S(t::Connection=HASH(0x33b7a20),???,unselected): * OK Net::IMAP::Simple Test Server (1) C(t::Connection=HASH(0x33b7a20),???,unselected): 0 LOGIN bad "login" S(t::Connection=HASH(0x33b7a20),???,unselected): 0 NO Login is disabled -(t::Connection=HASH(0x33b7a20),???,unselected): Connection closed by remote host 2012/03/04-22:42:37 Server closing! 2012/03/04-22:42:48 Net::IMAP::Server (type Net::Server::Coro) starting! pid(20493) Using default listen value of 128 Binding to TCP port 19794 on host * Binding to TCP port 19795 on host * Group Not Defined. Defaulting to EGID '1000 0 4 6 20 24 29 46 105 119 122 125 1000' User Not Defined. Defaulting to EUID '1000' 2012/03/04-22:42:49 CONNECT TCP Peer: "127.0.0.1:37477" Local: "127.0.0.1:19794" S(t::Connection=HASH(0x2e39910),???,unselected): * OK Net::IMAP::Simple Test Server (1) -(t::Connection=HASH(0x2e39910),???,unselected): Connection closed by remote host 2012/03/04-22:42:49 CONNECT TCP Peer: "127.0.0.1:37478" Local: "127.0.0.1:19794" S(t::Connection=HASH(0x2e45a20),???,unselected): * OK Net::IMAP::Simple Test Server (1) C(t::Connection=HASH(0x2e45a20),???,unselected): 0 LOGIN bad "login" S(t::Connection=HASH(0x2e45a20),???,unselected): 0 NO Login is disabled -(t::Connection=HASH(0x2e45a20),???,unselected): Connection closed by remote host 2012/03/04-22:42:59 CONNECT TCP Peer: "127.0.0.1:37482" Local: "127.0.0.1:19794" S(t::Connection=HASH(0x2e36688),???,unselected): * OK Net::IMAP::Simple Test Server (1) C(t::Connection=HASH(0x2e36688),???,unselected): 1 Shutdown 2012/03/04-22:42:59 Net::IMAP::Server (type Net::Server::Coro) starting! pid(20510) Using default listen value of 128 Binding to TCP port 19794 on host * Binding to TCP port 19795 on host * Group Not Defined. Defaulting to EGID '1000 0 4 6 20 24 29 46 105 119 122 125 1000' User Not Defined. Defaulting to EUID '1000' 2012/03/04-22:43:00 CONNECT TCP Peer: "127.0.0.1:37495" Local: "127.0.0.1:19794" S(t::Connection=HASH(0x3655838),???,unselected): * OK Net::IMAP::Simple Test Server (1) -(t::Connection=HASH(0x3655838),???,unselected): Connection closed by remote host 2012/03/04-22:43:00 CONNECT TCP Peer: "127.0.0.1:37496" Local: "127.0.0.1:19794" S(t::Connection=HASH(0x36603f8),???,unselected): * OK Net::IMAP::Simple Test Server (1) -(t::Connection=HASH(0x36603f8),???,unselected): Connection closed by remote host 2012/03/04-22:43:24 CONNECT TCP Peer: "127.0.0.1:37504" Local: "127.0.0.1:19794" S(t::Connection=HASH(0x3655580),???,unselected): * OK Net::IMAP::Simple Test Server (1) C(t::Connection=HASH(0x3655580),???,unselected): 1 Shutdown 2012/03/04-22:43:24 Net::IMAP::Server (type Net::Server::Coro) starting! pid(20574) Using default listen value of 128 Binding to TCP port 19794 on host * Binding to TCP port 19795 on host * Group Not Defined. Defaulting to EGID '1000 0 4 6 20 24 29 46 105 119 122 125 1000' User Not Defined. Defaulting to EUID '1000' 2012/03/04-22:43:25 CONNECT TCP Peer: "127.0.0.1:37518" Local: "127.0.0.1:19794" S(t::Connection=HASH(0x1a7c7b8),???,unselected): * OK Net::IMAP::Simple Test Server (1) -(t::Connection=HASH(0x1a7c7b8),???,unselected): Connection closed by remote host 2012/03/04-22:43:50 CONNECT TCP Peer: "127.0.0.1:37531" Local: "127.0.0.1:19794" S(t::Connection=HASH(0x1a7e1c8),???,unselected): * OK Net::IMAP::Simple Test Server (1) C(t::Connection=HASH(0x1a7e1c8),???,unselected): 1 Shutdown
Subject: Re: [rt.cpan.org #75514] Test failures and daemon process left active after testing
Date: Sun, 4 Mar 2012 18:21:42 -0500
To: bug-Net-IMAP-Simple [...] rt.cpan.org
From: Paul Miller <paul [...] voltar.org>
Download (untitled) / with headers
text/plain 6.1k
That's much worse looking than I expected. Is that on a roku? -- message brief, sent from phone On Mar 4, 2012 5:56 PM, "Thomas Edward Alexander Molesworth via RT" < bug-Net-IMAP-Simple@rt.cpan.org> wrote: Show quoted text
> Queue: Net-IMAP-Simple > Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=75514 > > > On Sun Mar 04 17:37:18 2012, paul@voltar.org wrote:
> > The tests should log most things they do. Doesn't show up on the testers > > output. Certainly send them. Though, these aren't really package bugs. > > They're just portability errors in the tests.
> > I've attached the output from running the first few tests directly via > perl, rather than going through prove, in case that was causing > additional issues. The informal-*.log files are empty. My guess is that > the make test failures are due to the daemon still running after the > first test so the next attempt to bind to the port fails, although if > that's the case I'm not sure why the first few tests are okay when run > manually. > > As I say, this is just something I'm reporting for completeness, so if > you're satisfied that it's purely due to environment rather than > anything wrong with the package itself, feel free to close this RT. > > cheers, > > Tom > > > cpan[2]> look Net::IMAP::Simple > Running look for module 'Net::IMAP::Simple' > > Trying to open a subshell in the build directory... > Checksum for > /home/tom/.cpan/sources/authors/id/J/JE/JETTERO/Net-IMAP-Simple-1.2030.tar.gz > ok > Working directory is /home/tom/.cpan/build/Net-IMAP-Simple-1.2030-U5PTEH > tom@roku:~/.cpan/build/Net-IMAP-Simple-1.2030-U5PTEH$ dir > total 136 > drwxr-x--- 2 tom tom 4096 2012-02-06 15:06 certs/ > -rw-r--r-- 1 tom tom 18547 2012-02-06 15:05 Changes > drwxr-x--- 2 tom tom 4096 2012-02-06 15:06 contrib/ > drwxr-x--- 3 tom tom 4096 2012-02-06 15:06 inc/ > drwxr-x--- 3 tom tom 4096 2012-02-06 15:06 lib/ > -rw-r--r-- 1 tom tom 2629 2011-09-02 19:35 Makefile.PL > -rw-r--r-- 1 tom tom 2478 2012-02-06 15:06 MANIFEST > -rw-r----- 1 tom tom 1689 2012-02-06 15:06 META.json > -rw-r----- 1 tom tom 960 2012-02-06 15:06 META.yml > -rw-r--r-- 1 tom tom 589 2010-10-29 14:09 README > -rw-r--r-- 1 tom tom 32602 2012-02-06 14:43 Simple.pm > -rw-r--r-- 1 tom tom 30064 2012-01-25 19:25 Simple.pod > -rwxr-xr-x 1 tom tom 95 2010-10-29 14:09 start_server.sh* > -rwxr-xr-x 1 tom tom 96 2010-10-29 14:09 stop_server.sh* > drwxr-x--- 2 tom tom 4096 2012-02-06 15:06 t/ > -rw-r--r-- 1 tom tom 212 2010-10-29 14:09 TODO > tom@roku:~/.cpan/build/Net-IMAP-Simple-1.2030-U5PTEH$ perl Makefile.PL > Do you wish to include some simple protocol extensions (pulls in > Parse::RecDescent)? [y] y > Checking if your kit is complete... > Looks good > Writing Makefile for Net::IMAP::Simple > Writing MYMETA.yml and MYMETA.json > tom@roku:~/.cpan/build/Net-IMAP-Simple-1.2030-U5PTEH$ make > cp Simple.pm blib/lib/Net/IMAP/Simple.pm > cp SimpleX.pm blib/lib/Net/IMAP/SimpleX.pm > cp SimpleX.pod blib/lib/Net/IMAP/SimpleX.pod > cp Simple.pod blib/lib/Net/IMAP/Simple.pod > cp lib/Net/IMAP/Simple/PipeSocket.pm blib/lib/Net/IMAP/Simple/PipeSocket.pm > Manifying blib/man3/Net::IMAP::SimpleX.3 > Manifying blib/man3/Net::IMAP::Simple.3 > Manifying blib/man3/Net::IMAP::Simple::PipeSocket.3 > tom@roku:~/.cpan/build/Net-IMAP-Simple-1.2030-U5PTEH$ make test > PERL_DL_NONLAZY=1 /home/tom/perl5/perlbrew/perls/perl-5.14.2/bin/perl > "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" > t/*.t > t/01_load.t .......................... ok > t/07_select_and_examine.t ............ Failed 21/23 subtests > > * OK inc/Net/IMAP/Server.pm (1.27) > t/08_selectalot.t .................... Failed 3/3 subtests > > * OK inc/Net/IMAP/Server.pm (1.27) > t/09_concurrent_connections_new.t .... 1/5 # Failed test 1 in > t/09_concurrent_connections_new.t at line 19 > * OK inc/Net/IMAP/Server.pm (1.27) > # t/09_concurrent_connections_new.t line 19 is: ok( $c->() ); > ^Cmake: *** [test_dynamic] Interrupt > > --- interrupted tests here in order to run them manually > > tom@roku:~/.cpan/build/Net-IMAP-Simple-1.2030-U5PTEH$ ps auxw | grep -i > imap > tom 20092 0.0 0.1 101500 19272 ? S 22:39 0:00 > Net::IMAP::Server(20092) > tom 20149 0.0 0.0 8960 864 pts/22 R+ 22:40 0:00 grep -i > imap > tom@roku:~/.cpan/build/Net-IMAP-Simple-1.2030-U5PTEH$ kill 20092 > tom@roku:~/.cpan/build/Net-IMAP-Simple-1.2030-U5PTEH$ perl -Ilib > t/01_load.t > 1..1 > # Running under perl version 5.014002 for linux > # Current time local: Sun Mar 4 22:42:43 2012 > # Current time GMT: Sun Mar 4 22:42:43 2012 > # Using Test.pm version 1.25 > ok 1 > tom@roku:~/.cpan/build/Net-IMAP-Simple-1.2030-U5PTEH$ perl -Ilib > t/07_select_and_examine.t > 1..23 > # Running under perl version 5.014002 for linux > # Current time local: Sun Mar 4 22:42:46 2012 > # Current time GMT: Sun Mar 4 22:42:46 2012 > # Using Test.pm version 1.25 > ok 1 > > * OK inc/Net/IMAP/Server.pm (1.27) > ok 2 > tom@roku:~/.cpan/build/Net-IMAP-Simple-1.2030-U5PTEH$ perl -Ilib > t/08_selectalot.t > 1..3 > # Running under perl version 5.014002 for linux > # Current time local: Sun Mar 4 22:42:58 2012 > # Current time GMT: Sun Mar 4 22:42:58 2012 > # Using Test.pm version 1.25 > tom@roku:~/.cpan/build/Net-IMAP-Simple-1.2030-U5PTEH$ perl -Ilib > t/09_concurrent_connections_new.t > 1..5 > # Running under perl version 5.014002 for linux > # Current time local: Sun Mar 4 22:43:23 2012 > # Current time GMT: Sun Mar 4 22:43:23 2012 > # Using Test.pm version 1.25 > not ok 1 > > * OK inc/Net/IMAP/Server.pm (1.27) > # Failed test 1 in t/09_concurrent_connections_new.t at line 19 > # t/09_concurrent_connections_new.t line 19 is: ok( $c->() ); > not ok 2 > # Failed test 2 in t/09_concurrent_connections_new.t at line 20 > # t/09_concurrent_connections_new.t line 20 is: ok( $c->() ); > not ok 3 > # Failed test 3 in t/09_concurrent_connections_new.t at line 21 > # t/09_concurrent_connections_new.t line 21 is: ok( $c->() ); > not ok 4 > # Failed test 4 in t/09_concurrent_connections_new.t at line 22 > # t/09_concurrent_connections_new.t line 22 is: ok( $c->() ); > ok 5 > > >
On Sun Mar 04 18:21:53 2012, paul@voltar.org wrote: Show quoted text
> That's much worse looking than I expected. Is that on a roku?
ah, that's just the hostname - it's an Ubuntu 10.10 system: tom@roku:~$ uname -a Linux roku 2.6.35-30-generic #61-Ubuntu SMP Tue Oct 11 17:52:57 UTC 2011 x86_64 GNU/Linux tom@roku:~$ cat /etc/lsb-release DISTRIB_ID=Ubuntu DISTRIB_RELEASE=10.10 DISTRIB_CODENAME=maverick DISTRIB_DESCRIPTION="Ubuntu 10.10" It's using a perlbrew-compiled 5.14.2 with threads disabled. Can't think of anything else particularly unusual about this system but if you think it's worth pursuing I can try setting up an equivalent system in a VM to see if it's easy to reproduce this situation. The note about Parse::RecDescent did make me wonder whether this might be related to https://rt.cpan.org/Public/Bug/Display.html?id=74733, but tried with both module versions mentioned in that bug with the same results each time. (I'm on irc.perl.org as tom_m and irc.freenode.net/#perl as tm604 if that's easier for you, by the way) cheers, Tom
Subject: Re: [rt.cpan.org #75514] Test failures and daemon process left active after testing
Date: Sun, 4 Mar 2012 18:37:05 -0500
To: bug-Net-IMAP-Simple [...] rt.cpan.org
From: Paul Miller <paul [...] voltar.org>
Download (untitled) / with headers
text/plain 1.4k
I'm sure I can reproduce the end... What I don't have is time... I'll look at parse recdescent this week. I wonder if that's related. -- message brief, sent from phone On Mar 4, 2012 6:28 PM, "Thomas Edward Alexander Molesworth via RT" < bug-Net-IMAP-Simple@rt.cpan.org> wrote: Show quoted text
> Queue: Net-IMAP-Simple > Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=75514 > > > On Sun Mar 04 18:21:53 2012, paul@voltar.org wrote:
> > That's much worse looking than I expected. Is that on a roku?
> > ah, that's just the hostname - it's an Ubuntu 10.10 system: > > tom@roku:~$ uname -a > Linux roku 2.6.35-30-generic #61-Ubuntu SMP Tue Oct 11 17:52:57 UTC 2011 > x86_64 GNU/Linux > > tom@roku:~$ cat /etc/lsb-release > DISTRIB_ID=Ubuntu > DISTRIB_RELEASE=10.10 > DISTRIB_CODENAME=maverick > DISTRIB_DESCRIPTION="Ubuntu 10.10" > > It's using a perlbrew-compiled 5.14.2 with threads disabled. Can't think > of anything else particularly unusual about this system but if you think > it's worth pursuing I can try setting up an equivalent system in a VM to > see if it's easy to reproduce this situation. The note about > Parse::RecDescent did make me wonder whether this might be related to > https://rt.cpan.org/Public/Bug/Display.html?id=74733, but tried with > both module versions mentioned in that bug with the same results each time. > > (I'm on irc.perl.org as tom_m and irc.freenode.net/#perl as tm604 if > that's easier for you, by the way) > > cheers, > > Tom > >
Subject: Re: [rt.cpan.org #75514] Test failures and daemon process left active after testing
Date: Sun, 4 Mar 2012 18:38:34 -0500
To: bug-Net-IMAP-Simple [...] rt.cpan.org
From: Paul Miller <jettero [...] cpan.org>
Download (untitled) / with headers
text/plain 435b
er, environment. autocorrect seems necessary with touch screens, but it's also something of a misfeature. If you can't replace things 100% correctly, you probably shouldn't change the input without some action from the operator. Show quoted text
> I'm sure I can reproduce the end... What I don't have is time...
-- If riding in an airplane is flying, then riding in a boat is swimming. 116 jumps, 48.6 minutes of freefall, 92.9 freefall miles.
Download (untitled) / with headers
text/plain 259b
I pretty much forgot about this. I really have no idea how to fix it, other than deleting/disabling most of the test suite. -- If riding in an airplane is flying, then riding in a boat is swimming. 116 jumps, 48.6 minutes of freefall, 92.9 freefall miles.
Download (untitled) / with headers
text/plain 540b
Show quoted text
> I pretty much forgot about this. I really have no idea how to fix it, > other than deleting/disabling most of the test suite.
I should ask too: Do you have any suggestions for repairing it? I'm really honestly thinking about disabling most of the test suite. It causes problems for people and I really haven't learned anything from it by running it all over the place -- it's more of a build tool. -- If riding in an airplane is flying, then riding in a boat is swimming. 116 jumps, 48.6 minutes of freefall, 92.9 freefall miles.
Download (untitled) / with headers
text/plain 284b
I'm just going to remove the initial module load. I think that will "fix" it by obviating the SSL library unload (or whatever the hell causes the problems on some machines, but never mine). Please be sure to test 1.2034_2 when it appears on the cpan and reopen if it doesn't "fix" it.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.