Skip Menu |
 

This queue is for tickets about the XML-LibXML CPAN distribution.

Report information
The Basics
Id: 75293
Status: resolved
Priority: 0/
Queue: XML-LibXML

People
Owner: Nobody in particular
Requestors: d.thomas [...] its.uq.edu.au
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 1.92
Fixed in: (no value)



Subject: XML-LibXML 1.92 equality also breaks XML-Compile
Download (untitled) / with headers
text/plain 522b
I got the same errors for XML::compile as reported in http://www.cpantesters.org/cpan/report/c78b4e30-5e1a-11e1-b881-a13064a970dd but I'm using perl 5.14.2, RHEL6.2 with Test::Deep version 0.109 XML::LibXML version 1.92 Math::BigInt version 1.994 XML::Compile version 1.24 XML::Compile::SOAP not installed XML::Compile::Tester version 0.06 XML::Compile::Dumper not installed XML::Compile::Cache not installed I found the tests PASSed with XML::LibXML 1.88, 1.90, 1.91 but failed when then going to 1.92
Download (untitled) / with headers
text/plain 358b
On Sat Feb 25 00:19:53 2012, d.thomas@its.uq.edu.au wrote: Show quoted text
> I found the tests PASSed with XML::LibXML 1.88, 1.90, 1.91 but > failed when then going to 1.92
It probably was also broken in 1.91, and is exactly the same issue as the other: with overloading the ::Element, the comparison got broken. Of course you can implement a really efficient comparison.
From: raherh [...] gmail.com
Download (untitled) / with headers
text/plain 725b
On Sat Feb 25 00:19:53 2012, d.thomas@its.uq.edu.au wrote: Show quoted text
> I got the same errors for XML::compile as reported in > http://www.cpantesters.org/cpan/report/c78b4e30-5e1a-11e1-b881- > a13064a970dd > but I'm using perl 5.14.2, RHEL6.2 with > Test::Deep version 0.109 > XML::LibXML version 1.92 > Math::BigInt version 1.994 > XML::Compile version 1.24 > XML::Compile::SOAP not installed > XML::Compile::Tester version 0.06 > XML::Compile::Dumper not installed > XML::Compile::Cache not installed > > I found the tests PASSed with XML::LibXML 1.88, 1.90, 1.91 but > failed when then going to 1.92
Same here with Ubuntu and perl 5.14.2 while installing XML::Compile. It does install with XML::LibXML v1.90.
Subject: Re: [rt.cpan.org #75293] XML-LibXML 1.92 equality also breaks XML-Compile
Date: Sun, 26 Feb 2012 00:00:37 +0000
To: "<bug-XML-LibXML [...] rt.cpan.org>" <bug-XML-LibXML [...] rt.cpan.org>
From: Danny Thomas <d.thomas [...] its.uq.edu.au>
Download (untitled) / with headers
text/plain 170b
On 25/02/2012, at 11:22 PM, Mark Overmeer via RT wrote: Show quoted text
> It probably was also broken in 1.91
I meant to update the report when I found same problem with 1.90 Danny
Download (untitled) / with headers
text/plain 175b
This is one of three duplicate reports and it should be fixed in XML-LibXML-1.93 that was just uploaded to CPAN. Please reopen by commenting again, if there are more problems.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.