Skip Menu |
 

This queue is for tickets about the XML-Twig CPAN distribution.

Report information
The Basics
Id: 7523
Status: resolved
Priority: 0/
Queue: XML-Twig

People
Owner: Nobody in particular
Requestors: ctrese [...] oneil.com
Cc:
AdminCc:

Bug Information
Severity: Critical
Broken in: 3.15
Fixed in: 3.16



Subject: syntax error under Win32
Download (untitled) / with headers
text/plain 1.2k
== XML::Twig 3.14 == This is perl, v5.8.4 built for MSWin32-x86-multi-thread == Undefined subroutine &XML::Twig::encode called at D:/Perl/site/lib/XML/Twig.pm line 3343. == Need to add "use Encode qw( encode );" == OS Name: Microsoft Windows XP Professional OS Version: 5.1.2600 Service Pack 1 Build 2600 OS Manufacturer: Microsoft Corporation OS Configuration: Member Workstation OS Build Type: Multiprocessor Free Registered Owner: O'Neil Workstation Registered Organization: O'Neil & Associates, Inc. Original Install Date: 6/10/2003, 9:12:19 AM System Up Time: 4 Days, 22 Hours, 9 Minutes, 0 Seconds System Manufacturer: Dell Computer Corporation System Model: Precision WorkStation 450 System type: X86-based PC Processor(s): 4 Processor(s) Installed. [01]: x86 Family 15 Model 2 Stepping 7 GenuineIntel ~3056 Mhz [02]: x86 Family 15 Model 2 Stepping 7 GenuineIntel ~3056 Mhz [03]: x86 Family 15 Model 2 Stepping 7 GenuineIntel ~3056 Mhz [04]: x86 Family 15 Model 2 Stepping 7 GenuineIntel ~3056 Mhz
Download (untitled) / with headers
text/plain 480b
[guest - Mon Aug 30 13:28:14 2004]: Show quoted text
> XML::Twig 3.14 > Undefined subroutine &XML::Twig::encode called at > D:/Perl/site/lib/XML/Twig.pm line 3343. > == > Need to add "use Encode qw( encode );"
Do you have a simple test case I could run? I think the problem might be with one of the output options, but it would be quicker if you gave me the exact one ;-) I can't do 'use Encode', Encode is not required to use XML::Twig, so I just require/import it when needed. Thanks __ Mirod
Download (untitled) / with headers
text/plain 651b
[MIROD - Mon Aug 30 18:14:26 2004]: Show quoted text
> [guest - Mon Aug 30 13:28:14 2004]: >
> > XML::Twig 3.14 > > Undefined subroutine &XML::Twig::encode called at > > D:/Perl/site/lib/XML/Twig.pm line 3343. > > == > > Need to add "use Encode qw( encode );"
> > Do you have a simple test case I could run? I think the problem might be > with one of the output options, but it would be quicker if you gave me > the exact one ;-) > I can't do 'use Encode', Encode is not required to use XML::Twig, so I > just require/import it when needed.
The development version at http://xmltwig.com/xmltwig/ should be fixed. Let me know if it works for you. Thanks -- Mirod


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.