|Subject:||Should not depend on whatever EUMM version it was released with|
I discovered today that:
Unintentionally infers a dependency on ExtUtils::MakeMaker 6.63_02 , due to Tom releasing his dist under perl 5.15.8 .
This is decidedly unwanted behaviour, as the latest stable version on ExtUtils::MakeMaker on CPAN is version 6.59, and there's nothing intrinsically special about his dist that makes it need 6.59, and there's nothing magical being done by MI that would suggest EUMM 6.63_02 is really necessary.
So, as a result of discussing this with tom, ribasushi and leont ( on #catalyst and #toolchain ), I was placed under the impression that the "sane" thing to do here is place a fixed requirement on 6.59 , both in the generated build_requires / configure_requires , and in the 'requires' for MI itself.
There was a little umming and aahing as to whether or not to completely strip out the perl 5.005 and lower back-compat code and just state the sane mentality that that platform now is pretty much deemed "broken" anyway, but its been left in anyway.
Attached Patch replaces the "use the current EUMM" logic with "use 6.59" and also places an install dep on EUMM 6.59.
The patch is in git format vs a git-svn'd copy of; , but hopefully that doesn't pose any complications.