Skip Menu |
 

This queue is for tickets about the REST-Client CPAN distribution.

Report information
The Basics
Id: 75012
Status: resolved
Priority: 0/
Queue: REST-Client

People
Owner: Nobody in particular
Requestors: w.wonton [...] gmail.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: REST::Client depends on a version of Test::More greater than 0.7
Date: Tue, 14 Feb 2012 15:39:37 -0800
To: bug-REST-Client [...] rt.cpan.org
From: Winston <w.wonton [...] gmail.com>
When installing REST::Client with Test::More version = 0.7, the install fails with: Writing Makefile for REST::Client Writing MYMETA.yml and MYMETA.json cp lib/REST/Client.pm blib/lib/REST/Client.pm Manifying blib/man3/REST::Client.3pm MCRAWFOR/REST-Client-243.tar.gz /usr/bin/make -- OK Running make test PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0, 'inc', 'blib/lib', 'blib/arch')" t/*.t t/basic....You tried to run a test without a plan at t/basic.t line 23. t/basic....dubious Test returned status 255 (wstat 65280, 0xff00) FAILED--1 test script could be run, alas--no output ever seen make: *** [test_dynamic] Error 255 MCRAWFOR/REST-Client-243.tar.gz /usr/bin/make test -- NOT OK //hint// to see the cpan-testers results for installing this module, try: reports MCRAWFOR/REST-Client-243.tar.gz Running make install make test had returned bad status, won't install without force Failed during this command: MCRAWFOR/REST-Client-243.tar.gz : make_test NO adding a dependency for a newer version should avoid this issue
Updated to require at least 0.8 in REST-Client-245


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.