Skip Menu |
 

Preferred bug tracker

Please visit the preferred bug tracker to report your issue.

This queue is for tickets about the Chart-Clicker CPAN distribution.

Report information
The Basics
Id: 74952
Status: open
Priority: 0/
Queue: Chart-Clicker

People
Owner: Nobody in particular
Requestors: GWS [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Important
Broken in: 2.76
Fixed in: (no value)



Subject: Tick labels are not shown at all
Download (untitled) / with headers
text/plain 502b
I never get any labels on the axis ticks. Since other text (axis labels, legend) come out ok, I assume this has nothing to do with possibly broken dependencies, but rather originates from Chart::Clicker itself. E.g., using the example for stacked lines from https://github.com/gphat/chart-clicker-examples/blob/master/line/stacked-line.pl, I get the attached image (whereas the reference version on github shows a perfectly formatted graph). For the reference, I'm running under Perl 5.14 on Windows 7.
Subject: stacked-line.png
Download stacked-line.png
image/png 17.9k
stacked-line.png
Download (untitled) / with headers
text/plain 324b
In the meantime I waded through several MB of self-inflicted debug output. I followed it down to the point within Graphics::Primitive::Driver::Cairo, The device coordinates for displaying the tick labels still seem to be quite OK. Font and colour setup at least *seem* to be ok. But still they don't show up. I'm stymied.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.