Skip Menu |
 

This queue is for tickets about the Bit-Vector CPAN distribution.

Report information
The Basics
Id: 74488
Status: open
Priority: 0/
Queue: Bit-Vector

People
Owner: Nobody in particular
Requestors: cpan698301 [...] mstier.de
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: 7.1
Fixed in: (no value)



Subject: module build fails for perl 5.15.7, in SLE 11 SP1 (OBS chroot)
Download (untitled) / with headers
text/plain 1.4k
perl Makefile.PL PREFIX=\/opt\/perl\-devel Checking if your kit is complete... Looks good Writing Makefile for Bit::Vector Writing MYMETA.yml and MYMETA.json Writing patchlevel.h for /opt/perl-devel/bin/perl (5.015007) executing cmd: make cp lib/Bit/Vector/Overload.pm blib/lib/Bit/Vector/Overload.pm cp Vector.pm blib/lib/Bit/Vector.pm cp Vector.pod blib/lib/Bit/Vector.pod cp lib/Bit/Vector/String.pod blib/lib/Bit/Vector/String.pod cp lib/Bit/Vector/Overload.pod blib/lib/Bit/Vector/Overload.pod cp lib/Bit/Vector/String.pm blib/lib/Bit/Vector/String.pm cc -c -fPIC -I/opt/perl-devel/include -DPERL_USE_SAFE_PUTENV -fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -O2 -DVERSION=\"7.1\" -DXS_VERSION=\"7.1\" -fPIC "-I/opt/perl-devel/lib/5.15.7/x86_64-linux/CORE" BitVector.c /opt/perl-devel/bin/perl /opt/perl-devel/lib/5.15.7/ExtUtils/xsubpp -typemap /opt/perl-devel/lib/5.15.7/ExtUtils/typemap -typemap typemap Vector.xs > Vector.xsc && mv Vector.xsc Vector.c cc -c -fPIC -I/opt/perl-devel/include -DPERL_USE_SAFE_PUTENV -fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -O2 -DVERSION=\"7.1\" -DXS_VERSION=\"7.1\" -fPIC "-I/opt/perl-devel/lib/5.15.7/x86_64-linux/CORE" Vector.c In file included from BitVector.h:16, from Vector.xs:34: ToolBox.h:96: error: expected identifier before numeric constant make: *** [Vector.o] Error 1
Download (untitled) / with headers
text/plain 1.6k
This is the same as #71052. On Sat Jan 28 21:12:48 2012, https://www.google.com/accounts/o8/id?id=AItOawkyOHx-- RP0sCuxSqimRLgFJ_YPC6QRWZk wrote: Show quoted text
> perl Makefile.PL PREFIX=\/opt\/perl\-devel > Checking if your kit is complete... > Looks good > Writing Makefile for Bit::Vector > Writing MYMETA.yml and MYMETA.json > Writing patchlevel.h for /opt/perl-devel/bin/perl (5.015007) > executing cmd: make > cp lib/Bit/Vector/Overload.pm blib/lib/Bit/Vector/Overload.pm > cp Vector.pm blib/lib/Bit/Vector.pm > cp Vector.pod blib/lib/Bit/Vector.pod > cp lib/Bit/Vector/String.pod blib/lib/Bit/Vector/String.pod > cp lib/Bit/Vector/Overload.pod blib/lib/Bit/Vector/Overload.pod > cp lib/Bit/Vector/String.pm blib/lib/Bit/Vector/String.pm > cc -c -fPIC -I/opt/perl-devel/include -DPERL_USE_SAFE_PUTENV > -fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include > -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -O2 -DVERSION=\"7.1\" > -DXS_VERSION=\"7.1\" -fPIC > "-I/opt/perl-devel/lib/5.15.7/x86_64-linux/CORE" BitVector.c > /opt/perl-devel/bin/perl /opt/perl-devel/lib/5.15.7/ExtUtils/xsubpp > -typemap /opt/perl-devel/lib/5.15.7/ExtUtils/typemap -typemap typemap > Vector.xs > Vector.xsc && mv Vector.xsc Vector.c > cc -c -fPIC -I/opt/perl-devel/include -DPERL_USE_SAFE_PUTENV > -fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include > -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -O2 -DVERSION=\"7.1\" > -DXS_VERSION=\"7.1\" -fPIC > "-I/opt/perl-devel/lib/5.15.7/x86_64-linux/CORE" Vector.c > In file included from BitVector.h:16, > from Vector.xs:34: > ToolBox.h:96: error: expected identifier before numeric constant > make: *** [Vector.o] Error 1


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.