Skip Menu |
 

This queue is for tickets about the POE-Declare CPAN distribution.

Report information
The Basics
Id: 74474
Status: resolved
Priority: 0/
Queue: POE-Declare

People
Owner: Nobody in particular
Requestors: ANDK [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: 0.58
Fixed in: (no value)



Subject: if ( defined @{"$callpkg\::ISA"} ) { # now warns with bleadperl
Download (untitled) / with headers
text/plain 372b
New warning in bleadperl breaks your nowarnings test. The cited code in the subject line is from lib/POE/Declare.pm line 288. Related tickets: https://rt.cpan.org/Ticket/Display.html?id=74234 https://rt.cpan.org/Ticket/Display.html?id=74342 and many more Sample fail report: http://www.cpantesters.org/cpan/report/921bf4de-4097-11e1-b69c-310a9aeef8c6 HTH && Regards,
Subject: Re: [rt.cpan.org #74474] if ( defined @{"$callpkg\::ISA"} ) { # now warns with bleadperl
Date: Mon, 26 Mar 2012 20:01:33 +0100
To: bug-POE-Declare [...] rt.cpan.org
From: Zefram <zefram [...] fysh.org>
I see that this was fixed in POE-Declare 0.59, released in February. -zefram


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.