Skip Menu |
 

This queue is for tickets about the Dist-Zilla-Plugin-ReportVersions-Tiny CPAN distribution.

Maintainer(s)' notes

This module is deprecated!

This distribution has reached end-of-life now that better alternatives exist.

The recommended alternative is Dist::Zilla::Plugin::Test::ReportPrereqs.

Report information
The Basics
Id: 74394
Status: open
Priority: 0/
Queue: Dist-Zilla-Plugin-ReportVersions-Tiny

People
Owner: Nobody in particular
Requestors: xenoterracide [...] gmail.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: v5.14 error
Date: Wed, 25 Jan 2012 17:35:32 -0600
To: bugs-dist-zilla-plugin-reportversions-tiny [...] rt.cpan.org
From: Caleb Cushing <xenoterracide [...] gmail.com>
Download (untitled) / with headers
text/plain 216b
Argument "v5.14" isn't numeric in numeric gt (>) at /home/ccushing/perl5/perlbrew/perls/perl-5.14.2/lib/site_perl/5.14.2/Dist/Zilla/Plugin/ReportVersions/Tiny.pm line 108. -- Caleb Cushing http://xenoterracide.com
Download (untitled) / with headers
text/plain 448b
Le 2012-01-26 00:35:42, XENO a écrit : Show quoted text
> Argument "v5.14" isn't numeric in numeric gt (>) at > /home/ccushing/perl5/perlbrew/perls/perl- > 5.14.2/lib/site_perl/5.14.2/Dist/Zilla/Plugin/ReportVersions/Tiny.pm > line 108.
Not enough information to reproduce the issue. Please, could you submit a test file as a pull request on https://github.com/dolmen/p5-Dist-Zilla-Plugin-ReportVersions-Tiny ? -- Olivier Mengué - http://perlresume.org/DOLMEN
Download (untitled) / with headers
text/plain 702b
Le 2012-01-26 00:35:42, XENO a écrit : Show quoted text
> Argument "v5.14" isn't numeric in numeric gt (>) at > /home/ccushing/perl5/perlbrew/perls/perl- > 5.14.2/lib/site_perl/5.14.2/Dist/Zilla/Plugin/ReportVersions/Tiny.pm > line 108.
The documentation for "use" (perldoc -f use) explicitely says: Specifying VERSION as a literal of the form v5.6.1 should generally be avoided, because it leads to misleading error messages under earlier versions of Perl (that is, prior to 5.6.0) that do not support this syntax. The equivalent numeric version should be used instead. So, please use instead "use 5.014;" or provide a patch that fixes the issue. -- Olivier Mengué - http://perlresume.org/DOLMEN
Subject: Re: [rt.cpan.org #74394] v5.14 error
Date: Sat, 8 Sep 2012 21:27:35 -0500
To: bug-Dist-Zilla-Plugin-ReportVersions-Tiny [...] rt.cpan.org
From: Caleb Cushing <xenoterracide [...] gmail.com>
Download (untitled) / with headers
text/plain 1.1k
I'm not using vstring... but I can't prevent other things from doing it. I'll write a patch but it'll add a dependency on Module::Metadata, so this thing can stop evaling modules which is the real source of the issue. On Fri, Sep 7, 2012 at 2:21 PM, Olivier Mengué via RT <bug-Dist-Zilla-Plugin-ReportVersions-Tiny@rt.cpan.org> wrote: Show quoted text
> <URL: https://rt.cpan.org/Ticket/Display.html?id=74394 > > > Le 2012-01-26 00:35:42, XENO a écrit :
>> Argument "v5.14" isn't numeric in numeric gt (>) at >> /home/ccushing/perl5/perlbrew/perls/perl- >> 5.14.2/lib/site_perl/5.14.2/Dist/Zilla/Plugin/ReportVersions/Tiny.pm >> line 108.
> > The documentation for "use" (perldoc -f use) explicitely says: > > Specifying VERSION as a literal of the form v5.6.1 should > generally be avoided, because it leads to misleading error > messages under earlier versions of Perl (that is, prior to > 5.6.0) that do not support this syntax. The equivalent numeric > version should be used instead. > > So, please use instead "use 5.014;" or provide a patch that fixes the issue. > > -- > Olivier Mengué - http://perlresume.org/DOLMEN
-- Caleb Cushing http://xenoterracide.com
Subject: Re: [rt.cpan.org #74394] v5.14 error
Date: Sun, 9 Sep 2012 23:40:44 -0500
To: bug-Dist-Zilla-Plugin-ReportVersions-Tiny [...] rt.cpan.org
From: Caleb Cushing <xenoterracide [...] gmail.com>
Download (untitled) / with headers
text/plain 1.5k
I Don't remember how to reproduce this (or maybe it's been fixed) but uploading a patch to fix #76308 On Sat, Sep 8, 2012 at 9:27 PM, Caleb Cushing via RT <bug-Dist-Zilla-Plugin-ReportVersions-Tiny@rt.cpan.org> wrote: Show quoted text
> <URL: https://rt.cpan.org/Ticket/Display.html?id=74394 > > > I'm not using vstring... but I can't prevent other things from doing > it. I'll write a patch but it'll add a dependency on Module::Metadata, > so this thing can stop evaling modules which is the real source of the > issue. > > On Fri, Sep 7, 2012 at 2:21 PM, Olivier Mengué via RT > <bug-Dist-Zilla-Plugin-ReportVersions-Tiny@rt.cpan.org> wrote:
>> <URL: https://rt.cpan.org/Ticket/Display.html?id=74394 > >> >> Le 2012-01-26 00:35:42, XENO a écrit :
>>> Argument "v5.14" isn't numeric in numeric gt (>) at >>> /home/ccushing/perl5/perlbrew/perls/perl- >>> 5.14.2/lib/site_perl/5.14.2/Dist/Zilla/Plugin/ReportVersions/Tiny.pm >>> line 108.
>> >> The documentation for "use" (perldoc -f use) explicitely says: >> >> Specifying VERSION as a literal of the form v5.6.1 should >> generally be avoided, because it leads to misleading error >> messages under earlier versions of Perl (that is, prior to >> 5.6.0) that do not support this syntax. The equivalent numeric >> version should be used instead. >> >> So, please use instead "use 5.014;" or provide a patch that fixes the issue. >> >> -- >> Olivier Mengué - http://perlresume.org/DOLMEN
> > > > -- > Caleb Cushing > > http://xenoterracide.com >
-- Caleb Cushing http://xenoterracide.com
I don't plan to fix this.
Instead I'm deprecating this module and recommends Dist::Zilla::Plugin::Test::ReportPrereqs instead.

-- 
Olivier Mengué - http://perlresume.org/DOLMEN - https://gratipay.com/dolmen/


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.