Skip Menu |
 

This queue is for tickets about the PAR-Packer CPAN distribution.

Report information
The Basics
Id: 74294
Status: resolved
Priority: 0/
Queue: PAR-Packer

People
Owner: Nobody in particular
Requestors: gilles.peyroux [...] gmail.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: --gui option doesn't work anymore
Date: Mon, 23 Jan 2012 23:53:38 +0100
To: bug-PAR-Packer [...] rt.cpan.org
From: Gilles Peyroux <gilles.peyroux [...] gmail.com>
Download (untitled) / with headers
text/plain 1.1k
The --gui flag doesn't work in versions 1.010, 1.011 and 1.012. And it still works with the version 1.009. I tested using different combinations of Windows XP 32-bit, Windows 7 64-bit, Strawberry Perl, Citrus Perl, Perl 5.12 and Perl 5.14. When using it, it often fails at the end of the build process (when removing the console) with the following message: Cannot open <exe> for reading: Permission denied at <perl>/site/lib/PAR/Packer.pm line 1169 Please note that I'm the sole user on the tested machines and I have indeed full privileges on all files and on the generated binary in particular. Sometimes, randomly, it doesn't fail on the console-removing step. But when executing the generated program, the console window is still present. There's a difference though: instead of displaying the full path of the binary in the console window, it displays the full path of the binary in the PAR_TEMP folder. When using the 1.009 version, everything works perfectly. No "permission denied" error, no console window. This bug is very strange, I don't know what's going on. Hope this description can help you. Best Regards.
Download (untitled) / with headers
text/plain 343b
On 2012-01-23 17:54:07, gilles.peyroux@gmail.com wrote: Show quoted text
> The --gui flag doesn't work in versions 1.010, 1.011 and 1.012. And it > still works with the version 1.009. I tested using different
Your problem should already be fixed in the current development version. Please try http://svn.openfoundry.org/par/PAR-Packer/trunk Cheers, Roderich
Subject: Re: [rt.cpan.org #74294] --gui option doesn't work anymore
Date: Tue, 24 Jan 2012 20:17:25 +0100
To: bug-PAR-Packer [...] rt.cpan.org
From: Gilles Peyroux <gilles.peyroux [...] gmail.com>
Download (untitled) / with headers
text/plain 731b
Yes, it works like a charm! Thank you very much. Keep up your great work... :-) I'm waiting for the next release now. For the trouble ticket, I don't know how to change the status. I don't even know if it's my job to do that. Regards, Gilles. 2012/1/24 Roderich Schupp via RT <bug-PAR-Packer@rt.cpan.org>: Show quoted text
> <URL: https://rt.cpan.org/Ticket/Display.html?id=74294 > > > On 2012-01-23 17:54:07, gilles.peyroux@gmail.com wrote:
>> The --gui flag doesn't work in versions 1.010, 1.011 and 1.012. And it >> still works with the version 1.009. I tested using different
> > Your problem should already be fixed in the current development version. > Please try > > http://svn.openfoundry.org/par/PAR-Packer/trunk > > Cheers, Roderich
Download (untitled) / with headers
text/plain 383b
On 2012-01-24 14:17:55, gilles.peyroux@gmail.com wrote: Show quoted text
> Yes, it works like a charm!
Thanks for testing. Show quoted text
> I'm waiting for the next release now.
It will probably take a couple of days, there's another bug I still want to fix. Show quoted text
> For the trouble ticket, I don't know how to change the status. I don't > even know if it's my job to do that.
No, that's my job :) Cheers, Roderich


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.