Skip Menu |
 

Preferred bug tracker

Please visit the preferred bug tracker to report your issue.

This queue is for tickets about the PPI CPAN distribution.

Report information
The Basics
Id: 74234
Status: resolved
Priority: 0/
Queue: PPI

People
Owner: Nobody in particular
Requestors: ANDK [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Important
Broken in: 1.215
Fixed in: (no value)



Subject: Bleadperl v5.15.6-559-g604a99b breaks a test in ADAMK/PPI-1.215.tar.gz
From: nick [...] ccl4.org
Download (untitled) / with headers
text/plain 205b
On Sun Jan 22 06:16:55 2012, ANDK wrote: Show quoted text
Is this now fixed by your release of Class::Inspector 1.27? Nicholas Clark
Download (untitled) / with headers
text/plain 309b
On Fri Jan 27 11:05:32 2012, nick@ccl4.org wrote: Show quoted text
> On Sun Jan 22 06:16:55 2012, ANDK wrote: > > Is this now fixed by your release of Class::Inspector 1.27?
Yes (even though the question was not addressed to me).
Download (untitled) / with headers
text/plain 150b
Although Class::Inspector is now fixed, an attempt to install PPI still fails if an old C:I is installed. PPI needs to declare a prereq of C:I 1.27.
Subject: Re: [rt.cpan.org #74234] Bleadperl v5.15.6-559-g604a99b breaks a test in ADAMK/PPI-1.215.tar.gz
Date: Thu, 2 Feb 2012 14:21:57 +1100
To: bug-PPI [...] rt.cpan.org
From: Adam Kennedy <adamkennedybackup [...] gmail.com>
Download (untitled) / with headers
text/plain 474b
There are no real world cases I can think of where this will be a problem. Any 5.16 installations will not have C:I, and thus won't hit this bug. Adam On 2 February 2012 11:05, ZEFRAM via RT <bug-PPI@rt.cpan.org> wrote: Show quoted text
>       Queue: PPI >  Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=74234 > > > Although Class::Inspector is now fixed, an attempt to install PPI still > fails if an old C:I is installed.  PPI needs to declare a prereq of > C:I 1.27. >
Download (untitled) / with headers
text/plain 619b
On Wed Feb 01 22:22:05 2012, adam@ali.as wrote: Show quoted text
> There are no real world cases I can think of where this will be a problem. > > Any 5.16 installations will not have C:I, and thus won't hit this bug.
Unless they share lib directories with other perl installations. Show quoted text
> > Adam > > On 2 February 2012 11:05, ZEFRAM via RT <bug-PPI@rt.cpan.org> wrote:
> >       Queue: PPI > >  Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=74234 > > > > > Although Class::Inspector is now fixed, an attempt to install PPI still > > fails if an old C:I is installed.  PPI needs to declare a prereq of > > C:I 1.27. > >
Subject: Re: [rt.cpan.org #74234] Bleadperl v5.15.6-559-g604a99b breaks a test in ADAMK/PPI-1.215.tar.gz
Date: Thu, 2 Feb 2012 22:29:35 +1100
To: bug-PPI [...] rt.cpan.org
From: Adam Kennedy <adamkennedybackup [...] gmail.com>
Download (untitled) / with headers
text/plain 1009b
If they're doing crazy things like that, they have bigger problems. I'll fix it the first time it happens in the wild, in the mean time I really don't want to force a major version bump. Adam On 2 February 2012 17:56, Father Chrysostomos via RT <bug-PPI@rt.cpan.org> wrote: Show quoted text
>       Queue: PPI >  Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=74234 > > > On Wed Feb 01 22:22:05 2012, adam@ali.as wrote:
>> There are no real world cases I can think of where this will be a problem. >> >> Any 5.16 installations will not have C:I, and thus won't hit this bug.
> > Unless they share lib directories with other perl installations. >
>> >> Adam >> >> On 2 February 2012 11:05, ZEFRAM via RT <bug-PPI@rt.cpan.org> wrote:
>> >       Queue: PPI >> >  Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=74234 > >> > >> > Although Class::Inspector is now fixed, an attempt to install PPI still >> > fails if an old C:I is installed.  PPI needs to declare a prereq of >> > C:I 1.27. >> >
> > >
Fixed in Class::Inspector


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.