Skip Menu |
 

Preferred bug tracker

Please visit the preferred bug tracker to report your issue.

This queue is for tickets about the CPAN-Reporter CPAN distribution.

Report information
The Basics
Id: 73475
Status: resolved
Priority: 0/
Queue: CPAN-Reporter

People
Owner: Nobody in particular
Requestors: ANDK [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: 1.2003
Fixed in: (no value)



Subject: Wrong "Prerequisite version too low" report
I discovered this with bleadperl (v5.15.6-94-ga65c7ff) and can reproduce it with 5.14.2. The involved dependency chain is huge, so I would not be surprised when this cannot be reproduced anymore by the time you read this. I installed older CPAN::Reporter versions and found 1.1902 the last one that does it right, 1.19_03 had the bug already. The perls I reproduced it with had version.pm 0.95, YAML 0.77, CPAN::Reporter 2.003, HTML::FormHandler 0.35005, Test::WWW::Mechanize::Catalyst 0.56, Moose 2.0401. In the cpan shell I tried to install ZBY/Catalyst-Example-InstantCRUD-0.038.tar.gz. Some tests are failing on this. The output then is the following. Note the bogus line for HTML::FormHandler. Please let me know when you have suggestions of how to debug this. [...] Test Summary Report ------------------- t/21.test_dvdzbr.t (Wstat: 512 Tests: 7 Failed: 1) Failed test: 7 Non-zero exit status: 2 Parse errors: Bad plan. You planned 20 tests but ran 7. t/31.test_rest.t (Wstat: 256 Tests: 2 Failed: 1) Failed test: 2 Non-zero exit status: 1 Files=9, Tests=49, 14 wallclock secs ( 0.06 usr 0.01 sys + 10.66 cusr 0.72 csys = 11.45 CPU) Result: FAIL Failed 2/9 test programs. 2/49 subtests failed. make[1]: *** [test_dynamic] Error 255 make[1]: Leaving directory `/tmp/tmp.2V6nCmp6FH/Catalyst-Example-InstantCRUD-0.038-0tmh5H' (/usr/bin/make test exited with 512) CPAN::Reporter: test results were not valid, Prerequisite version too low: requires: Module Need Have ------------------------------------------ ------- ---------- Catalyst::Devel 1.00 1.36 Catalyst::Helper::Model::DBIC::Schema 0 0.59 Catalyst::Model::DBIC::Schema 0.29 0.59 Catalyst::Plugin::ConfigLoader 0 0.30 Catalyst::Plugin::Session::State::Cookie 0 0.17 Catalyst::Plugin::Session::Store::FastMmap 0 0.14 Catalyst::Plugin::Static::Simple 0 0.29 Catalyst::Plugin::Unicode 0 0.93 Catalyst::Runtime 5.80006 5.90007 Catalyst::View::TT 0.21 0.37 DBIx::Class 0.08003 0.08195_01 DBIx::Class::ResultSet::RecursiveUpdate 0 0.24 DBIx::Class::Schema::Loader 0.03 0.07015 DBIx::Class::UTF8Columns 0 0 File::Slurp 0 9999.19 ! HTML::FormHandler 0.26 broken HTML::FormHandler::Generator::DBIC 0.03 0.03 HTML::FormHandler::Model::DBIC 0.04 0.16 Lingua::EN::Inflect::Phrase 0 0.11 List::Util 0 1.23 Path::Class 0 0.24 Pod::Usage 0 1.36 String::Random 0 0.22 build_requires: [...]
Download (untitled) / with headers
text/plain 291b
As expected, I cannot reproduce this anymore. But I'll resolve the ticket with an answer to how to debug this: yourperl=________ (fill in your perl) PC=`$yourperl -MCPAN::Reporter::PrereqCheck -le 'print $INC{"CPAN/Reporter/PrereqCheck.pm"}'` echo HTML::FormHandler 0.26 | $yourperl $PC


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.