Skip Menu |
 

This queue is for tickets about the Net-HTTPS-Any CPAN distribution.

Report information
The Basics
Id: 73363
Status: resolved
Priority: 0/
Queue: Net-HTTPS-Any

People
Owner: Nobody in particular
Requestors: racke [...] linuxia.de
Cc:
AdminCc:

Bug Information
Severity: Important
Broken in: 0.10
Fixed in:
  • 0.11
  • 0.11_01



Subject: Broken tests when only one SSLeay modules is installed
Download (untitled) / with headers
text/plain 502b
Net::HTTPS::Any cannot be installed when only Net::SSLeay is installed, because that breaks the Crypt::SSLeay tests with a really confusing error message: t/get-cryptssleay.t ... 1/4 # Failed test 'use Net::HTTPS::Any;' # at t/get-cryptssleay.t line 11. # Tried to use 'Net::HTTPS::Any'. # Error: One of Net::SSLeay (v1.30 or later) or Crypt::SSLeay (+LWP) is required at /home/interchange/.cpan/build/Net-HTTPS-Any-0.10- Y8amLQ/blib/lib/Net/HTTPS/Any.pm line 38. Regards Racke


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.