Skip Menu |
 

This queue is for tickets about the Cairo CPAN distribution.

Report information
The Basics
Id: 72783
Status: resolved
Priority: 0/
Queue: Cairo

People
Owner: Nobody in particular
Requestors: SREZIC [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 1.081
Fixed in: (no value)



Subject: "use Cairo $VERSION" does not work
Download (untitled) / with headers
text/plain 525b
See subject. The usual perl way to force a minimum module version does not work here: $ perl5.12.3 -e 'use Cairo 1;' Usage: Cairo::VERSION(class=NULL) at -e line 1. BEGIN failed--compilation aborted at -e line 1. $ perl5.12.3 -e 'use Cairo 9999;' Usage: Cairo::VERSION(class=NULL) at -e line 1. BEGIN failed--compilation aborted at -e line 1. Problem seems to me that Cairo's VERSION method is not compatible with the UNIVERSAL::VERSION method, which is usually used to determine the minimum version. Regards, Slaven
Download (untitled) / with headers
text/plain 437b
On Mon Nov 28 15:28:44 2011, SREZIC wrote: Show quoted text
> Problem seems to me that Cairo's VERSION method is not compatible with > the UNIVERSAL::VERSION method, which is usually used to determine the > minimum version.
Indeed. I did not know that a VERSION sub is supposed to have special semantics. Problem now fixed on master: <http://git.gnome.org/browse/perl-Cairo/commit/?id=f4ea540acbfb5bea6e6adf39238dcf5418eb5c9b>. Thanks for the report.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.