Skip Menu |
 

This queue is for tickets about the DBD-SQLite CPAN distribution.

Report information
The Basics
Id: 7278
Status: resolved
Priority: 0/
Queue: DBD-SQLite

People
Owner: Nobody in particular
Requestors:
Cc:
AdminCc:

Bug Information
Severity: Important
Broken in: 1.02
Fixed in: (no value)



Subject: DBD-SQLite-1.02 fails to compile on FreeBSD
Download (untitled) / with headers
text/plain 799b
Compilation fails with the following error: cc -c -I/usr/local/lib/perl5/site_perl/5.8.4/mach/auto/DBI -DAPPLLIB_EXP="/usr/local/lib/perl5/5.8.4/BSDPAN" -DHAS_FPSETMASK -DHAS_FLOATINGPOINT_H -fno-strict-aliasing -I/usr/local/include -O2 -DNDEBUG=1 -DSQLITE_PTR_SZ=4 -DVERSION=\"1.02\" -DXS_VERSION=\"1.02\" -DPIC -fPIC "-I/usr/local/lib/perl5/5.8.4/mach/CORE" dbdimp.c dbdimp.c:220: error: conflicting types for 'sqlite_db_last_insert_id' /usr/local/lib/perl5/site_perl/5.8.4/mach/auto/DBI/dbd_xsh.h:36: error: previous declaration of 'sqlite_db_last_insert_id' was here dbdimp.c:220: error: conflicting types for 'sqlite_db_last_insert_id' /usr/local/lib/perl5/site_perl/5.8.4/mach/auto/DBI/dbd_xsh.h:36: error: previous declaration of 'sqlite_db_last_insert_id' was here *** Error code 1
Download (untitled) / with headers
text/plain 103b
[guest - Fri Aug 6 11:40:59 2004]: It was a bug in DBI-1.42. Upgrading to DBI-1.43 fixes the problem.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.