This queue is for tickets about the Module-Load-Conditional CPAN distribution.

Report information
The Basics
Id:
72270
Status:
rejected
Worked:
5 minutes
Users:
BINGOS: 5 minutes
Priority:
Low/Low

People
Owner:
BINGOS [...] cpan.org
Requestors:
pawel [...] azotel.com
Cc:
AdminCc:

BugTracker
Severity:
Critical
Broken in:
0.46
Fixed in:
(no value)



Subject: cpan modules does not cooperate in CentOS release 5.7
I am not sure where should I post this bug, so I am posting it under each of the modules in question. All modules are the newest version. Error does not occur in older versions of CentOS. Try to execute the script: #!/usr/bin/perl #---------THESE MODULES DOES NOT COOPERATE----# use Module::Load::Conditional qw[can_load]; use Text::CSV; use LWP::UserAgent qw(:strict); use HTTP::Request qw(:strict); #-----------------------------------------------# under CentOS release 5.7. Error you get is: "strict" is not defined in %LWP::UserAgent::EXPORT_TAGS at ./test.pl line 38 main::BEGIN() called at /usr/lib/perl5/site_perl/5.8.8/LWP/UserAgent.pm line 38 eval {...} called at /usr/lib/perl5/site_perl/5.8.8/LWP/UserAgent.pm line 38 Can't continue after import errors at ./test.pl line 38 BEGIN failed--compilation aborted at ./test.pl line 38.
Your script works fine for me on CentOS 5.7 The error reported has nothing to do with Module::Load::Conditional, so I am rejecting this ticket for this module. Many thanks.


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.