Skip Menu |

This queue is for tickets about the Perl-MinimumVersion CPAN distribution.

Report information
The Basics
Id: 72033
Status: new
Priority: 0/
Queue: Perl-MinimumVersion

Owner: Nobody in particular
Requestors: KENTNL [...]

Bug Information
Severity: Normal
Broken in: 1.28
Fixed in: (no value)

Subject: A package declaring a 3-part version should infer >=5.010
If a user elects to use a 3-part version, it comes with a caveat that you can't depend on it via a 'use PKG VERSION'
statement on older perls ( at least 5.8 is a known failure for this )

Id expect that a package declaring a version stanza like this: 

  $Test::File::ShareDir::VERSION = '0.3.0';

Would come with the implicit requirement of increasing the dependency to 5.10.0 or higher ( though the exact version required I don't know )

I hope to propose a patch for this at some stage and work out the appropriate perl version requirement, but this bug is a standin for
that in the meantime in the event somebody is more equipped to do this than I am.

Yes, I do understand there are still many places in the toolchain 3-part versions don't work, and there are many heated debates over
versioning semantics, but I hope we can at least get 3-part versions working on modern enough perls to be used respectably in the possible future
that 5.8 finally bites it.

This service is sponsored and maintained by Best Practical Solutions and runs on infrastructure.

Please report any issues with to