Skip Menu |
 

This queue is for tickets about the Test-WWW-Selenium CPAN distribution.

Report information
The Basics
Id: 71874
Status: new
Priority: 0/
Queue: Test-WWW-Selenium

People
Owner: Nobody in particular
Requestors: maitrebart [...] videotron.ca
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: Test::WWW::Selenium (1.25) fails at test phase
Date: Sun, 23 Oct 2011 13:14:48 -0400
To: bug-Test-WWW-Selenium [...] rt.cpan.org
From: Martin Lemieux <maitrebart [...] videotron.ca>
Download (untitled) / with headers
text/plain 8.6k
Hi, I was installing WWW::Selenium (1.25) with cpan and the Test::WWW::Selenium (1.25) module failed at the testing phase. So I forced the install. But for your own info, here is the output of Test::WWW::Selenium (1.25) forced installation: CPAN: Storable loaded ok (v2.20) Going to read '/home/bart/.cpan/Metadata' Database was generated on Sun, 23 Oct 2011 14:30:43 GMT Running install for module 'Test::WWW::Selenium' CPAN: YAML loaded ok (v0.71) Running make for M/MA/MATTP/Test-WWW-Selenium-1.25.tar.gz CPAN: Digest::SHA loaded ok (v5.47) CPAN: Compress::Zlib loaded ok (v2.033) Checksum for /home/bart/.cpan/sources/authors/id/M/MA/MATTP/Test-WWW-Selenium-1.25.tar.gz ok CPAN: Archive::Tar loaded ok (v1.52) Test-WWW-Selenium-1.25 Test-WWW-Selenium-1.25/README Test-WWW-Selenium-1.25/Changes Test-WWW-Selenium-1.25/pom.xml Test-WWW-Selenium-1.25/todo.txt Test-WWW-Selenium-1.25/dist.ini Test-WWW-Selenium-1.25/META.yml Test-WWW-Selenium-1.25/MANIFEST Test-WWW-Selenium-1.25/build.xml Test-WWW-Selenium-1.25/META.json Test-WWW-Selenium-1.25/weaver.ini Test-WWW-Selenium-1.25/t Test-WWW-Selenium-1.25/t/01_load.t Test-WWW-Selenium-1.25/Makefile.PL Test-WWW-Selenium-1.25/t/interweb.t Test-WWW-Selenium-1.25/t/timeouts.t Test-WWW-Selenium-1.25/mypod2html.pl Test-WWW-Selenium-1.25/t/test_i18n.t Test-WWW-Selenium-1.25/t/00-compile.t Test-WWW-Selenium-1.25/t/test_google.t Test-WWW-Selenium-1.25/t/selenium-rc.t Test-WWW-Selenium-1.25/target Test-WWW-Selenium-1.25/target/iedoc.xml Test-WWW-Selenium-1.25/t/selenium-dwim.t Test-WWW-Selenium-1.25/t/test-selenium.t Test-WWW-Selenium-1.25/t/selenium-core.t Test-WWW-Selenium-1.25/t/WWW Test-WWW-Selenium-1.25/t/WWW/Selenium.pm Test-WWW-Selenium-1.25/t/selenium-compat.t Test-WWW-Selenium-1.25/lib/WWW Test-WWW-Selenium-1.25/lib/WWW/Selenium.pm Test-WWW-Selenium-1.25/util Test-WWW-Selenium-1.25/util/XMLParseUtils.t Test-WWW-Selenium-1.25/util/test_function.pl Test-WWW-Selenium-1.25/xt/release Test-WWW-Selenium-1.25/xt/release/distmeta.t Test-WWW-Selenium-1.25/t/files Test-WWW-Selenium-1.25/t/files/test_i18n.html Test-WWW-Selenium-1.25/t/test_default_server.t Test-WWW-Selenium-1.25/util/fetch_iedoc_xml.pl Test-WWW-Selenium-1.25/xt/release/pod-syntax.t Test-WWW-Selenium-1.25/lib/WWW/Selenium Test-WWW-Selenium-1.25/lib/WWW/Selenium/Util.pm Test-WWW-Selenium-1.25/lib/Test/WWW Test-WWW-Selenium-1.25/lib/Test/WWW/Selenium.pm Test-WWW-Selenium-1.25/xt/release/portability.t Test-WWW-Selenium-1.25/xt/release/has-version.t Test-WWW-Selenium-1.25/xt/release/pod-coverage.t Test-WWW-Selenium-1.25/BUILDING_FROM_SELENIUM.txt Test-WWW-Selenium-1.25/util/create_www_selenium.pl Test-WWW-Selenium-1.25/t/files/test_click_page1.html Test-WWW-Selenium-1.25/t/files/test_click_page2.html Test-WWW-Selenium-1.25/util/WWW/Selenium Test-WWW-Selenium-1.25/util/WWW/Selenium/XMLParseUtils.pm CPAN: File::Temp loaded ok (v0.22) CPAN.pm: Going to build M/MA/MATTP/Test-WWW-Selenium-1.25.tar.gz Checking if your kit is complete... Looks good Writing Makefile for Test::WWW::Selenium cp lib/WWW/Selenium.pm blib/lib/WWW/Selenium.pm cp mypod2html.pl blib/lib/Test/WWW/mypod2html.pl cp lib/Test/WWW/Selenium.pm blib/lib/Test/WWW/Selenium.pm cp lib/WWW/Selenium/Util.pm blib/lib/WWW/Selenium/Util.pm Manifying blib/man3/WWW::Selenium.3pm Manifying blib/man3/Test::WWW::Selenium.3pm Manifying blib/man3/WWW::Selenium::Util.3pm MATTP/Test-WWW-Selenium-1.25.tar.gz /usr/bin/make -- OK Running make test PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t t/00-compile.t ........... ok t/01_load.t .............. ok t/interweb.t ............. skipped: not running live interweb tests t/selenium-compat.t ...... 1/27 # Failed test at t/WWW/Selenium.pm line 40. # got: 'cmd=getNewBrowserSession&1=*firefox&2=http%3A%2F%2Fexample.com' # expected: 'cmd=getNewBrowserSession&1=%2Afirefox&2=http%3A%2F%2Fexample.com' # Looks like you failed 1 test of 27. t/selenium-compat.t ...... Dubious, test returned 1 (wstat 256, 0x100) Failed 1/27 subtests t/selenium-core.t ........ 1/? # Failed test at t/WWW/Selenium.pm line 40. # got: 'cmd=getNewBrowserSession&1=*firefox&2=http%3A%2F%2Fexample.com' # expected: 'cmd=getNewBrowserSession&1=%2Afirefox&2=http%3A%2F%2Fexample.com' # Looks like you failed 1 test of 151. t/selenium-core.t ........ Dubious, test returned 1 (wstat 256, 0x100) Failed 1/151 subtests t/selenium-dwim.t ........ 1/30 # Failed test at t/WWW/Selenium.pm line 40. # got: 'cmd=getNewBrowserSession&1=*firefox&2=http%3A%2F%2Fexample.com' # expected: 'cmd=getNewBrowserSession&1=%2Afirefox&2=http%3A%2F%2Fexample.com' # Failed test at t/WWW/Selenium.pm line 40. # got: 'cmd=getNewBrowserSession&1=*firefox&2=http%3A%2F%2Fexample.com' # expected: 'cmd=getNewBrowserSession&1=%2Afirefox&2=http%3A%2F%2Fexample.com' # Failed test at t/WWW/Selenium.pm line 40. # got: 'cmd=getNewBrowserSession&1=*firefox&2=http%3A%2F%2Fexample.com' # expected: 'cmd=getNewBrowserSession&1=%2Afirefox&2=http%3A%2F%2Fexample.com' # Failed test at t/WWW/Selenium.pm line 40. # got: 'cmd=getNewBrowserSession&1=*firefox&2=http%3A%2F%2Fexample.com' # expected: 'cmd=getNewBrowserSession&1=%2Afirefox&2=http%3A%2F%2Fexample.com' # Failed test at t/WWW/Selenium.pm line 40. # got: 'cmd=getNewBrowserSession&1=*firefox&2=http%3A%2F%2Fexample.com' # expected: 'cmd=getNewBrowserSession&1=%2Afirefox&2=http%3A%2F%2Fexample.com' # Failed test at t/WWW/Selenium.pm line 40. # got: 'cmd=getNewBrowserSession&1=*firefox&2=http%3A%2F%2Fexample.com' # expected: 'cmd=getNewBrowserSession&1=%2Afirefox&2=http%3A%2F%2Fexample.com' # Failed test at t/WWW/Selenium.pm line 40. # got: 'cmd=getNewBrowserSession&1=*firefox&2=http%3A%2F%2Fexample.com' # expected: 'cmd=getNewBrowserSession&1=%2Afirefox&2=http%3A%2F%2Fexample.com' # Looks like you failed 7 tests of 30. t/selenium-dwim.t ........ Dubious, test returned 7 (wstat 1792, 0x700) Failed 7/30 subtests t/selenium-rc.t .......... 1/50 # Failed test at t/selenium-rc.t line 151. # got: 'cmd=getNewBrowserSession&1=*firefox&2=http%3A%2F%2Ffoo.com' # expected: 'cmd=getNewBrowserSession&1=%2Afirefox&2=http%3A%2F%2Ffoo.com' # Looks like you failed 1 test of 50. t/selenium-rc.t .......... Dubious, test returned 1 (wstat 256, 0x100) Failed 1/50 subtests t/test-selenium.t ........ ok t/test_default_server.t .. skipped: No selenium server found! t/test_google.t .......... skipped: No selenium server found! t/test_i18n.t ............ skipped: No selenium server found! t/timeouts.t ............. 1/5 # Failed test at t/WWW/Selenium.pm line 40. # got: 'cmd=getNewBrowserSession&1=*firefox&2=http%3A%2F%2Fexample.com' # expected: 'cmd=getNewBrowserSession&1=%2Afirefox&2=http%3A%2F%2Fexample.com' # Looks like you failed 1 test of 5. t/timeouts.t ............. Dubious, test returned 1 (wstat 256, 0x100) Failed 1/5 subtests Test Summary Report ------------------- t/selenium-compat.t (Wstat: 256 Tests: 27 Failed: 1) Failed test: 4 Non-zero exit status: 1 t/selenium-core.t (Wstat: 256 Tests: 151 Failed: 1) Failed test: 5 Non-zero exit status: 1 t/selenium-dwim.t (Wstat: 1792 Tests: 30 Failed: 7) Failed tests: 4, 8, 13, 17, 21, 25, 29 Non-zero exit status: 7 t/selenium-rc.t (Wstat: 256 Tests: 50 Failed: 1) Failed test: 13 Non-zero exit status: 1 t/timeouts.t (Wstat: 256 Tests: 5 Failed: 1) Failed test: 4 Non-zero exit status: 1 Files=12, Tests=332, 5 wallclock secs ( 0.21 usr 0.04 sys + 2.00 cusr 0.25 csys = 2.50 CPU) Result: FAIL Failed 5/12 test programs. 11/332 subtests failed. make: *** [test_dynamic] Error 1 MATTP/Test-WWW-Selenium-1.25.tar.gz /usr/bin/make test -- NOT OK //hint// to see the cpan-testers results for installing this module, try: reports MATTP/Test-WWW-Selenium-1.25.tar.gz Running make install Installing /usr/local/share/perl/5.10.1/Test/WWW/mypod2html.pl Installing /usr/local/share/perl/5.10.1/Test/WWW/Selenium.pm Installing /usr/local/share/perl/5.10.1/WWW/Selenium.pm Installing /usr/local/share/perl/5.10.1/WWW/Selenium/Util.pm Installing /usr/local/man/man3/Test::WWW::Selenium.3pm Installing /usr/local/man/man3/WWW::Selenium::Util.3pm Installing /usr/local/man/man3/WWW::Selenium.3pm Appending installation info to /usr/local/lib/perl/5.10.1/perllocal.pod MATTP/Test-WWW-Selenium-1.25.tar.gz /usr/bin/make install -- OK It seems that for some tests, there is a difference about '%2A' and '*' in the test output (which are in fact the same character but in a different representation). I'm using: * cpan 1.9 (1.9402) * perl 5.10.1 * ubuntu 10.4 LTS (Lucid Lynx) * linux kernel 2.6.32-34-generic
Download (untitled) / with headers
text/html 12.3k

Message body is not shown because it is too large.



This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.