Skip Menu |
 

Preferred bug tracker

Please visit the preferred bug tracker to report your issue.

This queue is for tickets about the CPAN-Reporter CPAN distribution.

Report information
The Basics
Id: 71661
Status: resolved
Priority: 0/
Queue: CPAN-Reporter

People
Owner: Nobody in particular
Requestors: xiong [...] cpan.org (daily)
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: 1.2002
Fixed in: (no value)



Subject: Way too many non-core dependencies
Download (untitled) / with headers
text/plain 642b
Hi, CPAN::Reporter has way too many dependencies. Also, before any reports can be sent, Test::Reporter::Transport::Metabase is required and that has even more dependencies, by an order of magnitude. I'm talking about setting up a fresh install of the perl interpreter and a clean, new lib/. All the time that these dependencies are installing, warnings are emitted from CPAN::Reporter. At the least, these should be suppressed. I suppose I could 'o conf' cpan and disable; but why? Anyway, no reports are going to be sent during installation of this module and its dependencies. Suggest cutting back on the deps. XIONG@cpan.org
Download (untitled) / with headers
text/plain 989b
On 2011-10-13 14:24:08, xiong wrote: Show quoted text
> Hi, > > CPAN::Reporter has way too many dependencies. Also, before any reports > can be sent, Test::Reporter::Transport::Metabase is required and that > has even more dependencies, by an order of magnitude. I'm talking about > setting up a fresh install of the perl interpreter and a clean, new > lib/. > > All the time that these dependencies are installing, warnings are > emitted from CPAN::Reporter. At the least, these should be suppressed. I > suppose I could 'o conf' cpan and disable; but why? > > Anyway, no reports are going to be sent during installation of this > module and its dependencies. Suggest cutting back on the deps.
You can avoid at least the Metabase dependencies by specifying "File" transport. This will write reports only to disk. These reports may be sent using another perl which has all Metabase dependencies installed. I can provide a script for this task and assistence, if you like. Regards, Slaven


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.