This queue is for tickets about the POE-Component-IRC CPAN distribution.

Report information
The Basics
Id:
71537
Status:
resolved
Priority:
Low/Low

People
Owner:
Nobody in particular
Requestors:
AJCT [...] cpan.org
Cc:
AdminCc:

BugTracker
Severity:
Important
Broken in:
(no value)
Fixed in:
(no value)



Subject: Two missing dependencies
I just tried to install POE::Component::IRC (well actually Bot::BasicBot::Pluggable), which in turn installed 6.72 of P::C::IRC. It failed due to a couple of missing prerequists as far as I could see: t/01_base/04_pocosi.t .............................. Can't locate POE/Component/Client/Ident/Agent.pm in @INC (@INC contains: t/inc /Users/adam/.cpan/build/POE-Component-IRC-6.72-xq_pqG/blib/lib /Users/adam/.cpan/build/POE-Component-IRC-6.72-xq_pqG/blib/arch /Users/adam/perl5/perlbrew/perls/perl-5.12.1/lib/site_perl/5.12.1/darwin-2level /Users/adam/perl5/perlbrew/perls/perl-5.12.1/lib/site_perl/5.12.1 /Users/adam/perl5/perlbrew/perls/perl-5.12.1/lib/5.12.1/darwin-2level /Users/adam/perl5/perlbrew/perls/perl-5.12.1/lib/5.12.1 .) at t/inc/POE/Component/Server/IRC/Plugin/Auth.pm line 7. And also, I think POE::Component::Client::DNS (sorry didn't keep the build log). Was fine after I installed those modules manually. Cheers, Adam
Thanks for the heads up. I have now fixed this and released a new version.


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.