Skip Menu |
 

This queue is for tickets about the CPANPLUS CPAN distribution.

Report information
The Basics
Id: 71340
Status: open
Priority: 0/
Queue: CPANPLUS

People
Owner: Nobody in particular
Requestors: terryjames9461 [...] mm.st
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: "cpanp -o" results include "Unparseable" and no version change. Look for help to understand?
Date: Thu, 29 Sep 2011 10:00:28 -0700
To: bug-cpanplus [...] rt.cpan.org
From: terryjames9461 [...] mm.st
Download (untitled) / with headers
text/plain 997b
Hello, I am working on building of a Mail Server and am including tools like Spamassassin and Subversion on the machine for use. The perl version that is installed is perl -v This is perl 5, version 12, subversion 3 (v5.12.3) built for x86_64-linux-thread-multi And I use cpanp to keep up to date many of the perl modules I installed. Right now I have this situation cpanp -o [MSG] Checking if source files are up to date [MSG] Retrieving /root/.cpanplus/sourcefiles.s2.30.c0.9111.stored 1 Unparsable Mail::SpamAssassin::Reporter KMCGRAIL 2 Unparsable 1.60 SVN::Core MSCHWERN 3 0.72 0.72 Shell FERREIRA I am told in IRC this is probably because of bugs. But I dont understand in what the bugs are? Is it Perl or CPANP or the Modules. Can you help understand whats the problem? And then I can do more work to provide more information. TJ
Subject: Re: [rt.cpan.org #71340] "cpanp -o" results include "Unparseable" and no version change. Look for help to understand?
Date: Thu, 29 Sep 2011 23:35:35 +0100
To: terryjames9461 via RT <bug-CPANPLUS [...] rt.cpan.org>
From: "Chris 'BinGOs' Williams" <chris [...] bingosnet.co.uk>
Download (untitled) / with headers
text/plain 2.5k
On Thu, Sep 29, 2011 at 01:00:39PM -0400, terryjames9461 via RT wrote: Show quoted text
> > Right now I have this situation > > cpanp -o > [MSG] Checking if source files are up to date > [MSG] Retrieving /root/.cpanplus/sourcefiles.s2.30.c0.9111.stored > 1 Unparsable Mail::SpamAssassin::Reporter > KMCGRAIL > 2 Unparsable 1.60 SVN::Core > MSCHWERN > 3 0.72 0.72 Shell > FERREIRA > > I am told in IRC this is probably because of bugs. But I dont > understand in what the bugs are? Is it Perl or CPANP or the Modules.
There are no bugs. 'Unparsable' simply means that either the particular module has no version number ( a common occurance ) or that the module had an version number that was invalid in some way ( this is less common ). Mail::SpamAssassin::Reporter has the version number 'bogus' which is invalid, therefore 'unparsable' Perhaps the version of SVN::Core you have installed doesn't have a version number. As for Shell, this a special case. In the Perl version you have, Shell is a core module, but it has been deprecated in core. This means that it has been scheduled for removal from perl as a core module at some future point ( in fact Shell was removed from core with the current development series of perl, starting with v5.15.0, and will not be present in v5.16.0 and above ). In order to facilitate this deprecation of core modules, the Perl toolchain, ie. cpan, cpanp, etc., were taught to special case deprecated core modules. I've just hunted out the discussions on the perl5-porters mailing list about this: Starting here: http://www.xray.mpe.mpg.de/mailing-lists/perl5-porters/2010-03/msg00423.html My description of CPANPLUS' behaviour is: http://www.xray.mpe.mpg.de/mailing-lists/perl5-porters/2010-03/msg00434.html Really what you are seeing, is that Shell is in the 'core' lib location and is being flagged as out of date by CPANPLUS because it is deprecated as a core module. 'Updating' Shell will install it into the 'site' lib location and you won't see this again. It seems that the deprecation warning was missing from the Shell that shipped with v5.12.3, but it is there in v5.14.0 $ /usr/home/cpan/pit/bare/perl-5.14.0/bin/perl -w -MShell -e1 Shell will be removed from the Perl core distribution in the next major release. Please install it from CPAN. It is being used at -e, line 0. I hope this explains everything. Many thanks, -- Chris Williams aka BinGOs PGP ID 0x4658671F http://www.gumbynet.org.uk ==========================
Download (untitled)
application/pgp-signature 189b

Message body not shown because it is not plain text.

Subject: Re: [rt.cpan.org #71340] "cpanp -o" results include "Unparseable" and no version change. Look for help to understand?
Date: Thu, 29 Sep 2011 16:13:53 -0700
To: "chris [...] bingosnet.co.uk via RT" <bug-CPANPLUS [...] rt.cpan.org>
From: terryjames9461 [...] mm.st
Download (untitled) / with headers
text/plain 4.3k
Hello Chris, Show quoted text
> Mail::SpamAssassin::Reporter has the version number 'bogus' which is > invalid, therefore 'unparsable'
I do not understand the 'bogus' reason. But I think you're saying that it is a Spamassassin matter. I will address it there. Show quoted text
> Perhaps the version of SVN::Core you have installed doesn't have a version > number.
module_info SVN::Core Name: SVN::Core Version: .. Directory: /usr/lib/perl5/vendor_perl/5.12.3/x86_64-linux-thread-multi File: /usr/lib/perl5/vendor_perl/5.12.3/x86_64-linux-thread-multi/SVN/Core.pm Core module: no grep -i version /usr/lib/perl5/vendor_perl/5.12.3/x86_64-linux-thread-multi/SVN/Core.pm use SVN::Base qw(Core svn_ VERSION); # Some build tool hates VERSION assign across two lines. $SVN::Core::VERSION = "$SVN::Core::VER_MAJOR.$SVN::Core::VER_MINOR.$SVN::Core::VER_MICRO"; ... module_info SVN::Base Name: SVN::Base Version: (unknown) Directory: /usr/lib/perl5/vendor_perl/5.12.3/x86_64-linux-thread-multi File: /usr/lib/perl5/vendor_perl/5.12.3/x86_64-linux-thread-multi/SVN/Base.pm Core module: no CPAN Terminal> i --force SVN::Base SVN::Core ... ==> MISMATCHED content between SIGNATURE and distribution files! <== [ERROR] Signature check failed for module 'SVN::Base' -- Not trusting this module, aborting install I do not know what Alien-SVN is. So I am troubled byt this insecurity result and will do research on it. Show quoted text
> 'Updating' Shell will install it into the 'site' lib location and you won't > see this again.
module_info Mail::SpamAssassin::Reporter SVN::Core Shell Name: Shell Version: 0.72 Directory: /usr/lib/perl5/5.12.3 File: /usr/lib/perl5/5.12.3/Shell.pm Core module: yes CPAN Terminal> o [MSG] Checking if source files are up to date [MSG] Retrieving /root/.cpanplus/sourcefiles.s2.30.c0.9111.stored 1 Unparsable Mail::SpamAssassin::Reporter KMCGRAIL 2 Unparsable 1.60 SVN::Core MSCHWERN 3 0.72 0.72 Shell FERREIRA CPAN Terminal> i 3 Installing Shell (0.72) [MSG] Trying to get 'http://ftp.osuosl.org/pub/CPAN/authors/id/F/FE/FERREIRA/CHECKSUMS' [MSG] Checksum matches for 'Shell-0.72.tar.gz' [MSG] Extracted 'Shell-0.72/' [MSG] Extracted 'Shell-0.72/t/' [MSG] Extracted 'Shell-0.72/t/99_pod.t' [MSG] Extracted 'Shell-0.72/t/01_use.t' [MSG] Extracted 'Shell-0.72/t/Shell.t' [MSG] Extracted 'Shell-0.72/MANIFEST' [MSG] Extracted 'Shell-0.72/Shell.pm' [MSG] Extracted 'Shell-0.72/Changes' [MSG] Extracted 'Shell-0.72/Makefile.PL' [MSG] Extracted 'Shell-0.72/README' [MSG] Extracted 'Shell-0.72/META.yml' [MSG] Extracted 'Shell' to '/root/.cpanplus/5.12.3/build/Shell-0.72' ==> MISSING Signature file! <== Running [/usr/bin/perl /usr/bin/cpanp-run-perl /root/.cpanplus/5.12.3/build/Shell-0.72/Makefile.PL]... Writing Makefile for Shell Writing MYMETA.yml and MYMETA.json Running [/usr/bin/make]... Skip blib/lib/Shell.pm (unchanged) Manifying blib/man3/Shell.3pm Running [/usr/bin/make test]... PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t # Testing Shell 0.72, Perl 5.012003, /usr/bin/perl t/01_use.t .. ok t/99_pod.t .. skipped: Test::Pod 1.18 required for testing POD t/Shell.t ... ok All tests successful. Files=3, Tests=8, 0 wallclock secs ( 0.01 usr 0.03 sys + 0.22 cusr 0.12 csys = 0.38 CPU) Result: PASS Running [/usr/bin/make install]... Appending installation info to /usr/lib/perl5/5.12.3/x86_64-linux-thread-multi/perllocal.pod *** Install log written to: /root/.cpanplus/install-logs/Shell-0.72-1317336445.log Module 'Shell' installed successfully No errors installing all modules CPAN Terminal> o 1 Unparsable Mail::SpamAssassin::Reporter KMCGRAIL 2 Unparsable 1.60 SVN::Core MSCHWERN 3 0.72 0.72 Shell FERREIRA CPAN Terminal> quit module_info Shell Name: Shell Version: 0.72 Directory: /usr/lib/perl5/5.12.3 File: /usr/lib/perl5/5.12.3/Shell.pm Core module: yes find /usr/lib/perl5/ | grep Shell.pm /usr/lib/perl5/5.12.3/CPANPLUS/Shell.pm /usr/lib/perl5/5.12.3/Shell.pm /usr/lib/perl5/5.12.3/CPAN/Shell.pm I do not see the module installed site_lib which I understand is what must be done to stop the upgrade message. TJ


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.