Skip Menu |
 

Preferred bug tracker

Please visit the preferred bug tracker to report your issue.

This queue is for tickets about the YAML CPAN distribution.

Report information
The Basics
Id: 71322
Status: open
Priority: 0/
Queue: YAML

People
Owner: Nobody in particular
Requestors: RWSTAUNER [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: 0.76
Fixed in: (no value)



Subject: YAML::Any hard to find/install? cpan client confused
I am very confused here, and wanted to let you know what I was experiencing (and was curious if you had received any other reports)... I tried installing Catalyst and noticed that one of it's tests failed and included YAML something in the output (sorry, I don't have that on my screen any more). So I went to make sure I had all of the YAML modules up to date... The `cpan` client doesn't seem to be able to find YAML::Any even though it is listed in the 02packages.details.txt.gz file. Weird. It happens to show the 0.73 release as the dist it's in... so I'm not sure if the PAUSE indexer doesn't record modules that used to have a VERSION and don't any more? Regardless of that I am not sure why CPAN.pm can't find it. cpanminus does find the module in the module, but installs the 0.73 dist instead of the current 0.76 (since that's the one listed). Both metacpan and s.c.o. both show YAML-0.76 when searching for YAML::Any, which confuses me even more... So in the end I do have both YAML (0.76) and YAML::Any (undef) installed (as well as YAML::XS and YAML::Tiny)... and now the Catalyst test passes. /me shrugs
Download (untitled) / with headers
text/plain 156b
Turns out this may be a bug in CPAN::SQLite... that db only seems to index YAML, Test::YAML, and YAML::Mo. https://rt.cpan.org/Ticket/Display.html?id=71323


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.