Skip Menu |
 

This queue is for tickets about the File-Slurp CPAN distribution.

Report information
The Basics
Id: 71207
Status: open
Priority: 0/
Queue: File-Slurp

People
Owner: Nobody in particular
Requestors: rkitover [...] prismnet.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: throws warning on perl 5.10.0
Date: Sat, 24 Sep 2011 16:17:58 -0400
To: bug-File-Slurp [...] rt.cpan.org
From: Rafael Kitover <rkitover [...] prismnet.com>
Download (untitled) / with headers
text/plain 227b
% perl -w -MFile::Slurp -le 1 v-string in use/require non-portable at /home/rkitover/perl5/perlbrew/perls/perl-5.10.0/lib/site_perl/5.10.0/File/Slurp.pm line 3. This can be fixed by changing the "use 5.6.2;" to "use 5.006002;"
Download (untitled) / with headers
text/plain 477b
On Sat Sep 24 15:18:11 2011, rkitover@prismnet.com wrote: Show quoted text
> % perl -w -MFile::Slurp -le 1 > v-string in use/require non-portable at > /home/rkitover/perl5/perlbrew/perls/perl- > 5.10.0/lib/site_perl/5.10.0/File/Slurp.pm line 3. > > This can be fixed by changing the "use 5.6.2;" to "use 5.006002;"
This issue is causing test failures in other distributions that have their own warnings tests. E.g., http://www.cpantesters.org/cpan/report/db7c04c2-407c-11e1-9d6f-f6dbfa7543f5


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.