Skip Menu |
 

This queue is for tickets about the CPAN CPAN distribution.

Report information
The Basics
Id: 70155
Status: open
Priority: 0/
Queue: CPAN

People
Owner: Nobody in particular
Requestors: zefram [...] fysh.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: undeclared dep on CPAN::Meta
Date: Tue, 9 Aug 2011 09:33:32 +0100
To: bug-CPAN [...] rt.cpan.org
From: Zefram <zefram [...] fysh.org>
Download (untitled) / with headers
text/plain 869b
On one machine which isn't kept very up to date, I got this test failure when trying to install CPAN-1.9800: t/31sessions.t ......... ok # Failed test (t/41distribution.t at line 151) # got: '' # expected: 'HASH' # Failed test (t/41distribution.t at line 161) # Failed test (t/41distribution.t at line 151) # got: '' # expected: 'HASH' # Failed test (t/41distribution.t at line 161) # Looks like you failed 4 tests of 19. t/41distribution.t ..... Dubious, test returned 4 (wstat 1024, 0x400) Failed 4/19 subtests That's getting undef instead of an expected hash from attempting to read a distribution's YAML metadata. Installing CPAN::Meta fixed it. Presumably CPAN has an undeclared dependency on either CPAN::Meta or one of its dependencies, or perhaps on a sufficiently-recent version of one of those modules. -zefram
Subject: Re: [rt.cpan.org #70155] undeclared dep on CPAN::Meta
Date: Tue, 9 Aug 2011 06:41:10 -0400
To: bug-CPAN [...] rt.cpan.org
From: David Golden <dagolden [...] cpan.org>
Download (untitled) / with headers
text/plain 263b
On Tue, Aug 9, 2011 at 4:33 AM, Zefram via RT <bug-CPAN@rt.cpan.org> wrote: Show quoted text
> On one machine which isn't kept very up to date, I got this test failure > when trying to install CPAN-1.9800:
perl -v? My guess would be it's related to Parse::CPAN::Meta. -- David
Subject: Re: [rt.cpan.org #70155] undeclared dep on CPAN::Meta
Date: Tue, 9 Aug 2011 11:49:34 +0100
To: David Golden via RT <bug-CPAN [...] rt.cpan.org>
From: Zefram <zefram [...] fysh.org>
Download (untitled) / with headers
text/plain 440b
David Golden via RT wrote: Show quoted text
>perl -v?
This is perl, v5.8.8 built for i386-linux-thread-multi It's a Fedora build. Ancient, I know. We ought to be decommissioning it in a couple of weeks. Show quoted text
>My guess would be it's related to Parse::CPAN::Meta.
Looks likely. CPAN declares dependency on P:C:M, but without a version number. CPAN::Meta declares dependency on P:C:M 1.4400, and installing C:M caused installation of P:C:M 1.4401. -zefram


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.