Skip Menu |
 

This queue is for tickets about the Dist-Metadata CPAN distribution.

Report information
The Basics
Id: 69961
Status: resolved
Worked: 10 min
Priority: 0/
Queue: Dist-Metadata

People
Owner: Nobody in particular
Requestors: MELEZHIK [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Important
Broken in: 0.913
Fixed in: (no value)



Download (untitled) / with headers
text/plain 3.7k
tests fail, see file attached --- environment: perl -V Summary of my perl5 (revision 5 version 8 subversion 8) configuration: Platform: osname=linux, osvers=2.6.36.2-calculate, archname=x86_64-linux uname='linux melezhik-vb 2.6.36.2-calculate #1 smp preempt thu dec 30 09:23:52 local time zone must be set-- x86_64 amd athlon(tm) 64 x2 dual core processor 3600+ authenticamd gnulinux ' config_args='-des -Darchname=x86_64-linux -Dcccdlflags=-fPIC - Dccdlflags=-rdynamic -Dcc=x86_64-pc-linux-gnu-gcc -Dprefix=/usr - Dvendorprefix=/usr -Dsiteprefix=/usr -Dlocincpth= -Doptimize=-O2 - march=x86-64 -pipe -Duselargefiles -Dd_semctl_semun -Dscriptdir=/usr/ bin -Dman1dir=/usr/share/man/man1 -Dman3dir=/usr/share/man/man3 - Dinstallman1dir=/usr/share/man/man1 -Dinstallman3dir=/usr/share/man/ man3 -Dman1ext=1 -Dman3ext=3pm -Dinc_version_list=5.8.0 5.8.0/x86_64- linux 5.8.2 5.8.2/x86_64-linux 5.8.4 5.8.4/x86_64-linux 5.8.5 5.8.5/ x86_64-linux 5.8.6 5.8.6/x86_64-linux 5.8.7 5.8.7/x86_64-linux - Dcf_by=Gentoo -Ud_csh -Dusenm -Di_ndbm -Di_gdbm -Di_db -Dlibpth=/usr/ local/lib64 /lib64 /usr/ lib64' hint=recommended, useposix=true, d_sigaction=define usethreads=undef use5005threads=undef useithreads=undef usemultiplicity=undef useperlio=define d_sfio=undef uselargefiles=define usesocks=undef use64bitint=define use64bitall=define uselongdouble=undef usemymalloc=n, bincompat5005=undef Compiler: cc='x86_64-pc-linux-gnu-gcc', ccflags ='-fno-strict-aliasing -pipe - Wdeclaration-after-statement -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I/usr/include/gdbm', optimize='-O2 -march=x86-64 -pipe', cppflags='-fno-strict-aliasing -pipe -Wdeclaration-after-statement - I/usr/include/gdbm' ccversion='', gccversion='4.4.4', gccosandvers='' intsize=4, longsize=8, ptrsize=8, doublesize=8, byteorder=12345678 d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=16 ivtype='long', ivsize=8, nvtype='double', nvsize=8, Off_t='off_t', lseeksize=8 alignbytes=8, prototype=define Linker and Libraries: ld='x86_64-pc-linux-gnu-gcc -O2 -march=x86-64 -pipe', ldflags =' -L/ usr/local/lib64' libpth=/usr/local/lib64 /lib64 /usr/lib64 libs=-lpthread -lnsl -lgdbm -ldb -ldl -lm -lcrypt -lutil -lc perllibs=-lpthread -lnsl -ldl -lm -lcrypt -lutil -lc libc=/lib/libc-2.11.2.so, so=so, useshrplib=false, libperl=libperl.a gnulibc_version='2.11.2' Dynamic Linking: dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags='-rdynamic' cccdlflags='-fPIC', lddlflags='-shared -L/usr/local/lib64' Characteristics of this binary (from libperl): Compile-time options: PERL_MALLOC_WRAP USE_64_BIT_ALL USE_64_BIT_INT USE_LARGE_FILES USE_PERLIO Built under linux Compiled at Aug 2 2011 13:51:28 %ENV: PERL5LIB="/usr/local/rle/lib/perl/" @INC: /usr/local/rle/lib/perl/ /etc/perl /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux /usr/lib64/perl5/vendor_perl/5.8.8 /usr/lib64/perl5/vendor_perl /usr/lib64/perl5/site_perl/5.8.8/x86_64-linux /usr/lib64/perl5/site_perl/5.8.8 /usr/lib64/perl5/site_perl /usr/lib64/perl5/5.8.8/x86_64-linux /usr/lib64/perl5/5.8.8 /usr/local/lib/site_perl
Subject: logg.txt
Download logg.txt
text/plain 160.5k

Message body is not shown because it is too large.

Download (untitled) / with headers
text/plain 304b
Втр Авг 02 07:25:29 2011, MELEZHIK писал: Show quoted text
> tests fail, see file attached > ---
bug has gone when I upgraded File::Path to 2.8 (I started with pure virtual box and so had very old version of File::Path), I guess you need to require high version of File::Path in modules' prerequisites.
Subject: Failures with older versions of File::Path
Download (untitled) / with headers
text/plain 990b
Thanks for reporting! Turns out there was also a smoke report for this same bug that I hadn't addressed yet. File::Path was originally a core-only module so I wanted to use the legacy interface so it would work with older perls. The problem is that I was passing a Path::Class object to mkpath() without stringifying it first and File::Path 1.08 assumes any reference passed to mkpath() is an array ref. It turns out Path::Class already has a wrapper method to do the stringification so I was able to make this work with older versions of File::Path by removing code. Always a plus! New version has been uploaded. Thanks again. On Tue Aug 02 04:35:00 2011, MELEZHIK wrote: Show quoted text
> Втр Авг 02 07:25:29 2011, MELEZHIK писал:
> > tests fail, see file attached > > ---
> bug has gone when I upgraded File::Path to 2.8 (I started with pure > virtual box and so had very old version of File::Path), I guess you need > to require high version of File::Path in modules' prerequisites.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.